Dithering option seems to be working in the opposite way.

New Here ,
May 21, 2021 May 21, 2021

Copy link to clipboard

Copied

Hi there,

Tried both dithering options (i.e. with "Enabled" and "Disabled") through
File > Save As > Convert Sample Type > Bit Depth > Advanced > Dithering.
But the saved output file with the 'Dithering' option looks like working in the opposite way (i.e. dithering is disabled when "Enabled" is selected and vice versa).
Notice that I’m currently using Adobe Audition ‘Build 14.2.0.34’ (the previous versions look the same though) and tried 48KHz/16-bit generated tone with extremely small gain (-90 dB) just to see the effects of dithering more clearly.
Additionally,
Close/Reopen the file is required to check out the changes only when Dithering is “Disabled” (but actually dithered). No need to reopen it if “Enabled”.
And the last setting is gone (indicating "Disabled" always) when I revisit the menu again (just to make sure which option I've selected, right before saving it finally) which is not pretty intuitive and confusing.
Hope the GUI get revised, if applicable.

 

Thanks,
HP Lee

TOPICS
Feature requests , How to , User interface or workspaces

Views

227

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 21, 2021 May 21, 2021

Copy link to clipboard

Copied

I don't think it's anything like as simple as that, I'm afraid and there are some background conditions that you need to be aware of. The most important one is that tone is generated as 32-bit FP dithered whatever you've got the file set to. This was best explained by one of the developers in this thread (just ignore the background griping and read the answer marked as correct). Nevertheless I think that the 'save' bug he mentioned is still present...

 

I will try at some stage to see if we can get this looked at again, because I don't think it's particularly helpful the way it works at present; it needs to be clearer, at least. I strongly suspect though that it will become a 'back burner' issue...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 21, 2021 May 21, 2021

Copy link to clipboard

Copied

Hi SteveG,

 

Actually, I did recognize the thread you mentioned before posting my query here to wider experts. 🙂

Notice that "extremely small gain (-90 dB)" is actually coming from there. But looks to me still not working as it says (but in the opposite way). 

 

"I think what you're looking for is to get a signal that is quantized to 16-bit or 24-bit PCM without dither.  I tried this out a few ways, and I think I came across what I would agree with is a bug. Nonetheless, you can accomplish what you want. Here's the two paths where I think it makes a difference:

 

(A) Create a new file, but choose the bit depth to be 16-bit. What this does is automatically choose "16-bit" when you do File > Save, for the data type of the file, but also shows you 16-bit-quantized sample values in the vertical ruler (shown above). When you then Generate Tones, the signal will always be generated with 32-bit floats (we don't know what the user will save as later or what sort of processing they want to do, so we choose the highest precision we have).  Upon saving, or even File > Save As... and checking that dither was disabled, I noticed that the resulting file still seemed to be  dithered. I would consider this a bug when doing File > Save As... and explicitly checking that dither was disabled.

 

(B) Instead of creating a new file labeled 16-bit, just choose 32-bit Float (I agree that this is non-intuitive). Then save as you wish (or use Convert Sample Type) and ensure in either case that dither is disabled. In this workflow, we honor the no-dither setting and I end up with 16-bit quantized sample values when I generate a 440 Hz sine wave at -90.308998699194359 dBFS (about 15-bits of precision). I end up with what I think you're going for."

 

Thanks,

HP Lee

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

Just to be clear, see below screenshots why I reached to conclusion that it's working in the opposite way.

Dithering Enabled (@ Audition)

Dithering Disabled (@ Audition)

HP5DDA_0-1622118156326.pngHP5DDA_1-1622118156329.png

 

Notice that Y-axis in ‘sample value’.

 

Thanks,

HP Lee

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 23, 2021 Aug 23, 2021

Copy link to clipboard

Copied

I've tried reproducing this, but have not been able to do so.  To ensure I'm following along correctly, here are my precise reproduction steps:

  1. File > New Audio File > 48K Mono
  2. Generate > Tones.  First set Default preset, adjust first tone value to 1000 Hz, click OK
  3. Grab HUD and type -90dB to reduce the gain.
  4. File > Export > File.  Change bit rate to 16-bit and select "Disabled" for Dithering.
  5. File > Export > File.  Change bit rate to 16-bit and select "Enabled" for Dithering.  Leave all settings at default
  6. Open the Disabled and Enabled files, Zoom amplitude about as far as it goes, and zoom in on first portion of timline

 

 

Disabled: Shows samples at 0.  Reducing bit rate with such a low signal level appears to have fallen below the minimum values for 16-bit audio:

image (7).png

 

 

Dithering enabled:

Random dithering noise added to signal, just slightly above minimum sample bit rate represented with 16-bit.
image (6).png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 23, 2021 Aug 23, 2021

Copy link to clipboard

Copied

I missed that you were STARTING with a 16-bit source, and while I'm not entirely clear, it's possible that there's a logic issue when converting 16-bit to 16-bit?  At levels that low, 16-bit may already not adequately store the audio data.  We're digging into it further...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 23, 2021 Aug 23, 2021

Copy link to clipboard

Copied

LATEST

Thanks a lot for the update. Good to hear that we're on the same page eventually.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines