• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
5

P: X-T2 Fuji Files have small purple artifact at edge of image after Denoise

Participant ,
Jun 17, 2023 Jun 17, 2023

Copy link to clipboard

Copied

Hint: Originally I posted at the wrong forum part (Camera Raw) and therefore my post got lost (I think).

The symptoms are purple lines on the AI improved DNG files in lets say each 10th processed *.dng file. In the link at the end of this text you will find 3 files:

  1. _DSF2201.dng
  2. _DSF2201-Enhanced-NR.dng and
  3. LrC_12.4_2023-06-15.png

1. is a *.raf file which got converted to *.dng. (I do this with all my Fujifilm RAW files.)

2. is the AI enhanced / processed file with purple line at the top edge as well as the right edge. Default settings used at enhancement.

3. is my LrC system information.

LrC is running on Win 10 V22H2, on two (very) different machines. Both show the same purple line artifacts.

The fix made at LrC 12.4 may help for the original provided X-H1 *.raf files (from user Japhotofin) but not for my files. Can someone confirm my finding? Thank you!

AI Noise reduction bug, Fujifilm X-T2 

Bug Fixed
TOPICS
macOS , Windows

Views

1.3K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Pinned Reply

Adobe Employee , Jun 19, 2023 Jun 19, 2023

Adding bug number 

Status Investigating

Votes

Translate

Translate
29 Comments
LEGEND ,
Jun 19, 2023 Jun 19, 2023

Copy link to clipboard

Copied

[This post contains formatting and embedded images that don't appear in email. View the post in your Web browser.]

 

@Rikk Flohr: Photography, please consider moving to Bugs. Using the sample file provided, I see the same purple borders on the enhanced DNG (LR 12.4 / Mac OS 13.4):

 

johnrellis_0-1687159379115.png

 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jun 19, 2023 Jun 19, 2023

Copy link to clipboard

Copied

Adding bug number 

Rikk Flohr - Customer Advocacy: Adobe Photography Products
Status Investigating

Votes

Translate

Translate

Report

Report
Participant ,
Jun 19, 2023 Jun 19, 2023

Copy link to clipboard

Copied

@Rikk Flohr: Photography  1) Why is my post now at "Camera Raw" instead of  "Lightroom Classic"? The AI denoise tool is a part of LrC, isn't it?

2) You have changed my title "AI Noise reduction for Fujifilm DNG files produces purple lines also in LrC 12.4 (June 2023)" which was aligned with the title of the source post P: AI Noise reduction for Fuji X-H1 files produces purple lines on edges . Your new title hides the relation and implies that it is only an X-T2 bug. I expect that all Fujifilm X-Trans RAW files are problematic for the AI denoise, i.e. not only X-H1 and X-T2. (I will try to proof this if I have time in the next days.)

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jun 19, 2023 Jun 19, 2023

Copy link to clipboard

Copied

The failure is in the Camera Raw engine and fails across all clients ACR/LrD and LrC. It belongs in Camera Raw as they have to fix it for all the clients.

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Participant ,
Jun 19, 2023 Jun 19, 2023

Copy link to clipboard

Copied

From my previous post: 

"I expect that all Fujifilm X-Trans RAW files are problematic for the AI denoise, i.e. not only X-H1 and X-T2. (I will try to proof this if I have time in the next days.)"

This is already proofed in the source post! There are the following camera models mentioned X-Pro 2, X-PRO 3, X100F and may be some more. I have not read the entire source thread.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jun 19, 2023 Jun 19, 2023

Copy link to clipboard

Copied

"I have not read the entire source thread."

 

Please read the entire source post. It was fixed in 15.3.1 in Camera Raw and in 6.4 and 12.4 in Lightroom Desktop and Classic respectively. 

The fix was confirmed on 5.19 by an afflicted customer. 

If you find that other cameras are affected, the title can be changed. 

 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Participant ,
Jun 19, 2023 Jun 19, 2023

Copy link to clipboard

Copied

"It was fixed in 15.3.1 in Camera Raw ..."

Yes but it was fixed only for the X-H1 camera model but this is only one out of n models which often have different X-Trans Sensors. In the source thread there are several users which reported the same bug but on different cameras with different sensors (I already mentioned 3 of them). I guess that Adobe AI denoise needs a fix for each of the X-Trans sensors. By the way my camera model X-T2 is also there and as you now know the problem is not fixed.

I will try to get some light into the shade and asking therefore the prevoius discussion attendees:

@kernpanik is your X-T2 problem gone and happened it with RAF raw source files?

@saintleger is your X-Pro 2 problem gone and happened it with RAF raw source files?

@Debruineogenboy is your X100F problem gone and happened it with RAF raw source files?

@SoylentYellow is your X100F problem gone and happened it with RAF raw source files?

@Ory217759190xsq is your X-T20 problem gone and happened it with RAF raw source files?

@martat14582229 is your X-Pro 3 problem gone and happened it with RAF raw source files?

If all of them are happy now it would mean that not the X-Trans sensor is the culprit but may be my *.raf to *.dng conversion at photo import to LrC. Hopefully at least some will answer my question...

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jun 19, 2023 Jun 19, 2023

Copy link to clipboard

Copied

quote

@kernpanik is your X-T2 problem gone?

 

Yes, it's fixed for me. 

Votes

Translate

Translate

Report

Report
Participant ,
Jun 19, 2023 Jun 19, 2023

Copy link to clipboard

Copied

@johnrellis Thanks a lot for your test of my reported problem.

Votes

Translate

Translate

Report

Report
Participant ,
Jun 19, 2023 Jun 19, 2023

Copy link to clipboard

Copied

@kernpanik Do you use RAF or DNG raw files?

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jun 19, 2023 Jun 19, 2023

Copy link to clipboard

Copied

quote

@kernpanik Do you use RAF or DNG raw files?

 

I use RAF files.

 

A conversion to DNG takes place at the end of the AI denoise process, when the de-noised image is saved as a new DNG file.

Votes

Translate

Translate

Report

Report
Participant ,
Jun 19, 2023 Jun 19, 2023

Copy link to clipboard

Copied

quote

I use RAF files.

Thank you kernpanik. This points to my source file type suspicion. I cannot proof it, I do not keep the original *.raf files.

Votes

Translate

Translate

Report

Report
New Here ,
Jun 20, 2023 Jun 20, 2023

Copy link to clipboard

Copied

@.Michael. 

 

Hi Michael, tested 2 photos, seems that the problem is gone...thanks for taking care for it.

Ory

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jun 20, 2023 Jun 20, 2023

Copy link to clipboard

Copied

Yes it is! Than ks for the fix.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jun 20, 2023 Jun 20, 2023

Copy link to clipboard

Copied

quote

@SoylentYellow is your X100F problem gone and happened it with RAF raw source files?

 

Yes and Yes. Conversion works great now, and I was indeed working from the RAF file, I do not convert to DNG.

Votes

Translate

Translate

Report

Report
Participant ,
Jun 21, 2023 Jun 21, 2023

Copy link to clipboard

Copied

Thank you Ory217759190xsq and SoylentYellow for your answers. 

Now with the 2nd reply which is telling not using DNG files the chance is again increased that the AI Noise reduction is only for Fujifilm DNG files not working (but for the original RAF files it is since LrC V12.4 OK).

Votes

Translate

Translate

Report

Report
Explorer ,
Jun 29, 2023 Jun 29, 2023

Copy link to clipboard

Copied

Hi @.Michael. 
All good for me. Seems to be fixed!

Votes

Translate

Translate

Report

Report
Participant ,
Aug 24, 2023 Aug 24, 2023

Copy link to clipboard

Copied

LrC 12.5: After more than 2 months no fix provided 😞 but for Sony ILCE-7R there was a fix (link).

Votes

Translate

Translate

Report

Report
Participant ,
Oct 20, 2023 Oct 20, 2023

Copy link to clipboard

Copied

LrC 13.01: After approx. 5 months again no fix provided 😞

P.S. The now produced file size is 26.834 kBytes vs. before 67.915 kBytes. The new introduced JEPG XL compression works well.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Dec 23, 2023 Dec 23, 2023

Copy link to clipboard

Copied

Hi all, yesterday I updated LrC and Camera raw and then used the denoise tool and it generated purple two purple lines one at the very edge and one few pixels away. I use Canon R8 generating CR3 raw files and the result from denoise is DNG file. The issue is not totally resolved

Votes

Translate

Translate

Report

Report
Participant ,
Dec 23, 2023 Dec 23, 2023

Copy link to clipboard

Copied

@ahmadoooo As Adobe seems to release camera specific bug fixes I recommend you release a Canon specific bug report.

Votes

Translate

Translate

Report

Report
Participant ,
Dec 23, 2023 Dec 23, 2023

Copy link to clipboard

Copied

LrC 13.1: Since June 2023 (i.e. LrC 12.4) no fix provided!

Votes

Translate

Translate

Report

Report
Participant ,
Dec 23, 2023 Dec 23, 2023

Copy link to clipboard

Copied

@Calicaruso Thanks for your upvotes, I guess you know that the initial post of a thread needs it most, i.e. only this makes it (the problem) better visible to those who take care of it.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Dec 24, 2023 Dec 24, 2023

Copy link to clipboard

Copied

Thank you. I will look into it

Votes

Translate

Translate

Report

Report
Participant ,
Mar 03, 2024 Mar 03, 2024

Copy link to clipboard

Copied

LrC 13.2: Since June 2023 (i.e. LrC 12.4) no fix provided!

Votes

Translate

Translate

Report

Report