• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Captivate 8 scalable content max height/width

New Here ,
Sep 21, 2014 Sep 21, 2014

Copy link to clipboard

Copied

Hello,

I'm using Captivate 8 and using the scalable settings, however I only want the screen to downscale from set screen size as when the screen is enlarged past it's original size everything gets really blurry. Is there anyway to set a maximum height or width within captivate or by changing the code in css/js/html files?

Help is much appreciated! Thanks

Views

1.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 25, 2014 Sep 25, 2014

Copy link to clipboard

Copied

Hi,

I ran across thesame issue, I'm using Cp6, and found the solution in modifying /assets/js/CPLibrary.js file in following way:

Line 23528 there is following function:

function SetScaleAndPosition()

Line 23576 there is following condition:

  if(cp.verbose)

  {

  cp.log(cp.model.data.project.shc);

  cp.log(cp.movie.m_scaleFactor);

  cp.log(cp.shouldScale);

  }

Prior to that condition from line 23576, I placed this code:

  if( (cp.movie.m_scaleFactor >= 1.0))

  return true;

This limits scaling to 100% only, or lower.

However, when using scalable html5 content in Cp6, I encountered problems with smart shapes buttons (they do not work), so, if what is above works for You, I would appreciate, if You could inform me, if, in Cp8, there is no problem with smart shapes buttons when using scalable html5, thanks in advance.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 25, 2014 Sep 25, 2014

Copy link to clipboard

Copied

I think your problem could stem from the fact that CP still thinks it should scale. The smart objects are canvas elements that have different scale formulas and are based on the shouldScale variable and the scaleFactor which is constantly updated. Where you placed your code, it may not get called all of the time. The following will stop scaling on desktops or laptops but will allow scaling on all other devices:

Find the line:

cp.shouldScale = cp.D.project.shc;

Replace with:

if (isMobile)

{

     cp.shouldScale= cp.D.project.shc;

}

else

{

     cp.shouldScale= false;

}

Then add a mobile detection script in the head of the index.htm:

<script>

if( /Android|webOS|iPhone|iPad|iPod|BlackBerry|IEMobile|Opera Mini/i.test(navigator.userAgent) )
{
  var isMobile = true;
}
else
{
var isMobile = false;
}

</script>

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 17, 2017 Feb 17, 2017

Copy link to clipboard

Copied

Hi there,

I have a non responsive Captivate 9 project with only html5 output with scaling enable.

I would like to limit the scaling to the project's size (1280px).

Adding max-width to the css doesn't seem to work.

My guess is to look into the SetScaleAndPosition function of /assets/js/CPM.js line 1139

As piasek123456​ suggested, the idea is to limit scaleFactor to 1.0.

Could someone please help me to make the right change in the js code ?

Thanks
Phil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 17, 2017 Feb 17, 2017

Copy link to clipboard

Copied

Hi Phil,

I don't know if this will help or not, but when I was working on a project a while ago we fixed this problem by restricting the height, which by default restricted the width. I think I was using cp8 at the time so not 100% sure it will work but might be worth a try!

Open your captivate.css file and then underneath - text-align:centre; - just add in:

max-height:627px

Obviously change the pixels for whatever suits you! This might work as we found the project size was only restricted when using height rather than width. I'm afraid if this doesn't work then I don't know how to fix it!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 27, 2017 Sep 27, 2017

Copy link to clipboard

Copied

LATEST

Hi,

that max-height:627px solution sounds pretty simple.

Is there anybody who can describe such a solution for captivate 2017? I found solutions that only works on mobile but not on desktops.

By the way, for me it is unbelievable, that so many people are looking for solution for non-responsive-projects where the scaling only works downward and Adobe is not able to provide it.

regards

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines