Video using web object option not publishing

Participant ,
Apr 12, 2016 Apr 12, 2016

Copy link to clipboard

Copied

Video using web object option not publishing as

I am having a couple of issues going on with web object inserted into a slide on a blank project.

I am setting up a training module that links to another company’s updated training video on their software update we are about to implement. They utilized captivate 7 to create a .swf module. Unfortunately I only have access to the .swf output file via direct web link and not access to the captivate project file.

My problems are:

  1. When I open the project in captivate 9.0.1.320 the web object video automatically starts playing in the background the moment I navigate to that page.
    1. I have experienced this issue before and had even uninstalled and reinstalled captivate to try remedy this issue to make sure it was not a bad install.
    2. I also tried recreating the project from scratch and in both cases the web object auto plays when the project is opened. Even when I navigate to other pages the audio file keep playing in the background of the project only stopping when I close down captivate completely or when the swf object has finished (9.5 minutes long).
    3. As a side note I have other modules that experience the same issue with the web object streaming a video/audio file in the background as I work on other slides in the project but they have all exported the project fine and have no issues uploading the content to our lms etc.
    4. I have also cleared out the project cache files and restarted the pc and these had no effect on the outcome.


2. When I preview the module locally in browser the module works correctly, the web object auto loads the web link containing the .swf page. The moment I try and publish the project the web object does not get exported with the page and all I get is my blank background

a. If I preview the project in my browser the web object loads up correctly.

preview browser.PNG

b. When I select preview project option my web object page does not load correctly and only displays the background slide.

preview project.PNG


c. When I publish the project my web object page (page 2 of the module) does not load correctly and only displays the background slide.

project output.PNG

3. My project settings are as follows (see image below). I have tried outputting the project as swf, swf/html5 and html5

publish setting.PNG

I did find that when testing the output in html5 IE9 did not load the web object but Chrome and Firefox allowed the web object to load. Unfortunately IE 9 has to be my test base for IE browser as that is what the majority of users will be using.

Does anyone have any idea how to stop the audio running in the background when working on a web object inserted video etc and is anyone familiar with what could be causing the project to not publish correctly?

P.S This is what the object looks like on the slide in captivate.

in slide.PNG

Views

5.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Apr 13, 2016 Apr 13, 2016
Your issue with the SWF content not playing locally could be related to Flash Global Security.  Did you set the publish output folder as a trusted location in the Flash Global Security settings for the Flash Player in your browser?

Likes

Translate

Translate
Adobe Employee ,
Apr 13, 2016 Apr 13, 2016

Copy link to clipboard

Copied

Hi,

As for the audio running in the background during edit area, this is a known issue which occurs when your video is set to Autoplay. If you set the URL to not Auto Play then that should solve your issue.

During publish, are you hosting your project on a server to test? A Web object requires a web server to function correctly (which is why you wont see it play in the Captivate inbuilt Preview player).

Thanks,
Mohana

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 13, 2016 Apr 13, 2016

Copy link to clipboard

Copied

Thanks Mohana,

1. Unfortunately I did try taking off the autoplay option but it still seems to pull in the video and starts playing it. Just to be sure I went back into the project and unchecked the autoplay option, saved it and restarted captivate. The the audio still auto starts and plays in the background. (see shot below for settings)

web object setting.PNG

2. The project works fine in the inbuilt preview player it only will not work when I publish the project to my local machine.

3. Could you also explain to me why the html5 option works fine but the swf version will not display when I publish my project to my local machine. By the looks of the output file it seems like the web object is not even being written to the slide or the output .pdf.

I can send you a copy of the .pdf version or a zipped version of the project if you need to see what I mean.

4. I think I also failed to mention I am running the 64bit version of Captivate 9.

I appreciate you taking the time to respond.

Wayne

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 13, 2016 Apr 13, 2016

Copy link to clipboard

Copied

Your issue with the SWF content not playing locally could be related to Flash Global Security.  Did you set the publish output folder as a trusted location in the Flash Global Security settings for the Flash Player in your browser?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 13, 2016 Apr 13, 2016

Copy link to clipboard

Copied

Thanks Rod that solved the web object playing in ie with the swf option. It still will not work with firefox or chrome but that is not as crucial.
Would you know why it would affect the pdf output option (not essential for the moment more of a curiosity question)?

I uploaded the content to our lms web server and it opens up fine from there there now.

Thanks again for the help.

Wayne

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 13, 2016 Apr 13, 2016

Copy link to clipboard

Copied

Sorry.  This is a long thread.  Can you explain specifically what the PDF issue is again?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 29, 2016 Apr 29, 2016

Copy link to clipboard

Copied

LATEST

Rod I think you hit the nail on the head with it being the Flash Global Security settings affecting the pdf version as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 13, 2016 Apr 13, 2016

Copy link to clipboard

Copied

Hi Wayne,

A web object requires a web server to function properly, hence it may not work in PDF export. Is it working when you upload it to an LMS?

Also, the "AutoLoad" option is for your Web Object to auto play or not, not the video inside it. Looks like the SWF which you are linking to was published with Auto Play enabled. You may need to make changes to the SWF module to resolve the issue.

Thanks,

Mohana

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines