Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Button

New Here ,
Feb 23, 2017 Feb 23, 2017

Copy link to clipboard

Copied

Hi.. I'm new to cold fusion and still in process of the learning cold fusion.

I have a problem in create a button for update..i've use all kind of tag such us <a>, <input> and <button> but still it didn't work..

this is the result when i run the coding..anyone have a solution?

1.PNG

Views

589

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Feb 24, 2017 Feb 24, 2017

Copy link to clipboard

Copied

What is the actual code? What ever the content is you are entering here is just a string not HTML.

Without seeing how you are producing this though or what the code is, its impossible to tell. Could just simply be malformed HTML in the rest of it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 26, 2017 Feb 26, 2017

Copy link to clipboard

Copied

3.PNG

this is my code..if i remove the tag output the result is still the same..

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 27, 2017 Feb 27, 2017

Copy link to clipboard

Copied

Try this instead of <button...

<input type="Submit" name="Submit" value="Pilih " />

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Feb 28, 2017 Feb 28, 2017

Copy link to clipboard

Copied

Are you using another library on the table. I notice you have sorting etc, this library you are using might be stopping the cells from using html.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 28, 2017 Feb 28, 2017

Copy link to clipboard

Copied

i have attribute data-toggle for my table..that's why the result is like that..if i remove the attributes the button will be there..but can i still have the attributes and make the button there?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Mar 01, 2017 Mar 01, 2017

Copy link to clipboard

Copied

The question still stands, which third party library are you using?? You must be using another javascript plugin to make the table do this. What ever it is, is making the cells force to a string so that they can be correctly sorted. This is probably explained in the documentation of the plugin you are using.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 01, 2017 Mar 01, 2017

Copy link to clipboard

Copied

LATEST

One thing that I would suggest is to apply a class name to the TDs that you want that third party plugin to 'convert', then use JavaScript to apply the plugin only to those TDs, leaving the TD containing the button alone.

This is, of course, me assuming that you are currently applying the plugin to all TDs.  If this is not the case, then we need more information.  Like (as haxtbh​ pointed out) what third party library or plugin you're using.

V/r,

^_^

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 28, 2017 Feb 28, 2017

Copy link to clipboard

Copied

Is the HTML hard-coded by you?  As haxtbh​ pointed out, there could be a JavaScript library that is affecting the TDs.  Since the code is hard-coded and not pulled from a third source, I feel like this is being affected by something else.  If you "View Source" the section where the button is supposed to be, does the TD value start with &lt; or other encoded representation for '<'?

HTH,

^_^

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines