Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Coldfusion 10 will not start

Explorer ,
Jul 17, 2013 Jul 17, 2013

Copy link to clipboard

Copied

I am running CF 10 on Redhat Linux 6 and everything was working fine until recently, but now I cannot get CF to start up.  I had created a datasource to connect to a unidata database and it was not working, so I needed a newer version of the database driver.  I got the new version of the driver (the 2 files needed for the driver are unijdbc.jar and asjava.zip).  I placed the files in the location where I've always placed them while using CF 8:

/opt/coldfusion10/cfusion/wwwroot/WEB-INF/classes/unijdbc.jar,/opt/coldfusion10/cfusion/wwwroot/WEB-INF/classes/asjava.zip,"%CLASSPATH%"

and set the class path in the CF Administrator accordingly, then stopped and started CF, and it came up fine, but the datasource to unidata would not verify (see my other recent forum post) -- in reply to that post, someone had recommended I put the drivers in a different location, so I did that, and set the classpath accordingly:

/opt/coldfusion10/cfusion/runtime/lib/unijdbc.jar,/opt/coldfusion10/cfusion/runtime/lib/asjava.zip,"%CLASSPATH%"

then stopped and started CF, and it came up without problem, but datasource still would not connect. 

So, I made one more change to the classpath and took the "" off the end so it looks like this:

/opt/coldfusion10/cfusion/runtime/lib/unijdbc.jar,/opt/coldfusion10/cfusion/runtime/lib/asjava.zip,%CLASSPATH%

and then instead of doing "service coldfusion_10 stop" and "service coldfusion_10 start" as I had been doing, I decided to try "service coldfusion_10 restart".  It said it was stopping CF but then could not start it.  I don't have the exact error but it did end with this:

The ColdFusion 10 server instance named cfusion is starting up and will be available shortly.

There has been an error starting ColdFusion 10 server instance named cfusion, please check the logs.

So I thought perhaps the "restart" left a pid or something hanging and it did not completely shut down, so it could not restart, although it would not let me do the stop command either, nor were there any coldfusion processes running on the server.  So I decided to reboot the server to see if that would help, it did not -- after the server came back up, I tried starting coldfusion again, and keep getting this error: 

[root@ctc3650z selinux]# service coldfusion_10 start

Starting ColdFusion 10 server instance named cfusion ...

nohup: ignoring input and appending output to `nohup.out'

sh: /opt/coldfusion10/cfusion/runtime/lib/asjava.zip: cannot execute binary file

sh: line 0: bg: no job control

The ColdFusion 10 server instance named cfusion is starting up and will be available shortly.

There has been an error starting ColdFusion 10 server instance named cfusion, please check the logs.

[root@ctc3650z selinux]#

I cannot get into the coldfusion administrator to change the classpath, but it does not appear to like the asjava.zip file, which it had no problem wtih before (is same file).  I do not understand this error:

sh: /opt/coldfusion10/cfusion/runtime/lib/asjava.zip: cannot execute binary file

Also it says "please check the logs" ... I have looked at all the logs under /opt/coldfusion10/cfusion/logs and nothing in them references this error.

Here is the entry in the /opt/coldfusion10/cfusion/bin/nohup.out:

Usage: java [-options] class [args...]
           (to execute a class)
   or  java [-options] -jar jarfile [args...]
           (to execute a jar file)

where options include:
    -d32          use a 32-bit data model if available

    -d64          use a 64-bit data model if available
    -server       to select the "server" VM
                  The default VM is server.

    -cp <class search path of directories and zip/jar files>
    -classpath <class search path of directories and zip/jar files>
                  A : separated list of directories, JAR archives,
                  and ZIP archives to search for class files.
    -D<name>=<value>
                  set a system property
    -verbose[:class|gc|jni]
                  enable verbose output
    -version      print product version and exit
    -version:<value>
                  require the specified version to run
    -showversion  print product version and continue
    -jre-restrict-search | -jre-no-restrict-search
                  include/exclude user private JREs in the version search
    -? -help      print this help message
    -X            print help on non-standard options
    -ea[:<packagename>...|:<classname>]
    -enableassertions[:<packagename>...|:<classname>]
                  enable assertions
    -da[:<packagename>...|:<classname>]
    -disableassertions[:<packagename>...|:<classname>]
                  disable assertions
    -esa | -enablesystemassertions
                  enable system assertions
    -dsa | -disablesystemassertions
                  disable system assertions
    -agentlib:<libname>[=<options>]
                  load native agent library <libname>, e.g. -agentlib:hprof
                    see also, -agentlib:jdwp=help and -agentlib:hprof=help
    -agentpath:<pathname>[=<options>]
                  load native agent library by full pathname
    -javaagent:<jarpath>[=<options>]
                  load Java programming language agent, see java.lang.instrument
    -splash:<imagepath>
                  show splash screen with specified image
[root@ctc3650z logs]#

Can anyone help?  Thank you very much, and sorry so wordy...

Julie

Views

1.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 18, 2013 Jul 18, 2013

Copy link to clipboard

Copied

I fixed it myself!!  I could not get back into the CF Admin to undo the syntax change on the classpath on the Java/JVM page, since CF was down, so I dug around on the server and found this file:  /opt/coldfusion10/cfusion/bin/jvm.config  which is the contents of that screen.  I edited it with vi and undid the syntax change I did, then I was able to start up coldfusion.  Still can't get my unidata datasource to connect, but that's another issue...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 10, 2015 Sep 10, 2015

Copy link to clipboard

Copied

LATEST

Thank you,

I had the same problem yesterday with my ColdFusion 11 server. And your find helped.

thanks again.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines