• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Default Document not being honored after upgrade to CF10

Community Beginner ,
Jul 01, 2013 Jul 01, 2013

Copy link to clipboard

Copied

Windows 2008 R2

ColdFusion 10

IIS 7

We just upgraded our production server (clone, not in production yet) from CF9 to CF10. The issue seems to be that the default/welcome document is nto being honored. Example:

If I go to http://server/dir/default.cfm everything is cool, but if I go to http://server/dir/ I get a 404 error.

When we upgraded our test box, we had a handful of issues, but this was not one. I have gone ahead and removed and re-added the default docs in IIS, plus into the web.xml file (Tomcat) and applicationHost.config. I have also removed and re-added the IIS site via wsconfig (and once manually). The IIS server serves up all the cfm files, etc. fine, it is just using the dir only.

Views

1.1K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Jul 01, 2013 Jul 01, 2013

RESOLVED

I enabled detailed IIS errors and could see there was a conflict with the default document in IIS. This was a clone, so not sure why it was an issue, but I deleted the default documents in IIS for the server and left them at the local level I swear I checked that first, and saw local as inherited, but you know once you start manually editing the web.config file, trouble begins.

Votes

Translate

Translate
Community Beginner ,
Jul 01, 2013 Jul 01, 2013

Copy link to clipboard

Copied

Sorry, mistaken... not a 404, but a 500 - Internal server error.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 01, 2013 Jul 01, 2013

Copy link to clipboard

Copied

LATEST

RESOLVED

I enabled detailed IIS errors and could see there was a conflict with the default document in IIS. This was a clone, so not sure why it was an issue, but I deleted the default documents in IIS for the server and left them at the local level I swear I checked that first, and saw local as inherited, but you know once you start manually editing the web.config file, trouble begins.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
Documentation