Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


New Encoding-Problems with CFBuilder 1.0

New Here ,
Mar 24, 2010 Mar 24, 2010

Copy link to clipboard

Copied

Hello

We have a lot of pages encoded with iso-8859-1. CFBuilder Beta 1-3 was able to show the correct encoding (specified in project properties > resources > text file ecoding). Although we changed the settings in project properties and in preferences (general > workspace > text file encoding > other > iso-8859-1), cfbuilder opens every single page with utf-8. it's possible to change it for every page under page properties (or edit > set encoding), but this is a really big efford... it's also a little bit strange, because the set-encoding-menu shows "Determined from content: UTF-8" by default, although there are a lot of iso-8859-1 encoded characters inside (ä/ö/ü in our comments).

Any idea?

Thanx,

Patrick

TOPICS
Builder

Views

3.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Mar 24, 2010 Mar 24, 2010
To make CFML editor handel content of given CFML file for a given encoding, follow these steps  -1) Navigate to preferences->General->Content types page2) On this page expand Text node and select CFML source file.3) Once selected, default encoding text field will show "UTF-8" as default encoding for CFML content.4) Change this to any desired encoding type and click update button next to this field.5) Click OK.6) Reopen file in editor.Now content of any CFML source file (.cfm, .cfc, .cfml) will b...

Likes

Translate

Translate
Enthusiast ,
Mar 24, 2010 Mar 24, 2010

Copy link to clipboard

Copied

"although there are a lot of iso-8859-1 encoded characters inside (ä/ö/ü in our

comments)"

what makes you think those are iso-8859-1/latin-1 only chars?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 24, 2010 Mar 24, 2010

Copy link to clipboard

Copied

> "what makes you think those are iso-8859-1/latin-1 only chars?"

that's not what I claimed, of course these charactes exists also in utf-8, but not in the same position...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 24, 2010 Mar 24, 2010

Copy link to clipboard

Copied

"that's not what I claimed, of course these charactes exists also in utf-8, but

not in the same position"

try again.

do you want the full blown unicode lecture (it's already in these forums in

several places over the years) or will you just look this up yourself?

if you open the cf files up in notepad or whatever, what do you see?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 24, 2010 Mar 24, 2010

Copy link to clipboard

Copied

To make CFML editor handel content of given CFML file for a given encoding, follow these steps  -

1) Navigate to preferences->General->Content types page

2) On this page expand Text node and select CFML source file.

3) Once selected, default encoding text field will show "UTF-8" as default encoding for CFML content.

4) Change this to any desired encoding type and click update button next to this field.

5) Click OK.

6) Reopen file in editor.

Now content of any CFML source file (.cfm, .cfc, .cfml) will be handled as encoded in specified encoding.

thanks,

Sandeep Paliwal

Adobe ColdFusion dev team

Blog - http://sandeepp.org/blog/

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 24, 2010 Mar 24, 2010

Copy link to clipboard

Copied

Sorry, Sandeep Paliwa, i was wrong:

That was not exactly the same setting as I thought (I was reading it too fast, I'm really sorry): your are absolutely right!! This setting is the default for all pages without exceptions.

Thank you very much for your help!

patrick

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 26, 2018 Mar 26, 2018

Copy link to clipboard

Copied

LATEST

Hi there!

I am having the same issue but I don't see cfml or cfm content type for Coldfusion 2016. What am I missing?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 24, 2010 Mar 24, 2010

Copy link to clipboard

Copied

Thanks for all your help...

Sandeep Paliwa: thats exactly the solution I mentioned in the original post - but it's a big efford to do this for every single file...

PaulH: It's not about the difference between iso and utf-8.....!

Fact is:

CFBuilder beta got the text file encoding for all pages from the project settings

CFBuilder 1.0 does not...

thanks,

patrick

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 20, 2010 Jul 20, 2010

Copy link to clipboard

Copied

Hi Im trying to change my content type encoding but everything appears to be locked so i cant make the change.

Any idea how i unlock the content types?

Cheers

Ben

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 20, 2010 Jul 20, 2010

Copy link to clipboard

Copied

OK just Typing in the box seems to work (my bad)

However I need to set the type as ANSI (which isnt supported apparently) any clues

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines