Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Library Use Issues

Community Beginner ,
Jun 18, 2021 Jun 18, 2021

Copy link to clipboard

Copied

There seem to be multiple posts over the past years about issues with Libraries. I have been really frustrated trying to use them and have pretty much given up. But, making this post in HOPES that Adobe will do something to fix these issues.

  1. In Illustrator, I created a bunch of named groups in which I added many different graphics. While these items do sync to the Library in other Adobe apps, NONE of the other apps show the groups that I created in Illustrator. They merely appear under a general "Graphics" category.
  2. When I place an object from the Library in Illustrator, the object and then embed it so that it can be edited, I have to first Ungroup the object, but then it is (for some insane reason) placed inside a clipping mask, so I have to release the clipping mask. I can then edit the object as normal, but now there's an invisible clipping mask object floating around that I need to delete. This is driving me insane.
  3. Why is Libraries called CC Libraries in InDesign, but just called Libraries in Photoshop and Illustrator? It always throws me when I try to open the Libraries panel in ID, because it's not called the same thing.

 

I really hope Adobe addresses these things, because items 1 and 2 make this Libraries feature pretty much unusable for me. It has functioned like this since this feature was introduced and has not been fixed. Even after brand new installs of the software and brand new Macs. There is no reason why a native Illustrator graphic placed into the cloud should be put into a clipping mask when it's dragged back into the software that created it. I am assuming it's because it's being converted into a PDF when it's placed in the Library, but it's completely ridiculous.

TOPICS
Cloud storage web assets, File sync, Libraries

Views

42

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 18, 2021 Jun 18, 2021

Copy link to clipboard

Copied

LATEST

So, after digging around more, I finally found a solution to #1. I had to switch the Library panel display option, because that is not synced, and had to switch it to sort by Custom Group. The named groups now display properly.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines