Creative Cloud Android - work around for old versions

New Here ,
Oct 25, 2020 Oct 25, 2020

Copy link to clipboard

Copied

Hello,

 

I have an Android running on version 7.1.1 and when I try to download the Creative Cloud app I get an error message that the unit is not compatible with this version. It does not seem that my Android can be updated with a later version, is there an work-around to install and older Creative Cloud app?

 

Thank you

/Jan

TOPICS
How to

Views

72

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 25, 2020 Oct 25, 2020

Copy link to clipboard

Copied

a search using google revealed some non-adobe websites purporting to offer older cc for older android os'es. 

 

i would not recommend that you use those.  and even if you install an older cc app there probably would not be any compatible apps for you to install.

 

per adobe, "For optimal performance with Creative Cloud apps, we recommend you keep the operating system of your computer or mobile device up to date. For desktop apps, use no earlier than two versions back of Windows or macOS. For mobile apps, use no earlier than the previous version of iOS or two versions back of Android."

 

you should buy a newer android device.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 25, 2020 Oct 25, 2020

Copy link to clipboard

Copied

LATEST

And for what purpose do you want to install the Creative Cloud App on your android device?

 

I have looked at it on the Google Play Store and see no reason to install it on my Phone. I do have Lr Mobile installed and Acrobat. No need to install the CC app to install and use those or in fact any other Adobe app on android devices. Note that you might even need a newer Android OS to install those also.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines