Reconfig an existing site to use Git token rather than password?

Community Beginner ,
Apr 23, 2021 Apr 23, 2021

Copy link to clipboard

Copied

Hi - Like many who use GitHub I got the email that password access will soon be deprecated and we need to switch to token authentication. Fine, so I went into GitHub and created my token.

But how can I make this change to my site in Dreamweaver? When I go into Manage Sites and select the site, the whole Git section is grayed out, with no apparent way to update my authentication.

Views

874

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 25, 2021 Apr 25, 2021

Copy link to clipboard

Copied

Hi @briandunning ,

 

Thanks for writing to us. Please see if you can update the Git remote authentication by invoking Git panel from Window menu. Within Git panel, please click on "Create Remote" button and set the authentication details.

 

Git Create RemoteGit Create Remote

 

Please let us know if the above resolves the issue else we will further investigate the same.

 

Have a pleasant day!

 

Regards,

Nayan

Dreamweaver Team

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 26, 2021 Apr 26, 2021

Copy link to clipboard

Copied

Thank you Nayan. In the Git panel, I was unable to find a "Create remote" button.

- Brian

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 28, 2021 Apr 28, 2021

Copy link to clipboard

Copied

Same problem here - no 'create' button. Which DW version did that arrive with?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 29, 2021 Apr 29, 2021

Copy link to clipboard

Copied

Hi @Andy Darley ,

 

Please see if you have already configured the Git remote while setting up the site in Dreamweaver. 'Create Remote' will be visible in Git panel if the current Dw site post initializing Git repo doesn't have the remote site configured already.

 

Git integration in Dw is available from Dw 2017 version. Please refer below KB article for more info on using Git in Dreamweaver.

 

KB article: https://helpx.adobe.com/dreamweaver/user-guide.html/dreamweaver/using/git-support.ug.html

 

Have a pleasant day!

 

Thanks,

Nayan

Dreamweaver Team

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 29, 2021 Apr 29, 2021

Copy link to clipboard

Copied

Oh, OK. Thanks. The reason that button doesn't appear for me is that I already have at least one remote created, so mine looks different:

Screen Shot 2021-04-29 at 9.11.19 AM.png

 

When I click "origin" and select "Manage Remotes" I get the window you were trying to guide me to. However it only offers username/password authentication, and the original point of this question is that those are now deprecated on GitHub and we need need to use token based authentication from now one. So how do I set that up?

Screen Shot 2021-04-29 at 9.13.15 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 29, 2021 Apr 29, 2021

Copy link to clipboard

Copied

Hi @briandunning,

 

Thanks for reverting on this. Please see if following below steps helps in successfully connecting to the GitHub.

 

Steps:

  1. Login to your GitHub account in browser
  2. Click on your account icon in the upper-right corner GitHub page.
  3. Go to Settings and click on Developer Settings.
  4. Click on Personal Access Tokens and click on Generate New Token.
  5. For Token description, enter anything and for Scopes, you can use the default options.
  6. Make sure Repo and its sub-options are checked.
  7. Click Generate Token to invalidate any previous tokens you have generated and create a new token. Copy and paste the new token into the private document. This token can never be seen in GitHub again, so save it somewhere safe.
  8. Copy this token in Password textbox in Dreamweaver along-with other details and see if the connection to GitHub is successful.

 

Please confirm if the above resolves the issue else we will further investigate the same.

 

Have a pleasant day!

 

Regards,

Nayan

Dreamweaver Team

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 04, 2021 May 04, 2021

Copy link to clipboard

Copied

Thank you for your contribution, Nayan.   How does this address the fact that from August 13 (I think that's the date - I'm not at my office right now to check),  GitHub will no longer accept a password as part of the authentication to the account?        If that's not worked around somehow,  or Dreamweaver changed to use a github-issued token instead,  then GitHub integration will stop working.     

 

I rely on that integration for my business with more than 40 web sites and a dozen or so SSIS projects in GitHub.

 

Cheers,

Mike Kear

Windsor, NSW, Australia 

CEO,   AFP Webworks

Coldfusion conssultant and developer since 1996.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 04, 2021 May 04, 2021

Copy link to clipboard

Copied

My apologies Nayan,   I spoke before I put my brain into gear.       I have given your suggestion a try and it seems to work ok.    IN short, the answer is to get a token using the procedure you outline above,    Then use that instead of a password in Deamweaver.   


If what I saw today is what will continue after Githubs change is implemented,  then there's no other change that needs be done.    (I hope!!!!)

 

Cheers,

Mike Kear

Windsor, NSW, Australia 

CEO,   AFP Webworks

Coldfusion conssultant and developer since 1996

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 06, 2022 Sep 06, 2022

Copy link to clipboard

Copied

Thanks Nayan, 

That list of actions worked for me. I have been really troubled on this subject, and you came to the rescue. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 06, 2022 Sep 06, 2022

Copy link to clipboard

Copied

Hi Nayan, 

I set up the token authentication with Github, set it into the password field, and it worked once , failed each time afterward. 

    

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 07, 2022 Sep 07, 2022

Copy link to clipboard

Copied

Thank you Nayan, but I have tried this for days now, and it completely fails.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 06, 2022 Sep 06, 2022

Copy link to clipboard

Copied

For me, it failed after the first push. I am very disappointed in Dreamweaver right now.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 06, 2022 Sep 06, 2022

Copy link to clipboard

Copied

Hi @billmcentee,

 

Thanks for writing to us. Can you please try resetting Dw app preferences by following the steps from this KB article and see if the issue gets resolved. In case resetting Dw app preferences doesn't work, can you please try configuring a new site and confirm if the issue is consistent.

 

Have a pleasant day!

 

Regards,

Nayan

Dreamweaver Team

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 07, 2022 Sep 07, 2022

Copy link to clipboard

Copied

LATEST

Thanks Nayan, 

That failed me, also.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines