Locked

Adobe Flash Player Plugin crashes in ALL browsers while accessing webcam

New Here ,
Dec 23, 2010 Dec 23, 2010

Copy link to clipboard

Copied

Hi,

I am struggling to get my adobe flash player plug-in working while accessing webcam.
It simply crashes in all browsers. I googled this issue and realized many users are facing this issue.
However I did not get any solution to fix this. I tried uninstalling/reinstalling plug-in multiple times but of no use.

Following are specifications:

OS: Microsoft Windows XP Professional (32 Bit) SP3
Browsers: Internet Explorer (8.0), Chrome (8.0), Mozilla Firefix (3.0)
Webcam: Dell monitor inbuilt webcam
Flash Player version: 10,1,102,64

Please note, the webcam is accessible through other applications (e.g. Yahoo! Messenger, Skype, Windows Explorer)
Also, Adobe Flash player doesn’t give any trouble while playing streaming videos on YouTube etc.

Trouble is only when flash player tries to access webcam through any browser (eg. while "Record from Webcam" on YouTube)

An interesting observation I like to note here, the device list that appears in the plug-in window is blank for both video/audio devices (See the area encircled  RED in the image below)

Not sure, but just suspecting could this be potential reason for crash?


Any advice would be appreciated.

Thanks,
Struggler

AdobeFlash-BlankList.JPG

Views

8.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 23, 2010 Dec 23, 2010

Copy link to clipboard

Copied

I do not have a webcam, so I do not know too much of them.  All I can recommend is to check if there are any newer drivers available for your specific device.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 23, 2010 Dec 23, 2010

Copy link to clipboard

Copied

Hello all,

My doubt was correct. It was all due to the blank device list. After lot of struggle I found this solution worked for me:

1. As soon as the plug-in tries to access webcam, it will show you "Adobe Flash Player Settings" box

2. Click Deny then Close to close it

3. Now press tab key on keyboard. It will highlight (in yellow) and show list of devices in video device dropdown control (This could be little bit tricky and you need to put little bit more efforts to see the list). You can now select your webcam as device here.
AdobeFlash-GetList.JPG

4. Press Tab key again to go audio dropdown and select audio device.

5. Then right click and bring up "Adobe Flash Player Settings" again.

6. Under Microphone and Camera tabs, make sure we select same devices we selected in 3 & 4 above

7. Come back to privacy tab and this time chose "Allow" and then close "Adobe Flash Player Settings" box

8. You should now see the camera images in the plug-in

Conclusion: This is a workaround worked for me. Plug-in is quite unstable and there is definitely something here Adobe Flash Player plug-in developers need to do about.

Hope this workaround helps many other users.

Thanks,
Struggler

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 23, 2010 Dec 23, 2010

Copy link to clipboard

Copied

Thank you for the feedback!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 25, 2010 Dec 25, 2010

Copy link to clipboard

Copied

I have a similar problem. Shockwave crashes in all browsers regardless of what you are doing. Answer: My version of Shockwave is for the PPC platform, not the Intel based machines.

Possible source is the older CS3 Adobe Suite installed onmy imac. I'm still not out of the woods, but this scrap of information gives me a glimmer of hope!

Merry Christmas and Happy New Year!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 01, 2011 Jan 01, 2011

Copy link to clipboard

Copied

Great information! Thank you!


Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 24, 2010 Dec 24, 2010

Copy link to clipboard

Copied

However, this workaround I can not make it to work for Google Talk Video chat (It uses web based interface hence uses adobe flash player plugin to access webcam)

In that case the plug-in doesnt shows device list controls hence we cannot go and select devices.

Adobe to tell what should be solution/workaround to this.

Regds.

Struggler

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Jan 02, 2011 Jan 02, 2011

Copy link to clipboard

Copied

When viewing an on-line live web cam, Adobe crashes. Help page says you need 32-bit version of Web browser, not 62-bit, but it appears that mine says it's 128 bit, which isn't mentioned. Now, I'm really confused.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 08, 2011 Jan 08, 2011

Copy link to clipboard

Copied

LATEST

Finally I found the culprit. And it was none other than Adobe CS4 products !

I uninstalled flash player plugin, unstalled *ALL* CS4 products one by one, deleted everything under "program files\adobe" (except acrobat reader) and everything under "WINDOWS\system32\Macromed\Flash" restarted machine and then installed flash player plugin.

Now the plugin works fine for Google Video chat, YouTube recorder etc.

Its wired to see Adobe Products causes trouble for each other.

Surely something to be noticed by both Adobe Dev and QA teams.

Thanks,

FlashPlayerStruggler

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines