FrameMaker 11 won't start up

New Here ,
Dec 28, 2012 Dec 28, 2012

Copy link to clipboard

Copied

I'm running FrameMaker 11 on Windows 7. I just changed the settings from unstructured to structured Frame and restarted my computer. Now FrameMaker comes up for a few seconds and goes away. Is there something I can do to get FrameMaker to launch?

TOPICS
Structured

Views

4.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 29, 2012 Dec 29, 2012

Copy link to clipboard

Copied

First thing you can do to get back to Unstructured mode is edit the maker.ini file in the subdir where you have FrameMaker installed. There is an interface setting you can change back to unstructured from structured.

Now to the bigger issue of getting FrameMaker 11 functioning in Structured mode. I need to ask one question before we start. We're you part of the FrameMaker 11 beta test? Was this system used to test FrameMaker 11 before final release?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 02, 2013 Jan 02, 2013

Copy link to clipboard

Copied

I opened the maker.ini file, but I'm not sure which line(s) I need to change.

In answer to your question, I was not a part of the FrameMaker 11 beta test. I don't know if Windows 7 was used to test FrameMaker 11 before it was released. Prior to installing FrameMaker 11, I was using FrameMaker 7.2 with Windows 7. For FrameMaker 7.2 to work properly on Windows 7, I had to edit my compatibility settings to "Run this program in compatibility mode for Windows XP (Service Pack 3)".

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 02, 2013 Jan 02, 2013

Copy link to clipboard

Copied

You will find the "user" maker.ini file in the C:\Users\[USERNAME]\AppData\Roaming\Adobe\FrameMaker\11 subdir.

Edit the maker.ini file with the following change "ProductInterface=Structured FrameMaker" to "ProductInterface=UnStructured FrameMaker".

FrameMaker 11 should start in Unstructured Mode. Let me know how that goes. We will work on Structured mode next.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 02, 2013 Jan 02, 2013

Copy link to clipboard

Copied

Thanks for directing me to the "user" maker.ini file. I edited the ProductInterface setting, and FrameMaker started up in Unstructured Mode.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 02, 2013 Jan 02, 2013

Copy link to clipboard

Copied

Please try to change to Structured Mode through the Edit / Preferences menu. If it does not work, re-edit the user maker.ini. Let me know if Structured works.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 02, 2013 Jan 02, 2013

Copy link to clipboard

Copied

I went through Edit / Preferences and changed the setting to Structured. I restarted my computer and tried to launch FrameMaker. The same thing happened--looks like FrameMaker is going to start up but then goes away after a few seconds.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 02, 2013 Jan 02, 2013

Copy link to clipboard

Copied

Please send me your maker.ini file in the the Adobe FrameMaker install directory (not the user) to taldous@adobe.com. I will be looking for any reference to xmlutils.dll. If there is a refernence just comment out the line.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 02, 2013 Jan 02, 2013

Copy link to clipboard

Copied

I found a reference to xmlutils.dll. I tried to comment out the line in the maker.ini file, but when I tried saving the file, I got an "Access is denied" message.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 02, 2013 Jan 02, 2013

Copy link to clipboard

Copied

You can make the comment out and save the maker.ini file to your desktop. All you have to do is copy the revision on the desktop to where FrameMaker 11 is installed (replace the orginal).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 02, 2013 Jan 02, 2013

Copy link to clipboard

Copied

I was able to replace the original maker.ini file with my edited version. However, FrameMaker still does a vanishing act when I try to launch it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 02, 2013 Jan 02, 2013

Copy link to clipboard

Copied

Let me get our support team on this. Stay tuned.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 12, 2013 Apr 12, 2013

Copy link to clipboard

Copied

Curious as to what the verdict was on this.   I have a similar problem with one of my clients, and have followed this thread to no avail.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 08, 2014 Jan 08, 2014

Copy link to clipboard

Copied

This problem is still occuring. I am evaluating the Framemaker 11 trial. Downloaded the installer from the Adobe website two weeks ago.

I just decided to switch from Unstructured to Structured to check out the interface and, upon restarting the app, got an error saying Frame can't open. The solution listed here of editing the "maker" file worked luckily.

By the way, on my Windows XP machine, its path is C:\Documents and Settings\Administrator\Application Data\Adobe\FrameMaker\11

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 08, 2014 Jan 08, 2014

Copy link to clipboard

Copied

Can anyone suggest a way for me to get Structured Framemaker working on my machine? Reinstalling the OS is not an option. This is a borrowed machine for the purpose of evaluating Structured to see if I'm going to make the purchase. But I can't evaluate if I can't run it. ;(

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 13, 2014 Mar 13, 2014

Copy link to clipboard

Copied

Hi, I just posted the same question.  Thanks much for the fix to get FrameMaker running again (make change in maker.init file).

Did this major issue ever get resolved?  I assumed we could use FrameMaker 11 to do our DITA projects, but it looks like we're going to have to go to FM 12 sooner than later.

What do you recommend?

Thank you.

Laura Ferrer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 17, 2014 Mar 17, 2014

Copy link to clipboard

Copied

LATEST

Hi All,

FrameMaker11/12 needs .NET 4 for XML code view. It seems that some of the .NET 4 components are not properly installed in user’s machine.

User can correct this problem either by :
1) Apply windows updates
2) Repair .NET installation

To confirm that this issue is same, please follow below steps :
1) Go to C:\Program Files (x86)\Adobe\AdobeFrameMaker11
2) Open maker.ini
3) Comment the following entry XML View=plugin,structured,xml view,FMXmlView.dll,PL_SwitchToXmlView
4) Save maker.ini
5) Launch FrameMaker

Thanks

Vikas

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 12, 2013 Apr 12, 2013

Copy link to clipboard

Copied

I wasn't able to get FrameMaker11 to work in Structured mode. I thought at first it was a Windows 7 issue, but a co-worker who has Windows XP had the same problems. We have guessed that the problem may be related to our company's security or our installation of multiple Adobe products. Since I don't use FrameMaker much anymore, the best and quickest solution was to remove FrameMaker 11 and install FrameMaker 10.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 15, 2013 May 15, 2013

Copy link to clipboard

Copied

Did you ever get an answer to this?  I had the same problem too.  So sad...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 17, 2013 May 17, 2013

Copy link to clipboard

Copied

Coincidentally I spoke with an adobe representative at my company's annual conference - his suggestion was to use a different installation method, i.e. download directly from the website.  I did this over a fresh windows 7 installation - instead of using the disk I had, and it appears to be working ok right now in structured mode.  So...I'm not sure if it was the adobe installation or reinstalling windows that did it - I would try downloading new adobe installation files first, hope this helps!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 17, 2013 May 17, 2013

Copy link to clipboard

Copied

Interesting, HarrisBL. Thanks for the post.  I can't reinstall Win 7 - it would take way too much time to setup my system, but i can see if I can request a TCS DVD from Adobe and reinstall Frame that way.  I am surprised that more people haven't posted on it. This is big deal.  I can't even use FrameMaker right now.  How can that be acceptable?  😞  Thanks again....

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 21, 2013 Jun 21, 2013

Copy link to clipboard

Copied

I have the same issue. I switched from unstructured frame to structured frame and now cannot get frame to work. It crashes immediately after I start it. I don't see anything in the maker.ini to edit. I'd like to be able to switch back to unstructured frame. Please help.

Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jun 21, 2013 Jun 21, 2013

Copy link to clipboard

Copied

You need to edit the maker.ini file in your Roaming directory:

C:\Users\YOURUSERNAME\AppData\Roaming\Adobe\FrameMaker\11

[Frame]

ProductInterface=FrameMaker

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines