Deleted Global Colors/[HUH?] error/Unused Brushes Keep Returning

Adobe Community Professional ,
Sep 02, 2010 Sep 02, 2010

Copy link to clipboard

Copied

On Mac AI4 I inherited files, that have 1000s of duplicate brushes in the library. Any copying is slow and pasting between documents fills the swatches palette with 1000s of Deleted Global Colors and brushes. The files are excessively large, slow and any copying is really slow. Can't load CS5 trial here at work(to try out that new cleanup command). This problem has been on the forums before (MAC/PC/CS3/CS4), but has not been solved. I started this as a new thread, as this problem is spreading out of control on other files.

Picture 1.pngPicture 2.png

Here is what I have tried so far that has not worked (as the files are slow/crashing and the brushes keep coming back)

  1. Recovered the file using 'Content Recovery Mode = 1". Edited this in simpletext to remove all code that has "Deleted global colors" & the "Begin PluginObject: Object". There was lots of junk to remove and I got everything in between the open & close tags.
  2. Saved files as AI3
  3. Copied & Pasted all elements into a new document
  4. Removed all unused Brushes, Swatches, Graphic Styles
  5. Deleted all layers/objects & did a save as, and the file is still 6mb.

The "deleted global colors"(see images below) problem has gotten better since cleaning up the code. The problem must lie in in the non-standard characters of the code, as I used search to flush out all items with "Deleted global" and "BeginPlugInObject" between start and ends tags. I also am getting the HUH error(see images below) when saving.

Huh Error.jpg

HELLp

Views

58.8K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 02, 2010 Sep 02, 2010

Copy link to clipboard

Copied

First do a save as using a different name you canalways change it back.

then close the document  open the newly named document copy and do another save as close and open the document and do another save as.

Now close it again create a new blank document to the dimensions of the copied document. then place the last save as document in the empty document. Now try to delete the brushes then the coor swatches.

Do a save as three times again then close and see if it is still there.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 02, 2010 Sep 02, 2010

Copy link to clipboard

Copied

Thanks for your reply. Tried doing the six save as and did not notice any change in filesize. DId a test afterwards with just the logo and you can see the change in filesize below. The filesize is not a problem just the SLOW copying and crashing, but that is what I am monitoring to help cleanse these files.

Picture 1.png

Is there anyone I can email this 5.5mb to. Was 22mb prior to pdf compatible.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 14, 2010 Oct 14, 2010

Copy link to clipboard

Copied

Hi Mike

I have been experiencing the exact same problem, you are describing above ( Deleted Global Colors/[HUH?] ). I feel your pain!

We have 4 imacs running in our studio and first encountered this issue about a year ago in CS3, we upgraed to CS4 in the vain hope it would go away, alas it stayed with us, I have now upgraded to CS5 and the probelem still exists. I have raised the issue with Adobe and they made me run through some exercises. Such as using the new action in AI "Delete unused panel items". This has made no difference and in fact we had been removing the panel items manually anyway.Once the problem exists within the file it gets transferred by copying and pasting between files. That's if you have nerves of steel, to let you wait the absolute age while trying to copy even just small vectors or even type! Then the pasting into the new document takes an age. Adobes temporary solution is a "work around" "Don't copy and paste!" Easy to say harder to put into practice!

I have sent an infected file to Adobe to test and they said they have about 20 such on going cases they are working on.

If you hear anything or find any solutions I would love to know. And in the mean time remember not to copy and paste!

Many Thanks

Mat

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 14, 2010 Oct 14, 2010

Copy link to clipboard

Copied

Yes I found an answer to this and posted on a previous post.

  1. enable content recovery mode for illustrator and convert your file using this technote
  2. open the files in a text editor (I recommend downloading Text Wrangler cause there is alot of code to scroll through and you will need to turn on the line numbers in text wrangler).
  3. Do a find for the first line of code below, write the line number down, then do a search for the last line of code. Select everything in between and delete.

Credit to this solution goes to Moluapple (from China I believe) who emailed me a corrected file and this:

What I have done is delete all lines between
"%AI5_Begin_NonPrinting
....
....
....
%AI5_End_NonPrinting--

MY FILES ARE SMALL AND FAST AGAIN THANKS AGAIN MOLUAPPLE!

If you struggle with this you can ftp me a file and I'll do one for you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 15, 2010 Oct 15, 2010

Copy link to clipboard

Copied

Hi Mike

Wow this is great news. I must havemissed that previous posting.

It sounds a little bit complicated for someone not like me who is not that techie, we will have a go though for sure, I will get our Mac tech support guy to come in and help sort it for me.

Perhaps before I try it, if you would be kind enough to see if it does actually work on one of my files.

I have uploaded a file for you to our ftp if that's ok, I really appreciate your help very much.

FTP SERVER:

Host: ftp.wildandwolf.com

Username: gondek

Password: wolf2009

Kind regards

Mat

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 27, 2010 Oct 27, 2010

Copy link to clipboard

Copied

Sorry to have not seen your post earlier, not getting my updated post emails though I enabled them on this forum. I got the file, but did someone else fix it. Anyway I got the file down from 5.9mb to under 816k. Will try to private message you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 19, 2010 Nov 19, 2010

Copy link to clipboard

Copied

Mike If I delete the everthing between those two lines, there is not much left of my file after opening.

How far down in textwrangler should i dig? There are approx 14 of the %A15_End_NonPrinting lines in my file. Which one is causing the problem. Thousands of bogus brushes and symbols keep regenerating as well as deleted global colour

These damn files are really starting to be viruslike, I hope there is a real fix soon!!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 22, 2010 Nov 22, 2010

Copy link to clipboard

Copied

In my problem, I deleted  over 95% of my code, and the file got smaller, faster and functioned normally. Every case is different with how many you have so I can't give you a finite answer on how many to delete. You most likley can delete all of them.

Obviously keep a backup of your original, incase you delete too much. In worst case you might delete a brush or color, that you can recreate, just don't copy that from an infected file, or it comes back. Has been over 3 months now, and all is functioning well, and the infected files are fewer. We almost lost the entire Shurfine brand because of this problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 23, 2010 Nov 23, 2010

Copy link to clipboard

Copied

Mike,

I finally got the files cleaned up. Alot of experimental selections of in Text Wrangler paid off ...thanks!

I did notice quite a few references in the code to "ARTPRO" (which I removed)....Hmmmm could it be a careless use of plugins from a production shop?

thx

paul

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 23, 2015 Jun 23, 2015

Copy link to clipboard

Copied

Hi Mike, Can you please send me the (Exact) path of this file (Preference file) on my computer ... i can't find it on my my mac!!!

What is the name of the file?!

I don't understand this path!Screen Shot 2015-06-23 at 2.30.38 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 23, 2015 Jun 23, 2015

Copy link to clipboard

Copied

Hi Hatem,

Please try these steps:

1) Launch the Finder application

2) Press "Command + Shift + g"

3) Type "~/Library/Preferences" in the "Go to folder:" option

4) Press the Enter key

Hope this helps.

Regards,

Raghuveer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 23, 2015 Jun 23, 2015

Copy link to clipboard

Copied

Thanks alot rbhunwal, Your way is the only right way because if you try to go tracking by yourself you will not find the folder !!! very strange

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 23, 2015 Jun 23, 2015

Copy link to clipboard

Copied

Hello Hatem,

The mac OS since this post has made certain folders invisible. 2 additional ways to get around this:

  1. permanent method- Enter a short line of code in the terminal to show this folder "chflags nohidden ~/Library".
  2. quick method - Pull down the go menu, and once you hold down option the library folder will appear below home.

x.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 23, 2015 Jun 23, 2015

Copy link to clipboard

Copied

I have delet the in-between this two lines as below then i saved but it is ( the one with _ before the name)  the same size ..

Screen Shot 2015-06-23 at 5.37.30 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Oct 28, 2010 Oct 28, 2010

Copy link to clipboard

Copied

Adobe's Teri Pettit posted the solution here:

http://adobe.groupbrowser.com/t177412.html

on March 19, 2009.

The link won't open on my computer, so I don't know if that site is still active or not.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 18, 2011 Jan 18, 2011

Copy link to clipboard

Copied

Thanks to Mike for forwarding me to this thread. Unfortunately the prescribed cure hasn't worked for my nearly identical problem...

None of the infected files have any occurence of "%AI5_Begin_NonPrinting" or "%AI5_End_NonPrinting" or "ARTPRO" etc. They are client files, so I'd be unable to share them... any ideas?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 18, 2011 Jan 18, 2011

Copy link to clipboard

Copied

After a couple of weeks there are still some painful anomalies in the files. Some text changing to black instead of K/O etc. Not sure if this is a result of removing critical data in textwrangler? Still scary moving forward and trying to keep infected files separate from finals. Hope we don’t have egg on our face at the printers!!!! Still no word as to a cause anyone???

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 21, 2011 Feb 21, 2011

Copy link to clipboard

Copied

Paul,

You should be good once this goes to print if you have corrected any spot colors/styles/ brushes, that got lost in the process.  I've fixed quite a few files now since started working on this account. The worst that happens is some type goes missing, but doing a command Y shows it is there, and never had to spend more than 10 minutes proofing and recoloring lost spot colors. Prior to fixing this bad code, I lost 10 minutes on each copy/paste, so recoloring a few items was a small price to pay for clean files that won't infect other accounts.

Though we do packaging design here, they do not remember the Art Pro plug in, but will ask our weekly tech guy that comes in to see if he remembers.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 21, 2011 Feb 21, 2011

Copy link to clipboard

Copied

This may help, i've try one of the infected file.

- open the infected file, select all

- create new document

- click the arrange documents on the infected document, choose 2-up

- drag over the selected all file to the new document, save it.

- close all document

- open the new saved file. check brushes, it should back to normal.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 07, 2014 May 07, 2014

Copy link to clipboard

Copied

Yaa. Bro. ir works. Simple solution. Here I have repeat it.

This may help, i've try one of the infected file.

 

- open the infected file, select all

- create new document

- click the arrange documents on the infected document, choose 2-up

- drag over the selected all file to the new document, save it.

- close all document

- open the new saved file. check brushes, it should back to normal.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 17, 2015 May 17, 2015

Copy link to clipboard

Copied

Thanks a lot, from Bangladesh.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 15, 2011 Apr 15, 2011

Copy link to clipboard

Copied

Looks like there's still no real solution for this and we're at CS5 now. The real problem is when you copy and paste, all these deleted global colors get added to the swatches. Does anyone have a solution for the colors not being added at all? Cleaning up code is like a medicine for after you're already sick. We need a vaccine so this infection doesn't happen at all! Help us, Adobe! You're our only help!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 17, 2011 Apr 17, 2011

Copy link to clipboard

Copied

Hi,

hope my attached picture explain well.

1) open infected file, you can see all the brushes swatches and symbols duplicated.

Screen shot 2011-04-18 at 9.14.47 AM.png

2) Create New document.

3) click the arrange documents choose 2 up.

Screen shot 2011-04-18 at 9.15.16 AM.png

4) with the side by side documents, click the infected document. Then, select all. Drag the selected artworks Over to New document. As attached.

Screen shot 2011-04-18 at 9.16.39 AM.png

5) Check the brushes Swatches Symbols at the new document. The duplicated items has gone. Oh Yeah!

Now, save the new document. DELETE the infected file. Or you want to keep it.

Then, delete unwanted colors, then do the copy and paste in your new saved document. Check color swatches.

Is my solution fix your file?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 27, 2011 Apr 27, 2011

Copy link to clipboard

Copied

yes, thank you! i would also add unchecking the "Embed ICC Profiles" box in the Illustration Options window when you save. this seems to keep those deleted global colors from coming back.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines