How to export to JPG only what fits inside the actual page?

Community Beginner ,
Sep 09, 2009 Sep 09, 2009

Copy link to clipboard

Copied

When I export Illustrator drawing to JPG, Illustrator also includes objects which are outside the page boundaries, which causes the resulting JPEG to be of a different size than the actual page. This is very frustrating if there is a clip mask cropping out excess of a photo.

Image below should hopefully clarify my issue:

clipmaskongelma.jpg

Views

51.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Sep 09, 2009 Sep 09, 2009

Copy link to clipboard

Copied

Select your mask and double click on the Crop Area tool, or if in CS4 the Art Board tool from the options pull down select Fit Crop Area to Selected Art. Now try to export your jpg.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 09, 2009 Sep 09, 2009

Copy link to clipboard

Copied

My presets menu doesn't have that option? Only Fit Artboard to Artwork Bounds and Fit Artboard to selected art.

After activating the Artboard tool correct portion of the image is shown.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Sep 09, 2009 Sep 09, 2009

Copy link to clipboard

Copied

Well then I guess you're working in CS4?

It would be Fit Artboard to selected art. Then export.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 09, 2009 Sep 09, 2009

Copy link to clipboard

Copied

When I select "Fit Artboard to select art", Illustrator moves the selection to include the clipping mask.

You can try this yourself:

- Draw one rectangle inside the page and another one overlapping the first rectangle and going beyond the page boundaries

- Select rectangles and make clipping mask

- Select resulting object + double click artboard tool

- Now Illustrator should show in artboard exactly the parts inside the page (however, if you export to JPG at this point also the overlapping part is included)

- "Fit Artboard to select art" -> selection moves to include whole clipping mask (no effect on export JPG)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 09, 2009 Sep 09, 2009

Copy link to clipboard

Copied

Check the "Use Artboards" option in the export window. Or tick "Crop to artboard" in the save for web dialog.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 10, 2009 Sep 10, 2009

Copy link to clipboard

Copied

"Check the "Use Artboards" option in the export window. Or tick "Crop to artboard" in the save for web dialog."

Thanks!! I just didn't notice that option.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 10, 2009 Sep 10, 2009

Copy link to clipboard

Copied

torput,

You may perform the normally destructive deed:

1) Create a rectangle covering the desired part (stroke, no fill makes it easier);

2) Select both and Object>Clipping Mask>Make;

3) In the Transparency palette dropdown, select anything bu normal;

4) Object>Flatten Transparency (no need to change options).

4) should get rid of the outlying parts for you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 26, 2014 Sep 26, 2014

Copy link to clipboard

Copied

Thank you, Jacob Bugge! Your solution solved the problem I came here for. Very sophisticated that transparency flattening.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 26, 2014 Sep 26, 2014

Copy link to clipboard

Copied

You are welcome, hungrywave.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 22, 2016 Jun 22, 2016

Copy link to clipboard

Copied

LATEST

Open your Illustrator file in Photoshop and save it in JPG format

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines