Illustrator 2019 - File Type Association (WIN) *Bug*?

New Here ,
Oct 15, 2018 Oct 15, 2018

Copy link to clipboard

Copied

No matter what I try I cannot change the default file type .ai to always open/be associated with Illustrator 2019.

The files always show up as blank icons and I have to now always right click and 'open with' and choose Illustrator 2019.

Bug with the new updated?

Views

12.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Nov 21, 2018 Nov 21, 2018
Hi there,All the users on this thread have a similar issue but not the same. Every situation here has a different fix.XD defaulting to AI on Windows Please update to latest version of XD (13.1.32) to resolve the issue.PS defaulting to AI on MAC Please update to latest version of Illustrator (23.0.1) to solve this issue.For other issues: Please try these steps to correct general File association errors: How to fix broken file type associations for Creative Cloud appsIf you have tried all of these...

Likes

Translate

Translate
replies 108 Replies 108
Adobe Employee ,
Oct 15, 2018 Oct 15, 2018

Copy link to clipboard

Copied

Hi there,

Please try steps mentioned below and share results:

Solution 1: Use Windows control panel to establish the file association

This solution uses Illustrator as an example. For any other product, replace that product's filename extension and executable name with the product and file type you are attempting to restore.

  • Choose Start > Control Panel.
  • Double-click Default Programs.
  • Click Associate A File Type.
  • Choose Default apps by File Type.
  • Select .ai from the list.
  • Click application selected in front of it and choose Illustrator 2019
  • If it is not listed there click Browse to locate it and click Open.
  • Ensure that Always Use The Selected Program... option is selected. Click OK to close the Open With dialog box.
  • Double-click the .ai file to ensure that it opens with your preferred version of Illustrator.

Solution 2: Set a default path in the Registry

Note: Before trying these steps, please take a backup of your Registry: https://support.microsoft.com/en-in/help/322756/how-to-back-up-and-restore-the-registry-in-windows

  • Choose Start > Run, type regedit in the Open text field of the Run dialog box, and then click OK to open the Registry Editor.
  • Navigate to the key HKEY_CLASSES_ROOT\Adobe Illustrator Artwork 23.0\shell\open\command
  • Make sure that the (Default) value is set for the path where Illustrator is installed.
  • If the path is incorrect, double-click (Default) and type the following text with the quotation marks and "%1"in it:
  • "C:\Program Files\Adobe\Adobe Illustrator CC 2019\Support Files\Contents\Windows\Illustrator.exe" "%1"
  • Navigate to HKEY_CLASSES_ROOT\Adobe Illustrator Artwork 23.0\shell\edit\command
  • Make sure that the (Default) value is set for the path where Illustrator is installed.
  • If the path is incorrect, double-click (Default) and type the following text with the quotation marks and "%1"in it:
  • "C:\Program Files\Adobe\Adobe Illustrator CC 2019\Support Files\Contents\Windows\Illustrator.exe" /e "%1"
  • Right-click the file of the format you want to associate with Illustrator and choose Open With > Choose Default Program.

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 15, 2018 Oct 15, 2018

Copy link to clipboard

Copied

I have the same problem.

.AI files are associated with Adobe XD and I can´t change it. When I want to associate them with a different program, Illustrator appears in the list, but if I select it, nothing happens.

I tried both solutions.

P.S: In the registry I think that the correct path is "HKEY_CLASSES_ROOT\Adobe.Illustrator.23\shell\..."

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

Same here:.ai and .psd files are associated with Adobe XD on (Win10). Can't change the default programm for opening those filetypes.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

I have the exact same problem.

Tried both your solutions to no avail.

Will probably have to wait a few weeks until Adobe catches on and acknowledges the issue only to fix it in another month or so...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

Having the same issue on my Mac.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

Thanks! Figured it out!

Right click on an "ai" file and select "Get Info"

Click on "Open With" in the drop-down menu select Adobe Illustrator 2019 and click "change all." You will get a dialog box asking if "you want to change AISafeModeLauncher.app" click continue.

Your Illustrator files should now open in illustrator and not Photoshop.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

None of this worked, I finally deleted the XD CC that had installed with the CC 2019 files and it seems to have fixed the issue.  Although I don't have that software to use until this is figured out.  It is very frustrating, it messed up a lot of my files.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 20, 2018 Oct 20, 2018

Copy link to clipboard

Copied

My registry was fine at Adobe.Illustrator.23, and still did not update associations, but when i put the same entry into Adobe.Illustrator.21, it now works fine. Reg_Capture.JPG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 15, 2018 Oct 15, 2018

Copy link to clipboard

Copied

Same problem. Upgraded to Illustrator 2019 and cannot associate .ai files with Illustrator. Have tried both the registry and file associations suggestions and they do not work.

If I install Adobe XD on the same machine it takes over the association with .ai files. If I remove Adobe XD then .ai files appear as blank icons.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

Same problem here. How do you guys manage to screw something up every time you update something is beyond me. Do you do ANY product testing on Windows before release?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Nov 08, 2018 Nov 08, 2018

Copy link to clipboard

Copied

I second that. After the cloud service came about I feel like a crash test dummy paying good money to receive hits. Every single time I accept an "update" I keep regretting it. I'm always hoping to see some progress but every time I'm thrown into a pile of dirt by Adobe's lack of customer care. I'm seriously considering leaving.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

Same here, tried both solutions. Still not working. XD forcing association to .ai files

I'm using Windows 10

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

As an update I replicated the issue by trying to edit a Smart Object in Photoshop. Instead of opening Illustrator it asked me what app I'd like to use to open that file, so the association is clearly broken.

Windows 10 here as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

Also having the same issue. I tried removing XD but I still cannot associate Illustrator 2019 with AI files.

I noticed the unassociated files are listed as 'Adobe.Illustrator.22' in Explorer. This update is version 23, right?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

windows 10, complete messed up files associations. psd files open with XD. When I try editing an AI smartobject it opens XD....

Trying to change files associations in the windows settings doesn't work at all. keeps XD as default. I've also tried resetting the files associations same result, nothing happens. Fix this since we cannot edit smartobjects anymore because of this!!! Next time you should consider a Creative Cloud Beta upgrade program before releasing your products to everyone. We are not labrats, we are paying and working with those softwares! thx!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

On Windows the last one to register file gets precedence. Here is a simple fix go to any .ai file in  one of your folders right click on the file then do Open With > Choose another app . Select the application that you want to prefer and do not forget to check Always use this app to open .ai file

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

not working at all

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

I have already attempted this and it does not work. I uninstalled XD and Illustrator and reinstalled only Illustrator. File association would not happen after install or when choosing 'open with' and checking the box.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

did you also choose always use this app option to make it sticky? Open With > Choose another app > Always use this app to open .ai file

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

Yes, that option was chosen. The AI file type in Explorer when no application is associated is listed as 'Adobe.Illustrator.22' - presumably it should be 23?

File association still works as expected when I rolled back to v22.1. It is broken for me on v23.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 03, 2018 Nov 03, 2018

Copy link to clipboard

Copied

Ive change the value of "HKEY_CLASSES_ROOT\.ai" from "Adobe.Illustrator.22" to "Adobe.Illustrator.23" and then i could change the default program!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

As stated above multiple times, this solution does not solve the problem. With or without the checkbox being ticked. Neither does the registry edit. I have uninstalled XD as well and had the same result as the other users. Ai files remain blank, unassociated. Even after that, trying the "open with" solution doesn't do anything.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

That does't work either.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

Yes all that is said here is the case. I have noticed that other programs that import Illustrator are have a problem with this format for import. I have posted one I noticed before this discussions problem here.

Import Ai to Stage or Library does nothing

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines