Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Illustrator 2020 works extremely slow on macOS Catalina

New Here ,
Jan 14, 2020 Jan 14, 2020

Copy link to clipboard

Copied

cc 2020 I did the last update and Adobe Illustrator slowed down extremely and became unable to process.
I'm using Mac Pro Catalina version 10.15.2. but I could not solve this problem.

 

{Renamed by MOD}

TOPICS
Performance

Views

3.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 15, 2020 Jan 15, 2020

Copy link to clipboard

Copied

Hello! I moved your message to the Illustrator forum

When is AI slow? at boot during use? certain tools more than others?

Which exact version (check in "about Illustrator"?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 16, 2020 Jan 16, 2020

Copy link to clipboard

Copied

Hi Abbas,

 

So sorry to hear about this issue. I would request if you can share a few more details like:

  • Exact version of Illustrator.
  • Is it slow on a particuler action or while using some particular feature/ tool?
  • Is the issue related to a specific document? If yes, could you please share the document with us? You can upload it to the Creative Cloud and share the download link. 
  • Where the files are saved (Network Drive/ System HDD/ Shared Folder on System /External HDD)? 
  • Does resetting Illustrator Preferences (https://helpx.adobe.com/in/illustrator/using/setting-preferences.html) help resolve the issue?
    Please note that resetting preferences will remove all the custom settings and Illustrator will launch with default settings. You can also take a backup of the folders in case you want to. Location is mentioned in the article.

 

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 20, 2020 Feb 20, 2020

Copy link to clipboard

Copied

Hi!

I have the same problem, I have Illustrator 2019 CC and since I updated to Catalina, it's very slowly responding. 
For example when I'd like to modify an ancher point, it's simply doesn't follow my lead and at anchors in a different point than I'd like it to. This makes illustration very hard and annoying, thinking about downgrading back to Mojave, because I'm having the same difficulties in Photoshop (there is an extreme brush lag). 
Please advise if I can do something. Thank you!

Eszter

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 20, 2020 Feb 20, 2020

Copy link to clipboard

Copied

Hi Eszter,

 

Thanks for sharing the details. Please try following these steps and share your observations:

  1. Reset Preferences: - 
  • Close all Adobe applications. 
  • Go to locations 
  • ~/Library/Caches 
  • ~/Library/Application Support/Adobe 
  • ~/Library/Preferences 
  • Rename  Adobe Illustrator, com.adobe.illustrator and Adobe Illustrator 23 Settings folders to   Adobe Illustrator.old, com.adobe.illustrator.old and Adobe Illustrator 23 Settings.old 
  • Launch Illustrator from the Creative Cloud. 

 

Please note that resetting preferences will remove all the custom settings and Illustrator will launch with default settings. This way all your old settings will be saved in .old folders and Illustrator will recreate new folders with default settings.  

 

 

  1. If that doesn't help, try booting the system into Safe Mode (https://helpx.adobe.com/in/x-productkb/global/start-safe-boot-mode-mac.html) and check how it works there. It starts your system so that it performs certain checks and prevents third party software/ services from automatically loading or opening. If it works fine in Safe mode, then there is some third party service or application like antivirus, plugins or web extensions which are conflicting with the Illustrator. 

 

  1. If that doesn't help either, login to root account (https://support.apple.com/en-in/HT204012). Check how application works there. If it works fine there, then it could be related to permission errors. Follow these steps to repair permission errors: https://helpx.adobe.com/in/illustrator/kb/preferences-folder-read-only-error.html  

 

Regards!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 23, 2020 Apr 23, 2020

Copy link to clipboard

Copied

Hi. I've recently discovered and posted on the Adobe Indesign comminuty board that if you change the colour PREFS from LG UltraFine to Apple RGB in the display settings, all works brilliant. Seems that there is an issue with Adobe's code with LG UltraFine monitors. Pass this on please.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 26, 2020 Apr 26, 2020

Copy link to clipboard

Copied

Thanks for reaching out, Nicholas. Does it fix performance issues for Illustrator and other Adobe applications as well?

 

Regards!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 26, 2020 Feb 26, 2020

Copy link to clipboard

Copied

I, too, have been plagued with performance issues from Adobe since upgrading to Mojave. I've searched extensively, employeed copious "fixes" from both Adobe AND Apple to no avail. The only thing I knew that actually worked was to diconnect my iMacPro from the network before launching any Adobe software. So it's something that the apps are calling out home for.... well, I found this extensive list of Adobe servers that bootleggers use to block activation, amongst other things, via the hosts file. I employed it myself even with my account still active and legit. Everything is running like a champ now! Back to High Sierra responsiveness! Creative Cloud wanted to fix two entries with their Limited Access Error Tool, I allowed it, and it has not impacted performance at all. I highly suggest giving it a try. PM me for the list.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 26, 2020 Feb 26, 2020

Copy link to clipboard

Copied

Hi Chris,

 

Thanks for reaching out. I have sent you a DM for more details.

 

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 26, 2020 Apr 26, 2020

Copy link to clipboard

Copied

Yes. All Adobe CC programs, including Bridge. That's my experience. Was surprised as to how much.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 26, 2020 Apr 26, 2020

Copy link to clipboard

Copied

Thanks for sharing this. I will definitely pass it on to our Product team. 

 

Regards!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 23, 2020 Apr 23, 2020

Copy link to clipboard

Copied

Hi. I've recently discovered and posted on the Adobe Indesign comminuty board that if you change the colour PREFS from LG UltraFine to Apple RGB in the display settings, all works brilliant. Seems that there is an issue with Adobe's code with LG UltraFine monitors. Pass this on please.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 07, 2020 Jul 07, 2020

Copy link to clipboard

Copied

I think this is a general problem with individual color profiles.

 

I work on an Eizo CG248-4K and switching to Apple RGB was the only temporary solution beside a few not-so nice workarounds.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 01, 2020 Dec 01, 2020

Copy link to clipboard

Copied

LATEST

You just saved my night. Thank you!!!

 

Adobe RGB, Apple RGB ou Diplay, anything but LG Ultrafine works fine on my MacBookPro

 

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 19, 2020 Oct 19, 2020

Copy link to clipboard

Copied

I had the same issue, I enabled GPU Performance in Illustrator Perferences and it started to work smoothly. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 28, 2020 Nov 28, 2020

Copy link to clipboard

Copied

This solution totally solved this for me. Thank you so much.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines