Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Illustrator CC is not importing AutoCAD DWG file layers correctly

Community Beginner ,
Jun 18, 2013 Jun 18, 2013

Copy link to clipboard

Copied

In CS6, I could import (open) DWG files  and it would correctly categorize the input objects into separate layers. In CC, it is putting them into a group in a single layer,  which is a big usability regression. Is there a fix for this?

Views

35.8K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 24, 2013 Jun 24, 2013

Copy link to clipboard

Copied

I am experiencing the same error.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 24, 2013 Jun 24, 2013

Copy link to clipboard

Copied

I don't know whether it helps anyone or not, but I reported this as a formal bug to Adobe under case number 0184417993, which is now in the status of "Open - Pending Adobe Response." I spent some time on the phone with them and they were able to produce a very simple test case that duplicates the problem, although now we are playing phone tag to provide additional information of some sort. In the meantime, I have gone back to using CS6.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 19, 2013 Jul 19, 2013

Copy link to clipboard

Copied

Same problem here, llustrator CC.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 19, 2013 Jul 19, 2013

Copy link to clipboard

Copied

A brief update. I have spent a lot of time with Adobe Support on the telephone about this and they acknowledge that there is a bug that has been reported to Engineering. They have offered no prediction about when it would be corrected.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 24, 2013 Sep 24, 2013

Copy link to clipboard

Copied

It would be very helpful if they'd fix this! It defeats the advantage of using Illustrator to render acad drawings. Thanks for persevering.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 25, 2013 Oct 25, 2013

Copy link to clipboard

Copied

It's realy big problem for me but i figured out a way that you can make each layer on DWG as a one block. so when you open the file on illustrator u still be able to select each layer alone.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 25, 2013 Oct 25, 2013

Copy link to clipboard

Copied

Have you tried saving the acad file back to 2006? I think I saw a memo to that effect.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 25, 2013 Oct 25, 2013

Copy link to clipboard

Copied

There is no 2006 file... 2004, 2007, 2010, 2013. I tried all of them... It's the same. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 11, 2013 Nov 11, 2013

Copy link to clipboard

Copied

"i figured out a way that you can make each layer on DWG as a one block". How do you do this?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 18, 2013 Nov 18, 2013

Copy link to clipboard

Copied

In the latest update of  Adobe Illustrator CC, released about an hour ago, this bug has been fixed. For more details on this update, kindly refer to:

http://helpx.adobe.com/illustrator/release-note/illustrator-17-0-1-release-notes.html

Thanks & Regards,

Raghuveer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 18, 2013 Nov 18, 2013

Copy link to clipboard

Copied

Tnx for the fix and message!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 21, 2013 Nov 21, 2013

Copy link to clipboard

Copied

Thanks, Raghuveer. I confirm that this feature is now working for me correctly in 17.0.1 (64-bit).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 23, 2013 Nov 23, 2013

Copy link to clipboard

Copied

Well, I am embarrassed to say that I spoke too soon. When I did my test, I saw that the imported DWG file was producing multiple layers, so I assumed it was fixed. However, as I started working with it today, I find that paths are being placed in incorrect layers. Usually, the very first layer in the stack has quite a number of paths that should have been assigned to lower layers. I tried this with various versions of AutoCAD file formats, from R13 to R24. I use dozens and dozens of these files in my work, and they all import correctly into Illustrator CS6.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 29, 2013 Nov 29, 2013

Copy link to clipboard

Copied

Here is an update. I reported this to Adobe support on November 25 and they supposedly escalated it to engineering. I am awaiting a call back for details.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 10, 2013 Dec 10, 2013

Copy link to clipboard

Copied

Another update. After sending in some test files to demonstrate the problem, I received an email from Adobe support that said "Thanks a lot for reporting this issue. We have Isolated the issue and forwarded it to the core team for a fix."

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 16, 2014 Jan 16, 2014

Copy link to clipboard

Copied

FYI: This bug is still present in the new AI CC 17.1.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 28, 2014 Apr 28, 2014

Copy link to clipboard

Copied

Hi Raghuveer,

I was wondering if  we could see this issue ( dwg-import mixes up the obejects on the layers) be resolved soon ? Or does anyone has a workaround other than exporting or printing  as .pdf in autocad ?

thanks,

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 28, 2014 Apr 28, 2014

Copy link to clipboard

Copied

Hi Npau,

Will it be possible to share the dwg files with us. Also please let me know the AI version you are using.

Thanks for your valuable support. I appreciate this.

With Best Regards,

Raghuveer Singh

ShareWithAI@adobe.com

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 29, 2014 Apr 29, 2014

Copy link to clipboard

Copied

Hi,

In attachment I have included two dwg files,  both were made in autocad 2014, one saved to autocad version 2007 and one to version 2010.

link to the files (link active for 7 days): http://we.tl/idgHIsqNgk

  • I have opened both in illustrator CC and saved them. Some objects in the Illustrator CC file are on different layers then in the the original autocad file.
  • I have opened the same testfile (2007) in illustrator CS6. (file testfile_2007_opened_in_AI_CS6). AI CS6 correctly imports the dwg file.

The same results are achieved with prior file versions of autocad and with the dxf file format.

Also the same results are achieved on different computers (all are windows 7 pro 64bit/autocad 2014-english)

Software configuration:

Windows 7 64-bit professional SP1 – English

Autocad 2014 : Autocad architecture SP1 version l.108.0.0 – English

Illustrator CC : illustrator CC  (64-bit) version 17.1.0 - english

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
May 28, 2014 May 28, 2014

Copy link to clipboard

Copied

Hi rbhunwal,

do you know if there is any progress on this problem? Will there be a fix/update soon? Can't work with the software like this. Is there a workaround until a real solution is found? (Going back to CS6 is not an option for me).

thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 10, 2013 Nov 10, 2013

Copy link to clipboard

Copied

Dear Adobe...

Dont be Microsoft and push this half-assed CC software out the door!

And for Gods sake.. Secure your damn transaction servers...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 28, 2014 Jan 28, 2014

Copy link to clipboard

Copied

CC updated and now I am having an issue where the layers import but the objects are on diffferent layers than where they started out. Some of the dimension objects wind up on the walls layer the valence objects end up on the 0 layer amd all sorts of random objects land on the defpoints layer I never use the defpoints layer etc etc. I have to go through the file and select all the objects by stroke color then cut and paste in place everything in the correct layer. this is a new issue since the CC updated last week. Tried saving the autocad file back to 2000 and as a DXF.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 05, 2014 Jun 05, 2014

Copy link to clipboard

Copied

Having same issue. The only work around for me is to open in CS6 and copy and paste into a CC document. This needs to get fixed ASAP for us to complete instruction sheets. Should not have to have two versions of Illustrator for something I work on every day.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 19, 2014 Jun 19, 2014

Copy link to clipboard

Copied

Hi,

Same problem. CS6 opens dwg with layers as it should be, CC makes a mess.

Please, make fix asap.

Thanx.

Petr

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2