Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


PNG not placing with transparency in illustrator cc

Participant ,
Jan 24, 2019 Jan 24, 2019

Copy link to clipboard

Copied

I cannot get a transparent png file into my Ai document. They come in with a black background.

I have never had this issue before-till this week. I used to work with these all the time!

Is there some setting that i may have inadvertently checked off?  the png was saved correctly out of photoshop, and I can see the transparency in bridge.

Importing photoshop files with transparency is still working fine. it's only PNGs that are the problem.

anyone? thanks!

Views

36.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Participant , Jan 24, 2019 Jan 24, 2019
I've tried all methods. dragging from finder, dragging from bridge, using place command.I've triedembedding, using various view options.It used to work fine for me too.something mysterious has happened just in the last week, and i have no idea what.although, the one thing that i forgot to try and i just did- use older PNGs (not recently created ones.)success!That narrows it down. I must be having a Photoshop problem, not an illustrator problem.

Likes

Translate

Translate
Participant ,
Jan 24, 2019 Jan 24, 2019

Copy link to clipboard

Copied

also, I did try various methods of saving the PNG, as I thought mabye "save for web was the problem, but when i "saved as" a PNG from photoshop, it was an even worse result. once again, it looked fine in bridge. but when placed in illustrator, the whole thing looks like a broken up noise pattern.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Jan 24, 2019 Jan 24, 2019

Copy link to clipboard

Copied

How are you placing them? I've tried it now with a bunch of png's and they are all coming in fine

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 24, 2019 Jan 24, 2019

Copy link to clipboard

Copied

I've tried all methods. dragging from finder, dragging from bridge, using place command.

I've triedembedding, using various view options.

It used to work fine for me too.

something mysterious has happened just in the last week, and i have no idea what.

although, the one thing that i forgot to try and i just did- use older PNGs (not recently created ones.)

success!

That narrows it down. I must be having a Photoshop problem, not an illustrator problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 18, 2019 Mar 18, 2019

Copy link to clipboard

Copied

I'm having this issue. These PNGs were created in Photoshop. I've tried re-exporting but none of them will place in illustrator without looking like this. They look fine in everything else, including placing them back into Photoshop comps as a smart object or smart link… Only thing working for use in Illustrator is to save them to another format again… like .psd… I would really like to use the lighter weight library in .png that I made. [all these images are with alpha channel/transparency]… Adobe, please fix.

Screen Shot 2019-03-18 at 11.18.41 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 18, 2019 Mar 18, 2019

Copy link to clipboard

Copied

Can you post the original file? Because only with the screenshot it will be impossible to fix.

Also: post it to http://illustrator.uservoice.com That's the place where the engineers are.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 18, 2019 Mar 18, 2019

Copy link to clipboard

Copied

I think I've I figured it out… 16bits/Channel.. my source .psd files are set to 16bit/Channel, and retain it on the export to .png, with which Illustrator doesn't like, changing it to 8bit per channel color and exporting seems to avoid the glitch in illustrator, though it supports 16 bit .psd files no issue.

Gonna batch process all of these to 8bit now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 05, 2019 Nov 05, 2019

Copy link to clipboard

Copied

I am having this same problem - how does one change something to 8bit?  In plain english please I am not so great at understanding some jargon 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 05, 2019 Nov 05, 2019

Copy link to clipboard

Copied

This is explained in the documentation:

https://helpx.adobe.com/photoshop/using/image-essentials.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 16, 2020 May 16, 2020

Copy link to clipboard

Copied

The image mode option(s) may resolve your issue.

I changed my 8-bit (transparent background).png image file from indexed color to RGB color in Photoshop (CC) and dragged it from my desktop into an opened Adobe Illustrator (CC) .ai file. The transparent background remained after that procedure.

ImageModeOptions.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 17, 2020 May 17, 2020

Copy link to clipboard

Copied

Please show.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 17, 2020 May 17, 2020

Copy link to clipboard

Copied

ImageMode_IndexedColor.png

IMAGE MODE - Indexed Color 

-----------------------------------------------------------------------------------

ImageMode_RGB.png

IMAGE MODE - RGB 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 17, 2020 May 17, 2020

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 17, 2020 May 17, 2020

Copy link to clipboard

Copied

IMAGE_MODE_Indexed_Color_PhotoshopCC.png

IMAGE MODE - Indexed Color

-------------------------------------------------------------------------------------------------------------------------------------------

 

IMAGE_MODE_RGB_PhotoshopCC.png

IMAGE MODE - RGB

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 26, 2020 Nov 26, 2020

Copy link to clipboard

Copied

I'm having this problem persist even after resetting Photoshop's image mode to RGB 8 bit. Trying to finish an assignment in Illustrator; frustrated...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 26, 2020 Nov 26, 2020

Copy link to clipboard

Copied

Are you comfortable with uploading one of your images here so I can see what you having difficulties with?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 04, 2020 Dec 04, 2020

Copy link to clipboard

Copied

same! this is infuriating and completly disrupting my workflow

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 05, 2020 Dec 05, 2020

Copy link to clipboard

Copied

Hi Jessicama,

I solved it by exporting the PNGs from an older version of Photoshop. Not a great solution... but it worked

c

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 06, 2020 Dec 06, 2020

Copy link to clipboard

Copied

Can you share such a file?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 07, 2020 Dec 07, 2020

Copy link to clipboard

Copied

ADS-MRR2.png

I don't know if there is a way to attach VS inserting an image here, I hope it doesn't change or compress the image in a way that it'll now work when you place it in Illustrator.

I'm running the latest Illustrator, I'm on a MAC. I've heard this has been an issue for people with MacOS and Illustrator for many years so the versions and OS systems really probably aren't the issue here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 07, 2020 Dec 07, 2020

Copy link to clipboard

Copied

I view it on a Mac too.

Looks like there is nothing wrong with this image when place in Illustrator.

Maube you can shar a simple Illustrator file that shows the problem.

CC folder filesharing, DropBox, WeTransfer, Google sharing...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 07, 2020 Dec 07, 2020

Copy link to clipboard

Copied

I just re downloaded the image from here and tried again, same issue.

Different illustrator files will yield the same result so it's not the illustrator file.

Screen Shot 2020-12-07 at 1.14.04 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 05, 2021 Feb 05, 2021

Copy link to clipboard

Copied

In case anyone is still running into this issue in 2021. 

I attempted to import a PNG-8 as saved in the "export for web legacy" panel. Apparently Illustrator does not recognize this PNG type as far as transparency is concerned. 

I was successful with placing the image in illustrator once I resaved the image as a PNG-24. 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 06, 2021 Feb 06, 2021

Copy link to clipboard

Copied

interesting thanks I'll make sure its a 24 next time.  That is probably the reason why come work and others dont.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 14, 2021 Feb 14, 2021

Copy link to clipboard

Copied

Still intermittently happening. so annoying. This is probably my issue. i usually use the "legacy" panel, it's just so much easier to navigate and has so much better UI ...when working fast it's a lifesaver. why oh why can't they just leave good stuff alone. LOL  I am still kind of mad at the legacy-ization of this thing. If they ever take it away I'm done for.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2