• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Check boxes: checkmark resizes on click away

Explorer ,
Apr 05, 2018 Apr 05, 2018

Copy link to clipboard

Copied

Hi,

I'm running InDesign CC 13.1 (latest version) on Windows 10, and I'm trying to create check boxes on an interactive map that our staff will use to track progress as they complete various training courses.

I have successfully set up two variations of the check boxes -- one that is just a checkbox overlaid above the map marker graphic, and one using some map marker graphics I created. I have set up all six appearance states for both of the check box options.

When I export to PDF, they work great — until I click away from them. Then the checkbox field resets with a huge check mark filling the clickable space. This happens in both Acrobat DC Reader and Pro apps. Here are some screen shots:

Overlay version (where checkbox field is just sitting on top of the underlying map marker):

Initial view:

Clicked:

After click-away:

Custom version (where the states are linked versions of the marker graphic and I've deleted the check mark from all states):

Initial view:

As you can see, the marker is missing for some reason.

How it is supposed to look in the initial view:

Clicked:

After click-away:

Am I doing something wrong? I followed the steps exactly as I've seen them repeated in several places online, and I can't figure out why the appearance is resetting like this. I feel like there's an inactive state beyond the 6 states that needs to be set (or something like that...).

Thanks in advance for your help!

JN

Views

631

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Guide , Apr 06, 2018 Apr 06, 2018

Hi

About the missing marker (custom version), hard to tell without seeing your Buttons and forms panel, with all states... maybe you could share a screenshot?

About the "giant tick" issue, here's my guess:

(pasted from Re: InDesign checkbox appearance in Acrobat )

"I believe you are talking about the (annoying) "Highlight existing fields" Acrobat (reader/pro) feature. You can turn it off in Acrobat, but be aware this is an application setting, not a document one.

So, even if the PDF is displayed fine

...

Likes

Translate

Translate
Guide ,
Apr 06, 2018 Apr 06, 2018

Copy link to clipboard

Copied

Hi

About the missing marker (custom version), hard to tell without seeing your Buttons and forms panel, with all states... maybe you could share a screenshot?

About the "giant tick" issue, here's my guess:

(pasted from Re: InDesign checkbox appearance in Acrobat )

"I believe you are talking about the (annoying) "Highlight existing fields" Acrobat (reader/pro) feature. You can turn it off in Acrobat, but be aware this is an application setting, not a document one.

So, even if the PDF is displayed fine for you, this feature might be turned on in any other user application.

Now, here comes the trick: you can use a small JavaScript code in order to turn it off by default while opening the PDF.

In Acrobat Pro, go Tools > JavaScript > Document JavaScripts, create a new Script (name it as you wish), click add and replace the existing bit by: app.runtimeHighlight = false;

Click OK and you should be done."

Note: default color for highlighting fields is light blue but it can be changed through preferences

Here's an animated illustration of your replicated issue:

(Mettre les champs existants en surbrillance = Highlight existing fields)

checkk.gif

Hope that helps

Vinny

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 06, 2018 Apr 06, 2018

Copy link to clipboard

Copied

vinny38  wrote

… Now, here comes the trick: you can use a small JavaScript code in order to turn it off by default while opening the PDF.

In Acrobat Pro, go Tools > JavaScript > Document JavaScripts, create a new Script (name it as you wish), click add and replace the existing bit by: app.runtimeHighlight = false;

Click OK and you should be done.

Hi Vinny,

for that to work—also an application setting, no document setting—the customer has to turn on JavaScript in the Reader. And only Adobe Acrobat Reader on Windows or Mac OS X will be able to work with JavaScript for PDF, I think.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 06, 2018 Apr 06, 2018

Copy link to clipboard

Copied

LATEST

This totally fixed the issue, THANK YOU!

(PS: The animated walkthrough was really helpful — I sincerely appreciate the time you put into your response!)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines