Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Edge smoothing in Indesign creates lines where there should be none!

Explorer ,
Jul 16, 2021 Jul 16, 2021

Copy link to clipboard

Copied

Something that is extremely annoying and obstructive when designing. This was once different and better!

No matter if e.g. black or dark frames with white "narrow - narrow" outline or areas that cover others, hairlines appear everywhere where there shouldn't be any.

I don't know with which update this has crept in. But it nevt infinitely and it was no improvement.

The only way to get rid of these lines is to disable edge smoothing completely. But then you have a pixelated view with the charm of the 80s. So this is not an alternative either!Bildschirmfoto 2021-07-16 um 19.40.31.png

Bildschirmfoto 2021-07-16 um 19.45.47.pngBildschirmfoto 2021-07-16 um 19.40.07.pngGPU Unchecked.png

TOPICS
Bug, Performance

Views

373

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Community Professional , Jul 18, 2021 Jul 18, 2021
The problem is the rules of mathematics, understanding what creates the phenomenum lets us work around it. It is not a bug it is a limitation of how things are designed. As for the stroke when you have a Gap colur the colour is calculated to be a full width stroke under the stroke (why the artifact appears). Knowing this the sroke can be designed in the reverse as shown here (you will need to switch the gap and the fill colours) Here the stroke is made of the Gap with the stroke being over. Sin...

Likes

Translate

Translate
Adobe Community Professional , Jul 18, 2021 Jul 18, 2021
disable edge smoothing completely Hi @Tom Reuter , it could be happening because of your Display Performnce Anti-Aliasing setting—maybe that’s what you mean by edge smoothing?. I can replicate your problem by turning it on, which is the default for High Quality: Anti-Aliasing is only needed for display quality where there will always be compromises. It shouldn’t be a problem for high resolution print output where there would be no anti-aliasing in the RIP.

Likes

Translate

Translate
Adobe Community Professional ,
Jul 17, 2021 Jul 17, 2021

Copy link to clipboard

Copied

Hi Tom,

did you try to disable GPU support entirely for InDesign?

See InDesign's Preferences.

 

Regards,

Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 18, 2021 Jul 18, 2021

Copy link to clipboard

Copied

Hi Uwe,
You mean by "completely" quasi from the bowels of Indesign? How does that work? And what do I have to delete? GPU unfortunately does not work with Adobe at all, at least not without multiple problems.

Du meinst mit "komplett" quasi aus den Eingeweiden von Indesign? Wie geht das? Und was muss ich löschen? GPU funktioniert ja leider mit Adobe überhaupt nicht, zumindest nicht ohne multiple Probleme.

Beste Grüße
Tom Reuter

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 18, 2021 Jul 18, 2021

Copy link to clipboard

Copied

The GPU was already deactivated in advance in all screenshots. s last screenshot

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 18, 2021 Jul 18, 2021

Copy link to clipboard

Copied

Do you want a stroke? If so make a difference in size between the objects.

The hairline you are seeing is a result of antialiasing, and is an on screen artifact created by the constrains of mathematics. If you are trying to get a custom dashed line you can do as you are doing but make the box below slightly larger. The effect of having the lines dissapear will vary with zoom level, and is only affecting the representation on screen.

(you will get similar artifacts if you have a selection in photoshop, fill with black and then fill with white)

What is happening is that the computer is faking more resolution that you have by making partially darkened pixels on the screen grey rather than black or white. When you add the white box, pixels that are partially white will be lightened by the % covered by white to simulate since screen pixels cannot be split. Because if you darken by 50% and then lighten by 50% you don't end up at zero, you will get tis happen at certain zoom levels, and certain positions. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 18, 2021 Jul 18, 2021

Copy link to clipboard

Copied

Hi Lukas,

Yes, I know that these lines vary depending on the zoom level. Which unfortunately does not make it better. But the setting of my monitor is on original resolution and not scaled.

The artifacts that happen today in Indesign are new to me at least. Because I know that these lines did not exist before (at least not for me).

The lines appear e.g. also if one uses another, than the continuous line with borders, (thus e.g.: "Wide - wide" s. Screenshot) and the background is darker than the line.

However, it disturbs the design and I always have to explain it to my customers.

I know the lines in the kind of course already for years from Akrobat and know therefore around the trigger "the edge smoothing" and that they are not mher there in the pressure then. Nevertheless, the display is incredibly annoying.

If I knew with which update they came, I would posthaste install the old version of Indesign again. The updates have been buggy lately anyway.

However, I would find it even better if the old display state could be restored, as it was, namely good.

Thanks to you in any case

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 18, 2021 Jul 18, 2021

Copy link to clipboard

Copied

By the way, that linese appears whrer no lines should be, also happens recently when you put a cropped image in a frame with effect! This is also new for me.

s. Screenshot: on the left inserted into the frame on the right image above the frame

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 18, 2021 Jul 18, 2021

Copy link to clipboard

Copied

The problem is the rules of mathematics, understanding what creates the phenomenum lets us work around it. It is not a bug it is a limitation of how things are designed. As for the stroke when you have a Gap colur the colour is calculated to be a full width stroke under the stroke (why the artifact appears). Knowing this the sroke can be designed in the reverse as shown here (you will need to switch the gap and the fill colours)

Screenshot 2021-07-18 at 18.58.50.png

Here the stroke is made of the Gap with the stroke being over. Since there is no double strokes you do not get this effect. When it comes to your photos it could be how you are masking that is creating your problem. Clipping the object so that you do not have the edge of a mask will ensure that you do not have missmatch in edge pixels.

Screenshot 2021-07-18 at 19.33.14.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 19, 2021 Jul 19, 2021

Copy link to clipboard

Copied

@Lukas EngqvistHey Lukas, big thanks for the tip with the lines, this will be helpful, because my brand new logo uses this kind of lines and the "Visual effect (Antialaising)" of the thin lines arround quite kill my nerves.

4 the picture:

it is a completely transparent image in the outer edges and the effect only occurs when I insert it into a frame and give the frame an effect like . E.g. drop shadow inside, which I like to use now and then as a vignetting effect and that for years.

In 2019, this problem definitely did not exist yet, because I used this effect x times with exactly the same and other images in a pitch.

In the meantime, I'll just put an empty frame with the effect over the transparent image and multiply it. A bit awkward but an intermediate solution without annoying lines.

This always takes a lot of explaining, especially in times of TEAMS sessions with the client, and is time consuming for that reason alone. Also not reasonable for the customer.

Anyway I thank you for the solution attempts
and hope I can return the favor one day

with best regards Tom

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 26, 2021 Jul 26, 2021

Copy link to clipboard

Copied

LATEST

Filing this info too @Lukas Engqvist ,

 

It just got real

 

Be safe

mj

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 18, 2021 Jul 18, 2021

Copy link to clipboard

Copied

@Lukas Engqvist Yes indeed in Photoshop the same bug happens now. omg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 18, 2021 Jul 18, 2021

Copy link to clipboard

Copied

Hi @Tom Reuter ,

 

I see you've posted on the Indesign User Voice more than a week ago with no response. The InDesign team is meant to be following that thread.

 

I've tried to recreate your problem unsucessfully. 

 

Are you applying effects to empty and solid frames? Have you checked Object Styles to make sure nothing weird is going on there?

 

Consider resetting ID preferences to purge any changes to default settings.

 

Best

mj

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 18, 2021 Jul 18, 2021

Copy link to clipboard

Copied

No these frames are without anykind of effects. look at IDML

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 18, 2021 Jul 18, 2021

Copy link to clipboard

Copied

Hi @Tom Reuter ,

 

Where did you post the IDML file? 

 

I don't seem to see it on this thread.

 

This must be painfully frustrating for you.

 

Let's try and get to the bottom of this

 

Best

mj

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 18, 2021 Jul 18, 2021

Copy link to clipboard

Copied

Yes u r right. Of course that's frustrating.

(IDMLs are unfortunately not uploaded here)
I have uploaded now in my Highdrive to share

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 18, 2021 Jul 18, 2021

Copy link to clipboard

Copied

Forgotten the Link:
https://hidrive.ionos.com/lnk/rXEOnCfb

Thx 4 help

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 18, 2021 Jul 18, 2021

Copy link to clipboard

Copied

I have also deleted my preferences.
The effect with the lines remains. Unfortunately.

(IDMLs werden hier leider nicht hochgeladen)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 18, 2021 Jul 18, 2021

Copy link to clipboard

Copied

By the way I have the same problem with my MacBook where Mojave is installed, so it doesn't seem to be specific only to my iMAC Pro.
I've looked at this on a variety of screens to rule out that the screens and their resolutions are the problem, but it was allways the same. (All screens have the original physical resolution)

I have reinstalled an ancient version of Indesign that I was sure was still good. But now also there appear these hairlines.

This makes me suspect that the problem is not directly with Indesign itself, but rather with a component (OPenGL? CPU/GPU components or whatever?) that all Adobe applications share.

 

Because the high resolution preview in Indesign, seems to in whatever way, fall back on parts of these global components and smooth the edges, even though this is extra disabled in the preferences.


If you think about the massive problems of Adobe with the GPU support and the so far failed attempts to fix this for all, then it is obvious that the rabbit lies in the pepper. They are working feverishly to get this working for the new Macs and apparently a few here and there with older systems (Catalina) and Macs like me are falling off.

Mayby an update to BigSur could be helpful. But ...  I'm not sure if I'm going to have any other problems. I mean, the name "Bugs Sure" in the forums is not a coincidence. Or?

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 18, 2021 Jul 18, 2021

Copy link to clipboard

Copied

Hi @Tom Reuter ,

 

Thanks for the IDML share.

 

OK, here's what I found.

 

I don't think there's anything wrong with your settings or prefs.

 

It seems to be be the way ID is processing the information.

 

Two ways to get around this imho.

 

  1. Tweak the way you work slightly to accommodate for the artifacting.
  2. Image it to a print device and see if the problem persists. It is visible under high magnification, so it might be like a PDF/X1a aritifact, which e might be able to ignore.

 

Page 1, the double line on the circle creates the the artifact. If we choose another line type it does not show.

Page 2: If we reduce the black block behind by a factor of 0,3%, the artifiact goes away. Or if we introduce a stroke of 0,1mm on the top object, it also goes away.

Page 3: Same

Page 4: Same

Page 5: Making the Black object shorter so it touches the Pantone Stroke works for that.

Page 6: Placing a stroke or making the the white box slightly deeper sorts that.

 

No amount of preferences and GPU settings changes are going to make this go away @Tom Reuter . I don't think.

 

Tweak your workflow while you wait for Adobe to give you answers

 

Hope this helps

mj 

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 19, 2021 Jul 19, 2021

Copy link to clipboard

Copied

HI @mj 

Hey thanks for your effort, work and heart.
I knew it was just a visual effect like in acrobat and thought that was clear. I just didn't say that unfortunately.

But unfortunately the translator has translated "edge smoothing" with edge smoothing and not with anti-aliasing and I hold myself a little on the forehead, because I as an old gamer, had quite known.

So thanks again for your commitment and your time! I wish u the best of the best
tom

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 19, 2021 Jul 19, 2021

Copy link to clipboard

Copied

Hi @Tom Reuter ,

 

Thank you for your kindness in turn sir.

 

That seems to make more sense now 🙂

 

Appreciate your attention to detail man. As I was working through your file, I could not help reminding myself that I should be as thorough as Tom.

 

i guess a connection of hearts and minds can occur through an InDesign  challenge. Who would have thought?

 

Best of the best to you.

 

Be safe

mj

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 19, 2021 Jul 19, 2021

Copy link to clipboard

Copied

@mj @Laubender @rob day @Lukas Engqvist 
As a small thank you for your efforts!
One of my Indesign MockUps. Maybe one or the other can use it quite well.

Toms-MockUp.png

 (Of course without background and cup)
https://hidrive.ionos.com/lnk/rBkOn3K5

I like to use it for my references or presentations. Super fast and easy. "Via drag and drop motif exchange. Done.

Maybe some decoration, a cut out plant, a cup, a chocolate cookie and a nice background with some light modulation via Indesign. Who needs Photoshop lol :D. Just kidding.

So thank you ver much and do whatever you want with the MockUp. (Sure, please do not sell ...laugh 😉 but I think I do not need to tell you)

With the best regards
Tom Reuter

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 20, 2021 Jul 20, 2021

Copy link to clipboard

Copied

Thst's very kind of you @Tom Reuter ,

 

Thanks for spreading the creative love.

 

Stay safe

mj

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 20, 2021 Jul 20, 2021

Copy link to clipboard

Copied

Image it to a print device and see if the problem persists. It is visible under high magnification, so it might be like a PDF/X1a aritifact, which e might be able to ignore.

 

Hi @mj, it’s possible to imitate RIP output by exporting a PDF and opening it into Photoshop at the output device resolution with Anti-Aliasing turned off.

 

So here is page 1 of @Tom Reuter’s ID file exported to PDF/X-1a and opened into Photoshop at 1200ppi, with Anti-Aliasing on and off:

 

AA Off:

Screen Shot 10.png

 

AA On (a RIP would not anti-alias)

Screen Shot 11.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 18, 2021 Jul 18, 2021

Copy link to clipboard

Copied

disable edge smoothing completely

 

Hi @Tom Reuter , it could be happening because of your Display Performnce Anti-Aliasing setting—maybe that’s what you mean by edge smoothing?. I can replicate your problem by turning it on, which is the default for High Quality:

 

Screen Shot 2.pngScreen Shot 3.png

 

Anti-Aliasing is only needed for display quality where there will always be compromises. It shouldn’t be a problem for high resolution print output where there would be no anti-aliasing in the RIP.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2