Errant Paste in Rotated View

Explorer ,
Mar 03, 2019 Mar 03, 2019

Copy link to clipboard

Copied

I have InDesign CC 14.0.1 running in Windows 10.

I have a book to be printed landscape and bound along the top edge.  To get that to the printer as a pdf file that his machine will handle it needs to be portrait and bound on one edge - thus with all pages rotated.

In theory the easy way to do this is to created a document with two page portrait spreads and then rotate the pages as required for editing.  I have a few hundred images to drop in.

When a spread is rotated and I drop an image in it vanishes only to be found away off to the left.  A web search says this happens but I am hoping for a fix or workaround from somebody.

Once dragged back to the page the images are fine. Layout can continue and the spread can be rotated back to the portrait orientation.

Views

619

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Mar 12, 2019 Mar 12, 2019
Below one screenshot showing the bug at work. Tried to place the selected graphic inside the margins of page 1 of the 4th spread of my document. The 4th spread view is rotated to 90° clockwise. InDesign version is 14.0.1.209:The bug forced the pasteboard to expand and the right edge of the placed graphic is in touch with the pasteboard.As I already said: This issue should be resolved with InDesign version 14.0.2.315 or above.Regards, Uwe

Likes

Translate

Translate
Adobe Community Professional ,
Mar 03, 2019 Mar 03, 2019

Copy link to clipboard

Copied

That certainly is a wacky issue. I just did some experimenting and while this doesn't fix the problem it seems to minimise the issue… a little.

Preferences > Guides & Pasteboard > Pasteboard Options

     - Horizontal Margins: 0 mm

     - Vertical Margins: 0 mm

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 04, 2019 Mar 04, 2019

Copy link to clipboard

Copied

Thanks for testing, Michael. I reset to that and the offset of the dropped file was worse.  Now I have reset to the defaults and can't see any sign of the dropped file and there is a huge gap between the pairs of pages.

To save having to lie on my side doing page layout I think the easier option will be to drop the files onto the portrait page spreads.  Then rotate the pages.  Then select all the dropped images and rotate them all at once.  Then do my layout and cancel the rotate.  Looks like that will be easier.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 04, 2019 Mar 04, 2019

Copy link to clipboard

Copied

Sounds like the best way to go. Good luck.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 04, 2019 Mar 04, 2019

Copy link to clipboard

Copied

I don't seem to get that off-page rotation with your workflow, but I do get "unexpected" results. The preview drop-cursor shows the image upright, with the cursor at the top left corner, but after clicking -- and thus "confirming" I want to place the image somewhere -- it rotates according to the page rotation, around that same top left corner. A slightly more intuitive system would have taken the view rotation into consideration and thus either show the preview rotated, or after clicking place the image "rotated" (that is, rotated per the current view) so it appears just the way one expects.

However, it might be easier to circumvent all such rotation related issues. Define your pages as landscape, not portrait, and put the view in single-page mode instead of spreads. You'll miss the binding-preview (in case you have stuff overflowing from one page to another), but you can check it more easily after exporting to PDF. And binding edge is a printers' thing anyway.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 04, 2019 Mar 04, 2019

Copy link to clipboard

Copied

Interesting that you had slightly different issues.

Yes, binding edge is the printers' thing and in this case I am the one who needs to solve it.  I made a book like this a year ago and did start with my pages as landscape.  It was quite a challenge after that to get them to two page portrait spreads for the printer.  So, as InDesign has the page rotation option I thought I should use it.  This way may still be easier than starting landscape.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 07, 2019 Mar 07, 2019

Copy link to clipboard

Copied

Hi dickveitch ,

can you give some details about page size and spread view rotation angle?

And yes, there are some bugs with view rotated spreads.

E.g. try to change the origin of your coordinate space by dragging the cross-hair of the area where both rulers meet.

If you drop that to a specific coordinate the origin will not land at this specific point.

Example in screenshots from my German InDesign where I set up a facing pages document with A4 page size ( 210 x 297 mm ) and rotated the spread view to 90° clockwise. Ruler origin is Spread Origin by default. I'd like to change that to the upper left corner of the margins on page 2 as seen on my monitor:

SpreadView-Roated-90°CW-1.PNG

SpreadView-Roated-90°CW-2.PNG

I dragged the cross-hairs out and moved them to the indicated position ( red arrow in the screenshot above ), but the new origin is somewhere else:

SpreadView-Roated-90°CW-3.PNG

This is a bug since version CS5 I think, the first version that was able of rotating the view of spreads.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 07, 2019 Mar 07, 2019

Copy link to clipboard

Copied

Thanks.  Interesting observations but they don't really change the way I can make it work.  My setup of the pages is exactly as you describe.

I am now progressing well with my book and my answer to the initial problem is to drop all my images onto the double page portrait spread.  Then rotate the spread 90 degrees CW.  Then grab all images as a bundle and rotate them 90 degrees CCW.  Then work on the layout.  Rotate the spread back to be a two portrait spread.  All is well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 07, 2019 Mar 07, 2019

Copy link to clipboard

Copied

dickveitch  wrote

…When a spread is rotated and I drop an image in it vanishes only to be found away off to the left. …

Hi dickveitch ,

I cannot see this behavior if I am using the Place… command and drag out a graphic frame with the loaded placegun cursor.

Also cannot see this issue when dragging in an image file to my layout page from the file system.

How eaxctly do you drop an image in?

Did my tests with German InDesign CC 2019 version 14.0.1.209 on Windows 10 with a rotated spread view set to 90° clockwise.

Ruler origin is Spread Origin if that makes a difference. Document setup is just like my screenshots are showing in reply #6 above.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 07, 2019 Mar 07, 2019

Copy link to clipboard

Copied

I tested Place - a slow way when there are up to 8 images per spread.  The image vanished.

I drag and drop to the spread when it is not rotated - works fine.  After the pages are rotated and I do a drag and drop, they vanish or may be visible away out to the left if I zoom out and out and out.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 07, 2019 Mar 07, 2019

Copy link to clipboard

Copied

Hi dickveitch ,

hm. I can only tell that it's working perfectly for me on my Windows machine.

Maybe something's wrong with your document? Or something's wrong with your preferences?

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 07, 2019 Mar 07, 2019

Copy link to clipboard

Copied

I know others have this problem and see Michael Bullo above.

Yes, it may be something in the preferences but I am working with the defaults and there are hundreds of them which I do not dare to change.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 08, 2019 Mar 08, 2019

Copy link to clipboard

Copied

What I did not test are other rotation angles, other than 90° clockwise.

Check if you are doing this on spread views that are not 90° clockwise.

I also like to see a video about the issue.

Or if you could share the InDesign document plus one sample image via Dropbox and post the link.

You could also send me a link via personal message: Hover over my name and click the "Message" button.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 12, 2019 Mar 12, 2019

Copy link to clipboard

Copied

dickveitch  wrote

I know others have this problem and see Michael Bullo above.

The big difference with my tests and your issue is: I did test only on the first spread of a document!

But the bug can be seen only on the second spread or consecutive spreads of a document.

The higher the distance from the first spread the more significant the error in placing you'll see.

Ahem: Stumbled over my own reply at InDesign Uservoice from October last year. Ugh. I had totally forgotten about this…

Quoting myself:

I can confirm the issue. Just tested.
If the spread is rotated the image will be placed somewhere else if you do not place it on the first spread of a document! That will happen when you click the place gun to unload it or if you drag out a rectangle with it.

I also see a big difference to CC 2018.1 not only where the image is placed, but how it is rotated when it is placed. With CC 2018.1 it is placed so that the rotation of the view has no impact. With InDesign CC 2019 rotation of the view will also dictate rotation of the image while placing. And that's perhaps a good thing. Make it a preference one can turn on or off so that the user can decide if the image is placed and rotated with the rotated view or not.

Here the link to the thread:

can't place image on rotated page – Adobe InDesign Feedback

In the meanwhile the developers have fixed the issue with the latest bugfix version of InDesign that is currently only available at InDesign Prerelease.

Quoting Abhinav Kaushik, InDesign Qualitiy Engineer from the same thread:

Hello All,

The fix for this issue is now available in the beta builds of InDesign. You can download the latest beta build from Download section of InDesign Prerelease portal.

1. Go to https://www.adobeprerelease.com
2. Log in with your Adobe Id.
3. Once logged in, search for “InDesign CC Prerelease” program in the list.
4. Click on the program to join the same.
5. You can now download the build (14.0.2.315) from “Builds and Plugins” section on the page.
6. The steps for installing the build can be found in the release notes

Had no chance to test the new build yet, but will do.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 12, 2019 Mar 12, 2019

Copy link to clipboard

Copied

Below one screenshot showing the bug at work. Tried to place the selected graphic inside the margins of page 1 of the 4th spread of my document. The 4th spread view is rotated to 90° clockwise. InDesign version is 14.0.1.209:

Issue-PlacedGraphicOnSpread4.PNG

The bug forced the pasteboard to expand and the right edge of the placed graphic is in touch with the pasteboard.

As I already said: This issue should be resolved with InDesign version 14.0.2.315 or above.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 12, 2019 Mar 12, 2019

Copy link to clipboard

Copied

Thanks for persisting with your review of this problem.  I look forward to having version 14.0.2.xxx when I do my next book like this in January 2020.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 12, 2019 Mar 12, 2019

Copy link to clipboard

Copied

Further question, Uwe. You noted above that the bug forced the pasteboard to expand.  When the pages are rotated back into position the expanded pasteboard rotates as well.  This results in huge spaces between the spreads.  Any way to fix this?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 13, 2019 Mar 13, 2019

Copy link to clipboard

Copied

LATEST

Hi Dick,

just tested placing graphics with the latest Prerelease version 14.0.2.321.

The bug is fixed!

About the expanded pasteboard:
As soon as you move back the misplaced objects from the pasteboard to the page the pasteboard size should shrink back to its normal size. If that will not happen you can try to set a different pasteboard size in the preferences. Other workaround: Do a new spread and move all the elements on the pages ( not on the pasteboard ) of this other spread to the new one. Remove the old spread.

Export to IDML and open the IDML file as document would be the final options.

But watch out for changes ( any changes! ) if you compare the new document to your original one if you do so.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines