• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
0

Font showing up bolder on some pages

Guest
Apr 18, 2009 Apr 18, 2009

Copy link to clipboard

Copied

Hi,

when I generate a PDF file from my Indesign file, some of the pages end up with the font being noticeably thicker than others.

Please see the attached PDF - pages 4, 7, 8, 10 and 15 have this bolder-looking text on them.

My whole actual PDF file is over 100 pages and this sort of problem occurs on about 25-35% of the pages.

I have no idea what could be causing this.

Any ideas?

Thanks

Chuckee

Views

58.7K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Nov 27, 2018 Nov 27, 2018

I think I have the solution.

This issue (that some fonts seem bolder in the pdf) is caused by some effect. It can be a drop shadow, an inner shadow, a blending mode option or something like that. And it is happening on the texts that are on the blank areas. Right?

So the solution is to have the text block filled with white instead of blank.

I had the same issue for so long but the above solution has worked 100%.

Cheers, dudes.

Votes

Translate

Translate
Advisor ,
Apr 18, 2009 Apr 18, 2009

Copy link to clipboard

Copied

Your PDF is still queued, two hours later, but I'd be willing to bet this is a transparency issue. Transparency affects how text is rendered on the screen. It shouldn't affect how it's rendered when printed (although this has also been reported). It's difficult to explain to clients.

The fix I've read about is to put text on a higher layer than the transparent object, but I haven't been able to make this work. Last time I ran into this I put an empty 99% stroke opacity text box on the master page so that every page had this effect. Better bolder on every page than bolder on some pages.

Ken Benson

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Apr 18, 2009 Apr 18, 2009

Copy link to clipboard

Copied

Turning everything bold is a bit extreme And not very satisfactory. I find the layers solution works well.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Apr 19, 2009 Apr 19, 2009

Copy link to clipboard

Copied

Hi again,

I've determined that every page that has a bolder font on it has either a JPEG or a PSD image inserted on it.

I also have AI images inserted on other pages, but the text on those pages is fine.

So... this looks like it is a problem (a bug with the software?) related to the insertion of JPEG/PSD and other images (it also happens with TIFF/PNG files).

I see it has affected at least one other person who never managed to fix the problem:

http://forums.adobe.com/message/1294549#1294549

Things aren't looking good for me... do other people not have a problem when inserting images into their documents? Surely this problem cannot affect everyone like this?

Also, my knowledge of layers is nonexistent. I've never used them so don't like my chances of having to rework a 120 page document separating all of the text onto another layer (plus, this wouldn't work anyway because all of the images need to remain inline so that future alterations to the text will result in the images staying in the correct place in relation to the text).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 19, 2009 Apr 19, 2009

Copy link to clipboard

Copied

As Ken said, this is a display issue having to do with how transparency is rendered. That transparency can be in the form of a layered or transparent image, or (since jpegs don't support either of those features) some effect, such as a drop shadow applied in InDesign, which is why adding a transparent item to the master page will work to make all of the text render the same on screen.

While there are some occasional reports, I think, of the emboldened type printing on a desktop printer, I don't recall seeing any reports of the same on a press.

Peter

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Apr 19, 2009 Apr 19, 2009

Copy link to clipboard

Copied

Peter - the jpegs that I have inserted do not have any effects at all applied to them.

Also, the PDF I generate is for electronic viewing only so it is important that I have the text look the same on every page and the bolder text just looks bad, so I don't want to have the bolder text on every page.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 19, 2009 Apr 19, 2009

Copy link to clipboard

Copied

chuckee wrote:

Peter - the jpegs that I have inserted do not have any effects at all applied to them.

Also, the PDF I generate is for electronic viewing only so it is important that I have the text look the same on every page and the bolder text just looks bad, so I don't want to have the bolder text on every page.

The transaprency needn't be applied to the jpeg, or even be on the same page in a multipage spread, to cause this.

The only way I know to prevent this is to use only non-transparent images and never use any effects. As one of my former professors used to say, "That's a design decision."

Peter

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Apr 19, 2009 Apr 19, 2009

Copy link to clipboard

Copied

Thanks for replying Peter. As far as I know, I don't have any transparency. I have just inserted jpegs, psd's, png's, and ai files.

I had a look at the Pages view and couldn't see an chequerboards (thanks for the tip Noel).

I haven't ever turned on transparency for any of the images I've inserted, or turned on any other effects.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 19, 2009 Apr 19, 2009

Copy link to clipboard

Copied

Is this confidential? Can you package the file and zip it, then send me a private message (click my name or avatar to go to my profile, then use the actions panel) with a link to a server location? you can use yousendit.com, for example.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Apr 19, 2009 Apr 19, 2009

Copy link to clipboard

Copied

A quick way to check for transparency is to open the Pages panel and look for

chequerboards.

--

Noel

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Apr 19, 2009 Apr 19, 2009

Copy link to clipboard

Copied

Has some but not all of the text been turned to outlines?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Apr 19, 2009 Apr 19, 2009

Copy link to clipboard

Copied

Peter - thanks very much for the offer. I will upload the package tomorrow at work (it is about 70MB). I really appreciate this because this problem has plagued me for many months now. I'll PM you when it's uploaded.

Jeremy, the text just looks bolder/thicker. I don't see just outlines.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Apr 20, 2009 Apr 20, 2009

Copy link to clipboard

Copied

Yes, it was unlikely, but in my own experience, if I'm focussed on one thing, I find it very easy to overlook something else very obvious. I can easily imagine myself getting more and more focussed on issues such as transparency, text on uppermost layers, etc., and completely overlooking two "obvious" possibilities:

(1) Text that has been converted to outlines (i.e. it consists of vector paths rather than editable text) tends to look a bit heavier in PDFs (to my eyes).

(2)  A previous user might have tried to achieve a bold effect by applying a very thin but non-zero stroke to a font that doesn't have its own bold typeface.

Apologies if you are unlike me, and always check the obvious first!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 20, 2009 Apr 20, 2009

Copy link to clipboard

Copied

A long shot

What can happen is that you have images with that have transparency.

And you have transparency flattner preset that says Convert Text to Outlines.

When it hits a page with transparency it converts the text to Outlines. Which makes the glyphs bolder.

To see if this is the problem check the Transparency Flattner Presets and see what one you're using and if Convert Text to Outlines is applied.

If it is, then turn it off.

Everything else here is spot on. Put text on a higher layer. Make sure it's not coverted to outlines. Make sure there are no strokes on the text.

The Strokes on the text is also a likely candidate - because the Low and Medium Flattner Presets have Convert All Strokes to Outlines. Only the High preset has the Convert All Strokes to Outline turned off.

Hope that helps somehow.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Apr 20, 2009 Apr 20, 2009

Copy link to clipboard

Copied

One more suggestion: My battles with transparency turning text dark (which, as in your case, is critical since my end-product is the online PDF) were resolved when I stopped Exporting to PDF from InDesign and began Printing to PDF.

Dave

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 23, 2009 Apr 23, 2009

Copy link to clipboard

Copied

Chuckee sent me the file and I've been looking it over.

The file is non-facing pages and most pages do not contain any transparency. On my Windows system the type looks normal on those pages until I switch to Overprint Preview, at which point it gets slightly bolder, an expected behavior that has been around forever.

I've tried exporting and printing to PDF, and the only pages that appear darker to me are the exported pages with unflattened transparency (I cheated for testing by duplicating a page with with an image, then making that image 99% opaque).

I looked at the file history, and I note that it was originally a CS2 document. I'd recommend you export to .inx from CS3 to remove the missing plugins references. It's also a Mac doc, and I'm on Windows. I have some vague memories that this issue behaves differently on the two platforms, and that may in fact be what Chuckee is seeing. I'm inclined to suggest trying an export to PDF/X-1a to see if that helps.

I was going to ask why this wasn't set up as facing pages, but I've just remembered that you said it was going to be distributed as an on-screen PDF, not printed. My personal inclination would still be to make facing pages now to mirror your page borders, and then it would be ready to re-purpose for print when it becomes wildly popular. You can set the file properties in the PDF to open as a two-page spread with single cover page.

Not much help, I'm afraid.

Peter

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Apr 24, 2009 Apr 24, 2009

Copy link to clipboard

Copied

OK - I've tried everything that people have suggested, and no luck.

Peter - thanks for looking at the file. Can I ask what you meant by "the only pages that appear darker to me are the exported pages with unflattened transparency."

If that is the case, then how can I remove this unflattened transparency from those pages, while still keeping the images there? I really don't know if this is possible or not.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 24, 2009 Apr 24, 2009

Copy link to clipboard

Copied

As I said, this may look different on Mac than it does on PC. They use different schemes for rendering type.

In my testing pages with transparency ALWAYS show emboldened type in InDesign, and ALL pages show it if you switch to overprint preview. I think this has to do with the overprint preview engine, which I don't claim to understand.

When I export to PDF using a preset like [Press Quality] with a compatibility of  Acrobat 5, which leaves the transparency live, those pages with transparency look darker on screen in the PDF. If I use a setting like PDF/X-1a that flattens transparency (Acrobat 4 compatibility) I don't see the darkening. Printing to PDF instead of exporting also will always flatten transparency.

The downside to flattening transparency is it can lead to other screen artifacts like stitching -- thin white lines around regions in the file -- on screen and in low resolution printing. For your file I don't think that's going to be a major issue as for the most part you don't have transparency on top of other objects.

To get a feel for what you should see, make a two-page file, and set both pages identically. Add a small color filled rectangle somewhere on both pages, and on one set the opacity of the rectangle to 99%. That's enough to make that page show transparency problems, but not to make the object visually different on screen in most cases. Now make a PDF using a variety of settings and printing/exporting. When you view the PDFs, look at the pages separately and jump back and forth. If the type is the same you won't se anything as you shift, if one is bolder it will jump out at you. Jump from flattened to unflattened versions the same way.

Does that help?

Peter

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Apr 24, 2009 Apr 24, 2009

Copy link to clipboard

Copied

Sadly, exporting using those settings you mentioned still leave the pages with an image on them with bolder text.

Also, printing to PDF has the same problem.

So, the problem remains.

I think I may have to pay an Elancer to work on the file and see what they can do.

Thanks for trying so hard!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Apr 24, 2009 Apr 24, 2009

Copy link to clipboard

Copied

If you're going to pay someone, ask Peter instead of some stranger on Elance.

Ken Benson

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Apr 24, 2009 Apr 24, 2009

Copy link to clipboard

Copied

Oops, my bad. I didn't think. So, Peter please do PM me if you would like to take a look to see if you can fix the issue for a fee.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 24, 2009 Apr 24, 2009

Copy link to clipboard

Copied

It occurs to me that it might help to move this over to the Acrobat forums. There are a lot of smart folks over there, too, and most of them know ID as well, at least as far as exporting.

Be sure to link back to this thread so they can see what's been discussed already, and post a link here to the new thread so we can find it and subscribe. If they have a solution, I'd LOVE to learn about it (and so would quite a few other peple around here).

Peter

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 24, 2009 Apr 24, 2009

Copy link to clipboard

Copied

I'm not sure if you're suggesting paying me, or asking for a recommendation, and I appreciate the thought in either case , but I'm afraid it wouldn't do much good.

I'm pretty sure this is a platform-specific issue, and probably not solvable, at least not by me, and I don't know anyone who isn't likely to already be looking here who would be able to do any better.

Can Chukee post a link to some of the trial PDFs that show the problem that were exported using PDF/X-1a preset and any settings but that were printed rather than exported? Just two pages each, on that shows and one that doesn't (but the same two pages in each file). That will confirm, perhaps the platform connection.

Peter

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Apr 24, 2009 Apr 24, 2009

Copy link to clipboard

Copied

Here is a link to the first 15 pages having been 'printed' to a PDF from Indesign:

http://www.sendspace.com/file/fin807

Here is a link to the first 15 pages having been exported using PDF/X-1a:2001 as the Standard:

http://www.sendspace.com/file/wjecqo

Most of the pages with images you can see has thicker text.

I will also post in the Acrobat forum and post the link to that here.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 24, 2009 Apr 24, 2009

Copy link to clipboard

Copied

I've downloaded your samples, and I must say this is all very strange. Looked at on my monitor, all of the pages in each document seem to match each other in darkness (which I expected since both are flattened), but the exported sample "seems" slightly darker to me than the printed sample. Combining the two files into one, however, and looking at the same page side by side in the same window, there is virtually no difference in darkness, or perhaps the printed page is slightly darker. This could be due to different settings between the exported and printed versions --  the colors are definitely slightly different.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines