Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


InDesign CC 2020 - Contents reflowed while doing export PDF

Advocate ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

Dear All,


I'm very much appreciate if any one look into my issue!!!

I've an issue while generating the online PDF the texts are reflow in the PDF, in many occurances the paragraph contents get reflowed inside the Indesign while doing exportPDF.

We set-up a procees for 2 sets of PDF deliverables, 1st one print PDF and 2nd one is online pdf.

1. First we execute the Print PDF using the client provided InDesign PDF export job options with Black & White images.

2. After everything finalized then we generate the 2nd PDF that is Online PDF in this case we relink the images (i.e, color images), relink in InDesign and save the InDesign file to temp location and generate the PDF file, once pdf genearted then we don't save the InDesign file.

The above process happening from the set of articles structured in the InDesign Book file and exporting the online pdf one by one. The below mentioned PDF screnshot is contents reflowed PDF upto end of the particular indesign file.

 

Application:
Adobe InDesign CC2020 using Export PDF client provided job options.

InDesign File:

The particular paragraph applied formatting properties are below:

  • Paragraph Tracking -5
  • Text Frame vertical justification applied (i.e., justify)
  • Hyphenation Screenshot shared on below


InDesign file screenshot (Hyphenation, tracking, frame VJ):InDesign.png

Please find the attached PDF screenshots for your perusal:-


Correct PDF:

Correct.JPG

Wrong PDF:
Wrong.JPG




Regards,
csm_phil

TOPICS
Bug, Feature request, How to, Import and export, Performance, Print, Scripting, SDK, Type

Views

151

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

I suggest you save a copy of the InDesign document used to export each file, and compare the text flow in the design. It is unlikely to be the PDF export causing the reflow. More likely the other steps already caused the reflow before the PDF was made. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

I suggest you save a copy of the InDesign document used to export each file, and compare the text flow in the design. It is unlikely to be the PDF export causing the reflow. More likely the other steps already caused the reflow before the PDF was made. 


By @Test Screen Name

Hi,

Yes, I took backup everytime while doing the online PDF creating stage, but unfortunately the texts not reflowed in the InDesign file, it's affected only in PDF file. All the process is automated in javascript.

Again we created the same process #enumber of times we can't get the same issue.

Thanks for your response.

Regards,
csm_phil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

The weird thing is that you have no more hyphenation in the second screenshot.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

The weird thing is that you have no more hyphenation in the second screenshot.


By @jmlevy

Hi jmlevy,

Yes, the weird thing is the same particular para no more hyphenation, Again we created the same process #enumber of times we can't get the same issue. That is the big issue, we can't get the same issue I can do research or re-create the all text frame and top align and hyphnation properly set it up. But same file re-generate the pdf it's not affected everything comes perfectly.


Thanks for yoru kind response!!

Regards,
csm_phil


Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

So, did you save the InDesign document? Can you confirm that you have an InDesign document WITH hypenation, but when YOU export it manually the hyphenation is LOST? Discussing what happens in an automated workflow is interesting but you must get actual files where you can reproduce a problem if you want to go further with problem solving.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 10, 2021 Feb 10, 2021

Copy link to clipboard

Copied

What's the full process of Step 2 in your process?

What temporary location? 

 

Why are you doing these steps:

  1. relink the images (i.e, color images),
  2. relink in InDesign and save the InDesign file to temp location
  3. generate the PDF file,
  4. once pdf genearted then we don't save the InDesign file.

 

That's very confusing why you're even doing these steps.

Especially step 2 - what does Relink InDesign ???

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 10, 2021 Feb 10, 2021

Copy link to clipboard

Copied

LATEST

As jmlevy mentioned, the problem is that hyphenation was disabled during the export. That problem may be caused by insufficient memory or a problem with the font files. To troubleshoot the latter, try exporting with some different fonts and see whether the problem still occurs.

 

P.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines