InDesign file icons are generic white box

Explorer ,
Oct 05, 2018 Oct 05, 2018

Copy link to clipboard

Copied

Yesterday I had a new profile added to my desktop (Win7) at work so that it wasn't under the old designers name but this morning I noticed that all InDesign files had been disassociated with InDesign. So, I did the whole "open with x program always" by browsing for InDesign but instead of the regular file icon, it now shows the generic white thumbnail with a tiny InDesign logo:

example of photoshop file with icon vs indesign file with generic icon

I've tried deleting/reinstalling InDesign and refreshing the icon cache, and checking out the other discussions on the topic. No success.

The files still work fine but it's mostly just an aesthetic issue. I need it to be fixed or it will drive me crazy.

Any help would be greatly appreciated.

Views

13.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Contributor , Oct 08, 2018 Oct 08, 2018
I think you found the problem friend. It's your user profile. Just delete your said profile and start fresh. That should do it.

Likes

Translate

Translate
Enthusiast ,
Oct 05, 2018 Oct 05, 2018

Copy link to clipboard

Copied

Try changing the indd file association from InDesign to something else and then change it back and see if it resets the icon.

1. Go to: Start > Settings > Apps > Default apps >

2. Then scroll down to the .indd file type.

3. Change it to photoshop  (just for a second. Actually wait like 10 seconds)

4. Then change it back to InDesign

That should reset it.

Let me know if that worked.

- Dax

indd-type.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 05, 2018 Oct 05, 2018

Copy link to clipboard

Copied

Didn't work

When I changed it to photoshop it actually changed to the white box with the photoshop logo in it instead of the full icon.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 07, 2019 Mar 07, 2019

Copy link to clipboard

Copied

Hello ,

Your advice is for smart phones, right?

"Changing the indd file association from InDesign to something else and then change it back and see if it resets the icon."

How to go for Windows 7?

Same situation, file icons are white boxes.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Oct 05, 2018 Oct 05, 2018

Copy link to clipboard

Copied

Have you checked to see if there are any updates to the version of Windows you're running. It seems to me this is an OS issue.

J

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 08, 2018 Oct 08, 2018

Copy link to clipboard

Copied

Is it still an OS issue if when I log into the administrator profile (my old profile) the icons look fine?

1.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Oct 08, 2018 Oct 08, 2018

Copy link to clipboard

Copied

I think you found the problem friend. It's your user profile. Just delete your said profile and start fresh. That should do it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 08, 2018 Oct 08, 2018

Copy link to clipboard

Copied

Well, the IT guy is the one that created this new profile (took like an hour) so unfortunately that's not an option...also it took forever to get all my preferences and settings back to normal.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 30, 2018 Dec 30, 2018

Copy link to clipboard

Copied

Hi

could you please tell where i can find those, i have the same issue.

thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 02, 2019 Jan 02, 2019

Copy link to clipboard

Copied

I wish I could but I never fixed the issue

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 08, 2019 Mar 08, 2019

Copy link to clipboard

Copied

The case of missing InDesign file icon is solved with me.

It was missing in C:\Program Files\Common Files\Adobe\Shell\CS5.5\ the file Icons.dll

But it existed in Programs(x86)\Common\Files\Adobe\Shell\CS5.5\ as icons.dll

So I copy them from here to there.

With all Adobe CS5.5 InDesign files the white box is gone and indicated again by the correct icon.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 08, 2019 Mar 08, 2019

Copy link to clipboard

Copied

I copied the file but no such luck for me. I've basically gotten used to it at this point.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 09, 2019 Mar 09, 2019

Copy link to clipboard

Copied

It could be that your destination folder isn't like mine:

C:\Program Files\Common Files\Adobe\Shell\CS5.5.

Search the path to folders ... \Adobe\Shell\CS5.5.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 11, 2019 Mar 11, 2019

Copy link to clipboard

Copied

well mine isn't CS5.5 but i followed it all the way up to that point

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 11, 2019 Mar 11, 2019

Copy link to clipboard

Copied

What files are in your folder Adobe\Shell\your folder? (I dont know the name of your InDesign version)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 11, 2019 Mar 11, 2019

Copy link to clipboard

Copied

these 2 files

Capture2.JPG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 12, 2019 Mar 12, 2019

Copy link to clipboard

Copied

So, the two files are OK. You can try to open the file icons.dll to see if it contains the right icons for your version of InDesign. A program for this can be found for example here: http://www.nirsoft.net/utils/iconsext.html.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 24, 2019 Mar 24, 2019

Copy link to clipboard

Copied

Hi Sir,

I have the same trouble. My system does not recognize the icon of Indesign files it is in generic white box.

I followed the instructions with the analyse of the two files icon.dll and idicon.dll as you can see in this picture.

Could you tell me what is the next process?

Regardsprint screen.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 26, 2019 Mar 26, 2019

Copy link to clipboard

Copied

Hi ashokk,

it looks ok. Sorry to haven't more for you.

Maybe you'll ask the question again with a new wording.

Then people will look again.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 05, 2019 Apr 05, 2019

Copy link to clipboard

Copied

Hi,

I confirm that the problem comes from Indesign 32 bytes.

The problem is solved for me, we install Indesign CC2018 64 bytes and it's fixed.

And I install also Indesign CC2019 64 bytes everything is working fine.

Hope this could help everyone.

Ashok

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 22, 2020 Jul 22, 2020

Copy link to clipboard

Copied

What a PIA between Adobe and Microsoft, but I figured it out. Right click on the blank white InDesign icon, go to Properties. Click on Change button, then select InDesign! Et voila, they change to our familiar pink icon. Same for Edge instead of Acrobat for a pdf file.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 22, 2020 Jul 22, 2020

Copy link to clipboard

Copied

Now I've discovered an issue opening pdf files directly. They used to just
open when clicked on, but now there are options, so selecting Chrome which
is my browser of choice - instead of Edge, etc. - works, but it's another
step which is ridiculous. You all need to get together to get this
simplified please!

--

* carolspearls.weebly.com *

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 25, 2021 Oct 25, 2021

Copy link to clipboard

Copied

I had the same issue described above for over a year and this solution worked for me. Thank you!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 26, 2020 Sep 26, 2020

Copy link to clipboard

Copied

idml files associate correctly. using all recommended "association" methods, I can change indd files to any other icon except InDesign. Windows 10. InDesign install 9/26/2020

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 12, 2021 Sep 12, 2021

Copy link to clipboard

Copied

right click on the file with the missing icon, go to properties > open with: Change...> then there will be a selection of apps to choose from - if its not in this list > more apps - if not in this list, scroll down > look for another app on this pc > then find the application location in the file explorer. Once found and selected the application icon should return

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2