Live or Static Captions in InDesign 2021

Adobe Community Professional ,
Nov 19, 2020 Nov 19, 2020

Copy link to clipboard

Copied

Is anyone else having issues generating Live or Static captions in InDesign 2021? I was trying to use the feature and it was just displaying an empty text frame. I'm grabbing metadata from the Description field of an image. When I switch back to InDesign 2020 it works like a charm. Can anyone confirm the same? Trying to figure out if this is on my end.

TOPICS
Bug

Views

332

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Nov 20, 2020 Nov 20, 2020
That's a good suggestion but no, there is no character style appled. So on a whim, I decided to delete the preferences file and voila! It now works! Should have tried that from the very beginning! You'd think after using InDesign for 20+ years I'd know better! Thanks for your help guys!

Likes

Translate

Translate
Adobe Community Professional ,
Nov 19, 2020 Nov 19, 2020

Copy link to clipboard

Copied

Chad, I just tested in InDesign 2021 and had no problem generating a static caption:

 

Screen Shot 2020-11-19 at 6.46.33 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 19, 2020 Nov 19, 2020

Copy link to clipboard

Copied

Hi Chad,

maybe the placed file type makes a difference?

best post a link to a sample where you see the issue.

 

To Steve:

thank you very much for posting this image. Been there a couple of years ago.

 

Best,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 19, 2020 Nov 19, 2020

Copy link to clipboard

Copied

I tested with a .jpg on the left and a .psd on the right. I highlighted all of the text in the caption on the right and you can see the appearance. In the Story Editor, it shows up but visually isn't appearing in Layout view.

 

Captions.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 19, 2020 Nov 19, 2020

Copy link to clipboard

Copied

Wow. Never experienced this.

Thanks for the screenshot, Chad.

 

Could it be that a character style is applied that is using an unusual formatting like 1% character width and a point size of 0.1 Pt with a fill color set to [None] ?

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 20, 2020 Nov 20, 2020

Copy link to clipboard

Copied

That's a good suggestion but no, there is no character style appled. So on a whim, I decided to delete the preferences file and voila! It now works! Should have tried that from the very beginning! You'd think after using InDesign for 20+ years I'd know better! Thanks for your help guys!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 20, 2020 Nov 20, 2020

Copy link to clipboard

Copied

I'm glad you figured it out, Chad!

 

It's a good teaching moment: The three most common troubleshooting tips for InDesign I give: (1) Try rebooting your computer; (2) restore your preferences and cache files; (3) Save as an IDML file to remove file corruption.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 15, 2021 Jul 15, 2021

Copy link to clipboard

Copied

Hello, I'm having this same issue of InDesign creating a blank caption from my metadata (from the "description" field). I've checked the metadata of the images in Photoshop, and it is there, but it does not appear in InDesign. Some of my images work correctly and others don't. The main thing I see in common with the non-working files is that they started out very large (20 MB and up). Even when reducing the file size down significantly and resaving, the captions do not generate. This issue has happened to me multiple times with many different files. I would try resetting my preferences as noted above, but the command of Shift + Option + Cmd + Control is not working for me. It does not bring up a panel to reset preferences. I'm attaching one of the files that is giving me issues. Please help! Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 15, 2021 Jul 15, 2021

Copy link to clipboard

Copied

@kimh567 I'm sorry to hear about your trouble with static captions. It could be something with your system/version as I tested it with your image just now and it's working fine. Here is what I did. First, I opened your image in Photoshop to check the caption. It wasn't already assigned in the Description field (this may be due to the uploading/downloading of your image on my end or perhaps the caption wasn't set and saved on your end). I applied what was in the first dropdown list in that field (maybe this isn't your caption?). I added a note that this is a test with today's date and saved the file again. In InDesign's Caption Setup, I set the Metadata field to Description and the Paragraph Style to a Caption style I made. I placed the image into a new document with the "Create Static Captions" box checked. I right clicked on the image to Generate Static Caption and it placed correctly. Please let us know if you are using a different method to add captions so we can test that as well.

 

JainLemos_0-1626366451434.png

JainLemos_2-1626366561386.png

JainLemos_1-1626366486789.png

JainLemos_3-1626366587999.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 15, 2021 Jul 15, 2021

Copy link to clipboard

Copied

Hello Jain, 

Thank you for looking into my issue. The process you used to generate the caption in InDesign is the exact process I use. However, I'm not sure where that text starting with "This is a learning journey...." came from. The metadata that should have been in the description field looks like this, and this is what shows up in Photoshop for me from the same file I sent you:

 

Screen Shot 2021-07-15 at 1.01.16 PM.png

 

A couple of my colleagues have also been trying to troubleshoot this issue, and we've found that this issue is only happening with larger files. One workaround we found is to reduce the image size in Photoshop, and then add the metadata. (Adding metadata and then saving down does not work, though. The file size must be reduced FIRST and then the metadata added after.) We can use this workaround now that we've figure out how it works, but I suppose this issue could happen to others as well, if it is an InDesign issue. Could it be a Photoshop issue?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 15, 2021 Jul 15, 2021

Copy link to clipboard

Copied

Hi, I am not sure where that text came from either! It must have been from another image I was testing. Anyway, your description text was stripped out in the file transfer.

 

You know, it should not make any difference what the file size is. InDesign should be able to generate a caption from any image file's metadata as long as the file is not corrupted in some way. That seems very strange. I was wondering if it could be a Photoshop issue but that doesn't make sense. I work with captions a lot and have imported really large files without a problem. As a test just now, I inserted a file this large as CMYK tiff and had no problem generating a caption. How large are the files you are talking about?

 

The only other thing I'm wondering about is how the description text is being entered. It looks as though there are space or tab characters as well as paragraph breaks in the caption that might be causing a conflict? Just an idea...

 

JainLemos_0-1626374035341.png

JainLemos_1-1626374278157.png

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 15, 2021 Jul 15, 2021

Copy link to clipboard

Copied

That's interesting/good to know that we may be able to convert it to a Tiff file to get the caption working. Regarding the file size, the issue seems to be happening when the image is about 20 MB and up. Regarding the spaces and paragraph breaks in the metadata, we actually have lots of other images with metadata saved in the same format (but they are much smaller in file size), and the metadata works fine with the spaces, paragraph breaks, etc. We use these images for product catalogs, but sometimes the original image we get from the vendor is massive in size compared to the others, and those seem to be the only ones that cause the issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 15, 2021 Jul 15, 2021

Copy link to clipboard

Copied

Hi kimh567,

there is some contents in the Description field of the posted image:

 

Beautiful Flowers & Butterfly
37" XL®
110669 110670
$P35 Pkg $P35 Flat

 

Opened the JPEG in my German PhotoShop.

The contents of the field "Beschreibung" (Description) is the one I like to see as caption in InDesign:

 

XMP-Description-Field-Populated.PNG

 

Dynamic caption fails, static caption fails.

Tested with InDesign 2020 and 2021, also with InDesign CS6

 

What finally worked: saved the file to the TIFF format and placed the TIFF image:

SOLUTION-SaveAs-TIFF-AutoCaptionIsWorking.PNG

 

An old bug with InDesign…

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 15, 2021 Jul 15, 2021

Copy link to clipboard

Copied

FWIW: I was using a German version of InDesign.

Could be that the bug is not visible in the English/International version.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 15, 2021 Jul 15, 2021

Copy link to clipboard

Copied

So interesting, @Laubender. The jpg file had no metadata for me so I used placeholder text and placed the file as a jpg and the caption generated without any issues. But it's good to see it's not an issue with the characters in the caption such as tabs or spaces.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 15, 2021 Jul 15, 2021

Copy link to clipboard

Copied

@Laubender , yes, this is an English (American) version of InDesign. I appreciate you looking into it and doing some testing. I'm still stumped as to why this is happening with the JPEG version, but at least I know some workarounds now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 15, 2021 Jul 15, 2021

Copy link to clipboard

Copied

Please keep us posted if this keeps happening, as it shouldn't. I couldn't duplicate it on my end and now we've done a bit of elimination. Maybe it has to do with the vendor files and how they are delivering them to you. I also wonder if it might be document specific. Are you working from a copy of a previous ID file that you  continue to copy and change? Did you ever try saving as a .idml file and then opening and saving it back to .indd to see if this cleared out the problem? It might be a caching issue or you need a preference reset. Using workarounds is never ideal and we hope you will soon find the root cause.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 15, 2021 Jul 15, 2021

Copy link to clipboard

Copied

Hi Jain,

this is the way I saved the attached JPEG image:

 

HowIsavedAttachedPostAttachment-Firefox-Windows10.png

 

Firefox browser on Windows 10.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 15, 2021 Jul 15, 2021

Copy link to clipboard

Copied

Okay! I just used the browser download. Missed that little icon on the first glance. Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 15, 2021 Jul 15, 2021

Copy link to clipboard

Copied

Hi kimh567,

do you have an American version of InDesign?

I really think this is a bug with all non-american versions…

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 15, 2021 Jul 15, 2021

Copy link to clipboard

Copied

Jain said:

"I couldn't duplicate it on my end and now we've done a bit of elimination. Maybe it has to do with the vendor files and how they are delivering them to you. I also wonder if it might be document specific. "

 

Hi Jain,

we could test the following: I place the image and prepare how static or dynamic captions should be set up.

I will also do both in my document. Then I'll package it all up and post the download link of the zip that contains the package folder.

 

You do the same and I'll test your packaged document in my German version of InDesign 2021.

I'm on Windows 10, you are on Mac OS, I think; this could also be a contributing factor.

 

Here is my setup:

StaticCaption-DynamicCaption-JPEG-vs-TIFF-Description-Field.PNG

 

Here is my zip file of the packaged folder:

https://www.dropbox.com/s/5u5l9mmrvxvgzzf/210715-1-StaticCaption-Issue-INDD-2021.zip?dl=1

 

Regards,
Uwe Laubender

( ACP )

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 15, 2021 Jul 15, 2021

Copy link to clipboard

Copied

Okay, wow, @Laubender, check this out. With the downloaded jpg file from the button you showed me, I couldn't get the caption to work either static or live. As a tif file, both worked fine. But when I tried the same with the browser jpg I inadvertently downloaded the first time, the caption worked. Crazy! How do you explain that? Here's my packaged file with the browser-downloaded jpg. See if it works on your end.

 

https://www.dropbox.com/s/sekepy2xqjgdm9k/JainTest-StaticCaption-Issue-INDD-2021%20Folder.zip?dl=0

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 15, 2021 Jul 15, 2021

Copy link to clipboard

Copied

Hi Jain,

opened your IDML file from your package.

 

Note: Caption setup was totally reset to default.

Seems that InDesign cannot save the setup to IDML or cannot read the setup from the IDML file.

That should be considered a bug, I think.

 

IDML-Opened-CaptionSetUp-was-reset-to-Name.PNG

 

Next thing: Opened your InDesign file where the Caption Setup seems untouched:

INDD-Opened-CaptionSetUp-was-untouched.PNG

 

Next step: I redid all captions with your InDesign document.

Page 1, same issues as before:

CaptionsAddedAgain-Page-1.PNG

 

Page 2, all went well:

CaptionsAddedAgain-Page-2.PNG

 

Hm…

Have to leave the office now.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 15, 2021 Jul 15, 2021

Copy link to clipboard

Copied

LATEST

Hmmm is right. Also from your package, I had to reset the Caption Setup as it was also untouched. I think that is a bug for sure. Until next...

 

Oh, meant to add that I am also on Windows 10 and not Mac.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines