Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Spacing options locked/greyed out...?

Participant ,
Dec 14, 2018 Dec 14, 2018

Copy link to clipboard

Copied

I upgraded to InDesign 2019 and have an odd problem I never had before: every now and then the spacing option to align objects is suddenly locked:

Schermafbeelding 2018-12-14 om 10.39.48.png

Sometimes the option because editable again but at this moment I am stuck because I can't select and/or change either option (Afstand gebruiken)! I never ever had this in previous versions of InDesign where these options were ALWAYS available. Is this something new in ID 2019...? How can I unlock and use these options again? I need that option badly but can't use it at all right now!

Views

7.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 15, 2018 Dec 15, 2018

Copy link to clipboard

Copied

No one...? I use this option A LOT and this problem might make me reinstall CC2018 and forget about CC 2019 for now. Maybe I'd better contact Adobe support directly.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 15, 2018 Dec 15, 2018

Copy link to clipboard

Copied

Hi,

I cannot see this issue with my German InDesign CC 2019 14.0.1.209 on Windows 10.

So I can only suspect, that perhaps trashing preferences or cache files will bring you back the functionality.

And yes: It's always good to have older versions of InDesign at hand.

On my PC I have installed all versions from CS6, CC, CC 2014 up to CC 2019.

On my Mac, that currently has an older OS X installed and cannot run CC 2019, I went so far to install every version of InDesign from CS3 up to CC 2018.1.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 15, 2018 Dec 15, 2018

Copy link to clipboard

Copied

Ok, no issue on your PC so apparently it isn't a new option I wasn't aware off... I thought that maybe I did something to cause these options to get locked. Very odd. I am running CC 2019 on a Mac with 10.13.6 (afaik the latest Sierra OS).

I'd hate having to trash my preferences because it takes quite some time to set everything up again: my prefs are heavily edited from default. I will see if trashing the cache helps.

The odd thing though is that the option may SUDDENLY become available again! It's as if something is triggering the option on and off all the time. At one time simply hiding and showing the options part of the alignement window triggered the spacing option to become available again! Which is why I thought that maybe there is a new option/key to turn the spacing option on or off... It's a mystery to me...

coldjtf is having the exact same issue, I see, so I am not the only one...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Jan 28, 2019 Jan 28, 2019

Copy link to clipboard

Copied

https://forums.adobe.com/people/J+van+E  wrote

I'd hate having to trash my preferences because it takes quite some time to set everything up again: my prefs are heavily edited from default.

If you have to set up up your preferences again, maybe you can make a backup. That way, should you need to replace your prefs again, you can use the backup set and save some time. Just something to consider.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 29, 2019 Jan 29, 2019

Copy link to clipboard

Copied

That would mean that just the act of deleting and then replacing the preferences helps, which seems unlikely.

Also, I've been deleting application preferences on Macs for years now, as the go to solution, and it rarely works.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2019 Jan 29, 2019

Copy link to clipboard

Copied

I have to disagree with you. Deleting/restoring the Indesign preferences or deleting/restoring the InDesign cache frequently works, and if you read through the messages in this forum, you'll see it's frequently credited as a solution. But there can be a hundred things to try, depending on what's happening, and it's one I put at the top of the list of things to try. The second is to export IDML to deal with individual file corruption.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 18, 2018 Dec 18, 2018

Copy link to clipboard

Copied

Same problem here. Upgraded to 14.0.1 few days ago and just noticed the issue. Also hiding/showing options in the Align Palette made the 'Use Spacing' tick box available again. This will be an ok workaround for now but... Adobe, seriously?!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 18, 2018 Dec 18, 2018

Copy link to clipboard

Copied

Seems the only solution is to trash your prefs and set everything up from scratch again. That seemed to have solved the problem on my Mac, at least for now. Seems something goes wrong with the automatic import of previous prefs.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 18, 2018 Dec 18, 2018

Copy link to clipboard

Copied

Actually, come to think of it I think you're right J van E. I've can confirm I've trashed and remade the prefs for two others in the same studio after the update. Just assumed mine had escaped this as it hadn't shown any similar symptoms to the others. Sigh.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 18, 2018 Dec 18, 2018

Copy link to clipboard

Copied

Well, SCRAP THAT! I just wanted to align some objects and everything is GREYED OUT AGAIN! **** This really sucks. I spend half the morning with Adobe support on Chat and they decided that trashing the prefs was the only option. **** I am really screwed here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 18, 2018 Dec 18, 2018

Copy link to clipboard

Copied

Oops. Darn it, I thought that was a solution. Will try some options out myself when I get time. Thanks for spending your time with Adobe tho. Adobe - sigh.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 18, 2018 Dec 18, 2018

Copy link to clipboard

Copied

Sigh indeed. I am also screwed because there is NO WAY I can open my 2019 ID doc in 2018... Convert won't work, idml won't work, so I am stuck with a bugged ID 2019. This really sucks, specially after spending so much time with Adobe...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 19, 2018 Dec 19, 2018

Copy link to clipboard

Copied

https://forums.adobe.com/people/J+van+E  wrote

… idml won't work, so I am stuck with a bugged ID 2019.…

Hi,

is there an error message, if you exported an IDML file with InDesign CC 2019 and you try to open the IDML with InDesign CC 2018.1? Hm. Maybe the IDML file is never written fully? Exporting or saving to IDML could take a while. And it could take even longer to open an IDML file, depending on the complexity of your document. With a fairly complex one 10 to 20 minutes is no exception.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 20, 2018 Dec 20, 2018

Copy link to clipboard

Copied

I managed to get the file open in ID 2018 by splitting the 2019 file in 4 parts... I am back to ID 2018 now and won’t touch the 2019 for a few months anymore, that’s for sure. And when I do I will be testing it for a week or so before actually switching. Never again will I switch to a new version just like that. Lesson learned.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 21, 2018 Dec 21, 2018

Copy link to clipboard

Copied

https://forums.adobe.com/people/J+van+E  wrote

I managed to get the file open in ID 2018 by splitting the 2019 file in 4 parts...

Which route did you go from there?


A. Export/Save to IDML and open the IDML file with CC 2018.1 ?

B. Saveback Service by Adobe by opening the CC 2019 indd-document with CC 2018.1 ?

Thanks for giving the details.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 21, 2018 Dec 21, 2018

Copy link to clipboard

Copied

I think I split the document up in 4 parts, saved each part as a ID 2019 file and then opened it in ID 2018 which asked me if I wanted to convert them. (I say 'I think' because I tried so much options that I forgot what I did exactly...!) I suppose that's called the Saveback Service.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 31, 2018 Dec 31, 2018

Copy link to clipboard

Copied

I was able to get the distribute spacing ~use spacing~ to not be grayed out by selecting my objects then selecting a target object.  Hope that help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 24, 2019 Jan 24, 2019

Copy link to clipboard

Copied

This worked for me aswell.
Selecting a key object from all the objects you have selected, by clicking on it and then clicking it again to deselect it, made the option to use spacing available again.

This does seem like a bug though!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 28, 2019 Jan 28, 2019

Copy link to clipboard

Copied

I'm having the same issue. I have reset preferences twice which works, but Use Spacing goes back to being greyed out as soon as I've used it once.

Thanks joevangundy , your solution does work, but I have to choose a key object, unselect it, choose a different key object then unselect that one too. It then makes the Use Spacing available for a short time but it seems each time I go back to use it it's greyed out again - It's a pain in the a**!

Capture.JPG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 28, 2019 Jan 28, 2019

Copy link to clipboard

Copied

Can we agree that this issue is with InDesign on Mac OS X and not with the Windows version?

FWIW: I'm on InDesign CC 2019 14.0.1.209 on Windows 10 and cannot see the issue.

Tested a lot with all possible Align To: options.

All is working as expected.

Just like in my CS6 version on the same machine.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 28, 2019 Jan 28, 2019

Copy link to clipboard

Copied

I'm on InDesign CC 2019 14.0.1 on Windows 7 Professional so not it's not just affecting Mac

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 26, 2019 Feb 26, 2019

Copy link to clipboard

Copied

I'm having the same issue on windows.

It seems if I open and close the align palette it fixes the problem for the time being.

I also have issues with undo only working a few steps since I upgraded to cc2019

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 04, 2019 Mar 04, 2019

Copy link to clipboard

Copied

I, too, have had this issue, but I think I figured out the root cause...

In my case, I had several items for which I was creating specific spacing distribution. However, I think the hangup occurs when you apply spacing distribution to items, group them, and then try to apply additional items to the spacing distribution. I found that when I ungrouped all items in my design, the "Use Spacing" checkbox and sizing buttons unlocked.

Hope this helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 04, 2019 Mar 04, 2019

Copy link to clipboard

Copied

There is a new build being tested in Prerelease which may fix the problem:

Crash on using Align Distribute option – Adobe InDesign Feedback

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2