• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Switch primary text frame's Text Frame Options for multiple pages

Contributor ,
Jul 23, 2019 Jul 23, 2019

Copy link to clipboard

Copied

I am searching for a way to quickly turn on or off a certain Text Frame Option on the Primary Text Frame on multiple pages. Specifically, I want to turn off Balance Columns for better performance whilst editing, and then turn Balance Columns on for production.

You might think there is an easy way to do this, based on what David Blatner said in https://forums.adobe.com/message/10969839:

  • You set up a Master Page spread (let's call it B), each with a Primary Text Frame, and link them.
  • You select each of the Primary Text Frames,and
    • select Text Frame Options, and
    • make sure Balance Columns is on; this will be the production master page.
  • You then make a duplicate of this (let's call it D because that's what mine is) that is the same except that the Text Frame Options for the Primary Text Frames have Balance Columns off.
  • You apply the D master spread to all of the appropriate pages.
  • Edit to your heart's content with Balance Columns off to improve performance
  • When you're ready to produce your PDF:
    • Apply the B Master Page spread to all of your pages (in the Pages Panel, select all the appropriate pages, and then Alt-click the B Master Page spread).
    • Select all of the appropriate pages (those now with the B Master Page spread applied).
    • Go to the Pages Panel flyout menu
      • Click on Master Pages
      • Click Remove All Local Overrides

And voilà! All of your Primary Text Frames should now have balanced columns.

Doesn't work.

Any other ideas for how to switch Balance Columns for a bunch of pages all at once? And is this a bug or a feature?

Views

937

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 23, 2019 Jul 23, 2019

Copy link to clipboard

Copied

Hi Keith,

could be a bug.

Just tested that with my German version of InDesign CC 2019 version 14.0.2.324 on Windows 10.

If I change number of columns of the primary text frames on my master, the pages where this master is applied will reflect the change instantly. Not so with turning on or off Balance Columns.

I can see the same bug already with InDesign CS6.

Hm. I can enforce the right behavior if I remove the last text frame of the story when InDesign's preferences are set to add or remove pages when contents is changing. InDesign will remove the frame and adds a new frame to flow in the overset text. That frame will work exactly like the primary text frame was defined: Balance Columns turned on or off.

Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jul 25, 2019 Jul 25, 2019

Copy link to clipboard

Copied

Thanks, Uwe. Posted as a likely bug. Thanks for the workaround.

I've also noticed something weird as I've tried to make this work. I find that sometime my primary text frame now has another identically-sized non-primary text frame superimposed on it. This might be a clue to whoever tries to debug this.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Aug 10, 2019 Aug 10, 2019

Copy link to clipboard

Copied

I have found that the "delete-last-page" workaround doesn't reliably turn off Balance Columns on all my pages. Sigh.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 12, 2019 Aug 12, 2019

Copy link to clipboard

Copied

LATEST

Hi Keith,

any details on that?

Do you have a link for your bug report so one could vote for fixing the issue?

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines