Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Text quality goes down when apply any effect

Community Beginner ,
Apr 08, 2021 Apr 08, 2021

Copy link to clipboard

Copied

Hi everyone, I'm new to InDesign and I can't figure out how to handle this problem. When I apply any effect to an object from the effects panel (ex. Transparency) any other image or text in the same page lose quality (resolution goes down I think...). You can see an example in the screen (Left: no effect/tranparency applied to the rectangle. Right: 50% transparency and texts below look a little more pixelated). Open attachment for better image quality.

 

Immagine.png

 

When I export the entire file to a PDF, in Acrobat it looks exactly the same as I said above. When I open the PDF in Chrome, instead, everything is fine and both texts are perfect.

I'm a bit confused...

 

Already set High Quality Display Performance and each View Setting to High Quality (max).

 

InDesign v16.1

Acrobat v 21.0

TOPICS
Bug, How to, Import and export

Views

158

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

LEGEND , Apr 09, 2021 Apr 09, 2021
There is a rule that, if ANY transparency is used ANYWHERE on a page, then EVERYTHING on the page is converted into the document blend space. Check the document blend space matches the RGB/CMYK definition you are using for your text colour. Converting colour space won't cause pixellation though. 

Likes

Translate

Translate
Adobe Community Professional ,
Apr 08, 2021 Apr 08, 2021

Copy link to clipboard

Copied

Check you haven't inadvertently applied a stroke (outline) or effect like Glow to the text.

How are you applying the tint to the object – is it like I've done it below from the swatches panel?

 

Screenshot 2021-04-08 at 14.47.34.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 09, 2021 Apr 09, 2021

Copy link to clipboard

Copied

Hi,

thank you for your reply.

 

Yes, I've already checked and there is no stroke or any other effect to the text. When I apply the tint to the rectangle I use one of the swatches in that panel ([black] in this case), but instead of using the "% tint" in the upper right, I use "% Opacity" from the Properties panel (because I need transparency in my graphic).

Immagine2.pngImmagine.png

 

The "pixelated" text appear immediately after applying the opacity/transparency or any other effect (drop shadow for example...) to any object in the same page. And immediately disappears when i deactivate that effect or bring the opacity back to 100%.

 

Another intresting thing is that texts in other project's pages remain perfect. Only the page where I apply an effect to an object seems to be affected.

 

Thank you again!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 09, 2021 Apr 09, 2021

Copy link to clipboard

Copied

There is a rule that, if ANY transparency is used ANYWHERE on a page, then EVERYTHING on the page is converted into the document blend space. Check the document blend space matches the RGB/CMYK definition you are using for your text colour. Converting colour space won't cause pixellation though. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 09, 2021 Apr 09, 2021

Copy link to clipboard

Copied

It worked!

I've changed the Transparency Blend Space from CMYK to RGB and there are no more pixeleted texts.

 

Didn't know about this thing, thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 09, 2021 Apr 09, 2021

Copy link to clipboard

Copied

LATEST

If your document is for press output, setting the Transparency Blend Space to RGB will likely convert your blacks and grays to 4-color CMYK on export or output—small 4 color text could cause registration problems on press. You can open the Separation Preview panel and mouse over the page to check the output values.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines