Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Unwanted gaps between colors when using tints in a table

New Here ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

 

Hi,

 

I apologize for my english in advance.

 

I made a table with cells filled with different shades of grey, starting with black, tint: 90% and ending with black, tint: 10%.

I don't want the cells to have strokes between them (the diferent shades of grey should "touch" each other directly, without any borders between them).

 

So I turned off all the strokes between the cells, but I noticed some kind of tiny white lines / gaps (or how should I call them) between the cells. I checked all the cell options, but I can't find the culprit.


Just as a test, I replaced the shades of grey with different colors (red, green, blue, yellow etc.) and it looks fine. The colors touch each other without unwanted "gaps" between them.

 

The problem not only appears in Indesign, but also in exported PDFs and even printed on paper, though it's not so visible on paper. But it is there, I can see it if I look carefully.

 

Thanks.

TOPICS
How to

Views

273

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

did you make a table style with no columns and row strokes?  screenshots help

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

example printscreen.png

 

JonathanArias, thank you for your reply. 

 

Here's a screenshot, I just added some red arrows manually so you can notice the phenomenon more easily. The darker the shade - the more obvious is the problem.

 

You can also zoom in the picture (it doesn't matter that the text will get pixelated, it will help you to notice those "lines" or "gaps" more easily).

 

This is an ordinary printscreen (just cropped). If I export the page as a jpg in 600 or 1200 dpi, the problem seems to be gone or maybe it's just not so obvious anymore, I don't know. In PDF it is quite obvious.

 

On paper it is hard to notice it, but I think that it is still there (like tiny tiny lines between the cells) or maybe it's just my imagination.

 

Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

Thanks. You did not answer my question. What are your table styles?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

I haven't defined any table styles. I just inserted a table (Table > Insert Table, with the default Basic Table style) and I choosed 1 column, 15 rows, 1 header row. Then I made some manual interventions:

 

I selected all the rows, except the header one, and I set the strokes between them to 'none'. 

 

Then I manually selected the rows one by one and I defined a fill for each one of them (black + playing with the tint percentage).

 

I didn't touch any other settings.

 

Even if I select the whole table and if I switch off ALL the strokes: top, bottom, left, right, everywhere, the problem remains the same.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

I created a similar setup and I exported as Interactive PDF with default settings which at 96 ppi compression.  I saw the problem, though, honestly,  I wouldn't have necessarily noticed it if I wasn't looking for it.  When I changed the compression to 300 ppi, it seem to help resolve it. And bear in mind, most viewers will not be zooming in beyond 100%, right? What compression are you using for the PDF?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

 

Thanks for your reply, Diane Burns. I'm not an expert, but these artifacts should not be there and I don't think that improvizing with the ppi settings is the right solution (or hoping that the readers will not zoom 100%). I don't find that approach very professional. It's like trying to obscure imperfections in "post-production" (sort to speak). I believe that things should be done as good as possible in the source document (at the "production stage"), so it can be exported digitaly and then zoomed at will or printed without worrying that something will pop up. After all, this is just a table, not something very ambitious, so why this cannot work well is beyond me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

export int pdf.png

 

Update:

 

Dear Diane Burns,


I gave your advice a chance, but no offence, it is not a serious and professional advice, and I'm afraid that you maybe confused something.

 

I'm talking about a table, not an image (jpg, tiff, png), so how the 'Image Handling' settings that appear when you export as Interactive PDF can affect a table? You suggested changing the compression and/or ppi. Afaik, that affects only images.

 

Also, why do you reffer to 'changing the ppi' as to 'changing the compression'? What is "96 ppi compression"? I'm afraid that you confuse different things.

 

And after all, why would one need to go through all that just to have a decently looking table?

 

For this experiment, I exported the page as an interactive pdf (as you suggested), but I ussualy don't do that. I always export as PDF print with the best settings, so people can get good prints if necesary.

 

With your approach, the artefacts are still visible (at least here on my machine). Note that I opened the interactive pdf it in a PDF reader, but strangely, when opened in a browser (Chrome), the problem is not so obvious. This is an unpredictable behaviour and this is not good.

 

No offence, please, but I'm afraid that your answer didn't deserve a like. If I'm wrong, I will apologize.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

I am not confused (though I do take a little offense 😊).

I created a table, of course. I had thought of working with gradient or other as Uwe suggested, but wanted to try to keep it simple. 

While this issue is not addressed directly, if you have any other questions about tables, you may want to check out my 3+ hrs course on InDesign tables on LinkedIn Learning (formerly Lynda.com) https://www.linkedin.com/learning/indesign-tables/

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

You are right, of course, that compression only affects images; I didn't think that one through. But have you tried turning off this setting in Print PDF? Good luck!

 
 

compress.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

Hi sd5e8a,

I think it's the same issue we sometimes see with aligning objects that are stacked on each other and are rendered a bit off for screen representation with various zoom values depending on screen resolution and viewing sizes with PDF viewers of any kind. No issue for high quality offset printing. No issue for digital printing with high res output.

 

To avoid this we would need a table without any fills in the cells.

Stacked behind the table should be either an image showing the diverse fills or, if we are lucky, separate graphic frames with the different shades of gray. An awfull hack, yes, I know…

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

Table_grey.png

  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

LATEST

Jumping in: I created a similar table in my ID and am not experiencing the same issues.

When you said you selected "None" for the strokes between cells, are you talking about the Colour assigned to them?

Did you also specify a Stroke weight of "0"? This is actually the critical setting; It's actually not necessary to spec a colour of "None" for the stroke, as long as the weight is "0"

 

Anyway: Can you upload an .innd file with your table on it for review?

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines