P: AgExport Rendition error when emailing image

4 Votes
LEGEND ,
Mar 07, 2012 Mar 07, 2012

Copy link to clipboard

Copied

After I enter an e-mail address and subject, I hit send, which immediately returns "Unable to Export: An Internal Error has occurred: AgExportRendition: can not import a photo exported to a temporary location."

I found a report of this bug for the Beta, and tried the solution there of deleting the "For Email" preference file. Did this and restarted LR, but it made no difference.

I am running with Administrator privileges on Vista 64bit, using MS Outlook 2003. I upgraded from LR 3.6 to LR 4, and am in a catalog that was converted from LR 3.6 to LR 4. LR 3.6 and a 2.x version are still installed on the same computer.

Bug Fixed
TOPICS
macOS, Windows

Views

16

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
9 Comments
Participant ,
Mar 11, 2012 Mar 11, 2012

Copy link to clipboard

Copied

Same problem here.

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 11, 2012 Mar 11, 2012

Copy link to clipboard

Copied

I have the same problem after upgrading from LR3 on my Windows 7 x64 workstation. I also tried deleting the preferences files without any success.

Votes

Translate

Translate

Report

Report
Participant ,
Mar 16, 2012 Mar 16, 2012

Copy link to clipboard

Copied

Interesting. I guess we are the only three people with this problem. I re-installed and got the same error message "an internal error has occurred: AGExportRendition: can not import a photo exported to a temporary location."

I wonder what's up with this. I would like to email some photos. No dice.

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 26, 2012 Mar 26, 2012

Copy link to clipboard

Copied

A fix for this was posted
Here, as follows:


chicoma12345906867 wrote: Select "email photo" and when you get the email dialog screen (Where youenter the email address etc.) you should have preset drop down on the lowerleft. If you click on it, there should be an option create new preset. Makesure email is the type and change an option like quality and click exportand see what happens.


I tried it on my Vista 64 bit system and it worked fine. Oddly enough, I retried the original preset that had failed before, and it works now too!

Votes

Translate

Translate

Report

Report
Community Beginner ,
Apr 01, 2012 Apr 01, 2012

Copy link to clipboard

Copied

Title says it all. Hitting Send gets that error without explanation, so can't email from File/email photo even after trying to avoid all possible personal input errors.

Also, inserting "address" doesn't do anything for me, such as creating an address book or inserting that address into the dialog box.

Tried Help, but there's none for LR 4 therefore no help about email.

Win 7 Pro 64-bit, 12GB RAM, Thunderbird email -- DKD

Votes

Translate

Translate

Report

Report
Community Beginner ,
Apr 02, 2012 Apr 02, 2012

Copy link to clipboard

Copied

A fix and two questions:

The fix above from chicoma fixed the "send" problem, apparently permanently - thanks.

The "captioning as label" is grayed out - and I want to use that. I have captions in the metadata of the photos I emailed but that block doesn't enable them in the email. What conditions make that block active?

Entering an address into the "address" block enables an address to be picked from the list it creates by typing the first letter, but clicking or double-clicking on an address does nothing. This means that addresses that have the same first letter can't be separated out, it seems, or have I just not psyched out what this does (no instructions that I can find on this).

Votes

Translate

Translate

Report

Report
Participant ,
Apr 02, 2012 Apr 02, 2012

Copy link to clipboard

Copied

To select an address that you have already entered into your addresses (clicking on the address button will reveal your saved addresses), click the check box on the left of the address. An address will be created in the To field, so long as you were in the To field to start with. It isn't hellish intuitive that they are check boxes but this is the only way to auto-insert the address into the To field.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Apr 02, 2012 Apr 02, 2012

Copy link to clipboard

Copied

Address problem fixed - thanks to Katherine

Still wondering about the captioning, as in my above: "The "captioning as label" is grayed out - and I want to use that. I have captions in the metadata of the photos I emailed but that block doesn't enable them in the email. What conditions make that block active? "

Votes

Translate

Translate

Report

Report
LEGEND ,
Apr 13, 2012 Apr 13, 2012

Copy link to clipboard

Copied

LATEST
An internal error has occurred: bad argument #1 to 'loadstring' (string expected, got nil)

This is the error I get when sending an image

Votes

Translate

Translate

Report

Report