Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


P: Camera Raw, Lightroom Classic: Internal math error on export

9 Votes
Engaged ,
Apr 01, 2021 Apr 01, 2021

Copy link to clipboard

Copied

ScreenShot20210401at7.59.44AM-d1428c80-b880-4866-afcf-87b6b570ff45-576464191.pngScreenShot20210401at7.59.44AM-d1428c80-b880-4866-afcf-87b6b570ff45-576464191.png

After exporting this error report populates and states that an internal math error has occurred for 18 of the images. I'm not sure how to fix this. Can someone help me out? 

Bug Investigating
TOPICS
macOS, Windows

Views

479

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
94 Comments
Adobe Community Professional ,
May 26, 2021 May 26, 2021

Copy link to clipboard

Copied

First, try disabling GPU in the preferences (Preformance). Any better? Exactly what version of your OS would also be helpful. Assuming you really want help from other users.  

2nd, this is a User to User forum so your 'rants' towards Adobe are pointless. 

To provide feedback and suggestions about what you desire from Adobe, you should go to this URL and comment after selecting the appropriate product line:
https://feedback.photoshop.com/categories/products/5f5f2090785c1f1e6cc40864

Author “Color Management for Photographers" & "Photoshop CC Color Management" (pluralsight.com)

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 26, 2021 May 26, 2021

Copy link to clipboard

Copied

Images are corrupted exporting reporting Math Error, after editing over 600 photos of a wedding......

Exporting to DNG is an option, then create a new Catalog and exporting to JPG is not reporting errors but is killing my workflow...

Copy/paste is still failing

Awaiting for the proper solution

Versions:

BIG SUR 11,3,1

LRC 10,2

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

I am sorry to hear about your issue @paying4sheet. 

I have a few questions for you.

  • Were all 600 images corrupted or a smaller number? How many?
  • Is it only on Export as JPEG that you see the issue? Export as Tiff?  
  • You mention export as DNG and creating a new catalog. Do those images not import into and work from your regular catalog?

No one at Adobe has yet been able to reproduce this issue. We need example files and step by step instructions to try and recreate this issue so the devs can fix it. 

Can anyone here provide an image that fails and the steps used to create the error?

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

Same Issue!! Adobe please fix this bug. I have never had this issue before. What the heck! I was working on 900 photos for a client and this showed up. Same thing would happen when I would copy and paste settings or presets. 

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

A number of people have reported this bug. Please add your constructive opinion to the bug report:

https://feedback.photoshop.com/conversations/lightroom-classic/lightroom-classic-internal-math-error...

 

and be sure to click Like and Follow at the bottom of the first post. That will make it a little more likely Adobe will prioritize the fix, and you'll be notified when the bug's status changes. Product developers rarely participate in this forum and won't see your feedback.

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jun 01, 2021 Jun 01, 2021

Copy link to clipboard

Copied

Have you found a correction to this issue?

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

Hallo zusammen,

 

seit einigen Tagen ist es mir nicht mehr möglich bearbeitete Bilder zu exportieren.

Angehängte Meldungen erscheinen.

Neustart hat nicht geholfen. Was kann ich tun?

 

Vielen Dank vorab.

Alexandra

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

Google translation: "Edited images cannot be exported. For a few days I have not been able to export edited images. Attached messages appear. Rebooting did not help. What can I do?"

 

Google translation of first screenshot: "Some exports were not performed. An internal calculation error has occurred.".  Second screenshot: "There was a problem reading this photo in lightroom. You cannot make any changes to the photo."

 

The export error in the first screenshot has been reported by a number of people; the English version is "An internal math error occurred."  Adobe has acknowledged the bug:

https://feedback.photoshop.com/conversations/lightroom-classic/lightroom-classic-internal-math-error... 

 

No workaround has been posted for it, unfortunately.  You could try rolling back to an earlier version of LR, e.g. 10.1.1 or 10.0.

 

The error in the second screenshot, "There was a problem reading this photo in Lightroom", may be unrelated to the first.  The photo could be corrupted on disk, or it could have bad file permissions.  Upload it to Dropbox or similar and post the sharing link here.  We can see if the photo is corrupted or the problem is something else.

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jun 04, 2021 Jun 04, 2021

Copy link to clipboard

Copied

Same issue, it's so bizarre and so completely frustrating! I've literally tried everything imaginable for the past two days and thought I was going crazy until finding this thread... thank you all for sharing, and Adobe please fix this bug! 

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jun 04, 2021 Jun 04, 2021

Copy link to clipboard

Copied

I've been experiencing the same issue, and it's random, which makes it really difficult to figure out. However, the issue/error message does seem to occur when syncing settings or using copy/paste in the Develop module. I uninstalled and reinstalled every recent version of Lightroom Classic, created a new catalog, exported and renamed the files, and imported new files and nothing seems to change or fix the issue – it only (and continues to) glitches and corrupts the files in the develop module. I can export as DNG or JPEG but none of the changes are recorded. 

ScreenShot20210604at11.34.10AM-ebce09a4-5191-4f38-b0d8-9bb1c163ee16-169421819.png
ScreenShot20210604at11.34.01AM-69b629a0-986d-49ac-83bc-843168834700-1024728473.png
I don't have a screenshot of it, but I've also received the "math error" and this error when I've attempted to edit the files in PS - 
ScreenShot20210604at1.27.51PM-1f057046-33cf-45c5-b5de-afe75d74aa74-190214656.png
Please help! I have so many clients waiting on images! 

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jun 06, 2021 Jun 06, 2021

Copy link to clipboard

Copied

Alguém já teve retorno sobre esse erro?

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 06, 2021 Jun 06, 2021

Copy link to clipboard

Copied

Google translation: "Has anyone had feedback on this error?"

This bug report is marked "In progress" at the top, which means that Adobe is actively working on it.

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jun 11, 2021 Jun 11, 2021

Copy link to clipboard

Copied

I am having this same issue! I am exporting over 800 photos for a wedding, and maddeningly, the 12 best bridal photos are the ones that are reporting the math error! I have tried clearing multiple caches, I have tried updating Lightroom, restarting that and my computer multiple times, I have tried to delete the photos and reupload them to Lightroom and re-edit them, and then I get the same error message on export. Also if I try to zoom in to these photos at 100%, the exposure goes darker. When I click and drag while zoomed in, the photo goes to my edited exposure, then as soon as I let go of the click it goes dark again. And when I zoom back out to 50% or 0%, the photo stays at normal edited exposure. Also, when I am zoomed in to 100% or more, the brush doesn't work.

I edited these 12 photos the exact same way I edited the rest of the 800+ photos. I always use a preset and tweak on top of that.

My info:

Macbook Pro 2015

Big Sur 11.3

Lightroom Classic 10.3

Canon R6, R Adapter, Canon 24-70mm 2.4L II

This has been so frustrating -- I can't deliver the photos when the bride needs them because I can't export them! Please fix this! The same thing happened last week with a family session and I couldn't export 4 photos for the same reason. 

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jun 11, 2021 Jun 11, 2021

Copy link to clipboard

Copied

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 11, 2021 Jun 11, 2021

Copy link to clipboard

Copied

As a temporary go around, try different export settings. These are not fixes, just ideas that might keep you productive. This is not a new problem. For example: 

  • some have reported that the problem goes away if they always export to a new folder that Lightroom creates as part of the export. (Put in Subfolder) 
  • others have reported the reverse, only export into an existing folder. 
  • try sRGB, Adobe RGB and ProPhoto RGB 
  • try different Output Sharpening settings, particularly uncheck the Sharpen For box as you've probably already adjusted the sharpening. If that doesn't work, try other Sharpening settings, particularly Amount: low. 
  • and so forth though the other settings. 
  • don't use an Export preset 

Since your problem is relatively rare, it is likely that the bug is related to some combination of Export settings. 

  

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 13, 2021 Jun 13, 2021

Copy link to clipboard

Copied

Do the images in question have Transform adjustments

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jun 13, 2021 Jun 13, 2021

Copy link to clipboard

Copied

Any updates on this? I'm going through the exact same thing (for the second time in a month). I have 10 sessions and 4 weddings to edit and I have sessions edited I can't even get out. It's awful. 

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jun 13, 2021 Jun 13, 2021

Copy link to clipboard

Copied

Same exact thing is happening to me (photoshop error as well). 

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 18, 2021 Jun 18, 2021

Copy link to clipboard

Copied

Any update adobe? Been having this problem for months now. 

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jun 20, 2021 Jun 20, 2021

Copy link to clipboard

Copied

This is a shame! 
Adobe simply refuses to understand the problem and expend efforts to fix it.
I am really biased towards seeking legal assistance as I am being hampered in my work and getting paid for Adobe's poor service!

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jun 29, 2021 Jun 29, 2021

Copy link to clipboard

Copied

@Rikk I am having the same exact problems and have been for a few months now. I am happy to share my raw files and project file for your team to see what exactly is going on. you can reach me at (removed)

Thanks,

Tyler Paulson

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 12, 2021 Jul 12, 2021

Copy link to clipboard

Copied

Thank you for the offer, tpaulson36. The team was able to replicate the issue last week and have logged a bug. The problem exists Camera Raw as well so we've logged it with them. If they need another file, I will contact you. 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jul 13, 2021 Jul 13, 2021

Copy link to clipboard

Copied

@Rikk 

This is a shame. The problem has been around for so long and Adobe just doesn't do anything!

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 13, 2021 Jul 13, 2021

Copy link to clipboard

Copied

While Adobe has responded that they are working on it, you can help. Is there anything unique about those 18 images? 

 

I've tested exports of over a thousand images on Windows 10 and can't recreate the problem.

 

Have you posted a couple of those images somewhere to enable others to conduct additional tests?

  

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 15, 2021 Jul 15, 2021

Copy link to clipboard

Copied

No me deja exportar desde Lightroom, me arroja el error "se ha producido un error matematico interno"

tampoco me deja pasar de Lightroom a Photoshop. 

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines