P: Conflict between Airplay and LrC

1 Vote
Explorer ,
Dec 27, 2021 Dec 27, 2021

Copy link to clipboard

Copied

Just upgraded to 11.1 and am getting unexpected error on starting up across two different catalogs(have not tested more).

I downgraded to 11.01, and was able to open Lightroom Classic without a problem.  Backed up the library, rebooted my Mac (iMac 5K Retina, 2017) running 11.6.1, reinstalled 11.1 and it seemed to run ok for about 2 days.  This morning got the error report again and have downgraded to 11.01 again

 

Any suggestions?

Thanks

Bug Fixed
TOPICS
macOS

Views

820

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Feb 07, 2022 Feb 07, 2022
Updates to the Adobe Photography Products were released today and contain a fix for this issue. Please install the update via your Creative Cloud Desktop App or your respective App Store.    Note:  You may need to refresh the Creative Cloud App for desktop software to show an update available.  ([Ctrl/Cmd]+[Alt/Opt]+ [ R ]) For Mobile downloads, it may take several days for the update to appear in your respective App Stores.   Thank you for your patience. 
Status Fixed

Votes

Translate

Translate
16 Comments
Adobe Community Professional ,
Dec 27, 2021 Dec 27, 2021

Copy link to clipboard

Copied

What OS are you running? During installation, you might want to ensure that you are not accidentally using the previous versions' preferences and generate new ones.

warmly/j

Votes

Translate

Translate

Report

Report
Explorer ,
Dec 27, 2021 Dec 27, 2021

Copy link to clipboard

Copied

Using OS 11.6.1  

Anything thoughts about why it seemed to work for a couple of days, if the preferences were a problem?

Votes

Translate

Translate

Report

Report
Community Beginner ,
Dec 27, 2021 Dec 27, 2021

Copy link to clipboard

Copied

I have recently spent 4 hrs on the phone with Adobe support for Lightroom Classic not opening.

System iMac 2019 5k 3.7, ram 96gb...Catalina 10.15.7

Lightroom Classic 11.1

 

First call... Adobe rep after 40 min told me to upgrade to Big Sur, LR not supported bt Catalina. I hung up on them. Problem nor resolver

 

Second call....Adobe rep deleted LR and Reinstalled. After problem not resolved. Plus lost all presets for last 15yrs. Problem not resolved.

 

Third call....Helped me reload presets. Rebooted mac Lightroom opened when Apple music was not running...closed Lightroon opened Apple music and Lightroon refused to open.

 

Since then I have tried to open Lightroom over a dozen times with Apple music running...will not open. Lightroom opens fine with Apple music not running.

 

Anyone have an Idea how I can rectify this...It started with the update to LR11.1

 

Thanks

Votes

Translate

Translate

Report

Report
Explorer ,
Dec 28, 2021 Dec 28, 2021

Copy link to clipboard

Copied

Some follow up.......these are notes that I took along with way of this odyssey, but the final observation is there seems to be an adverse interaction between playing music through airplay to HomePod minis and LR 11.1 opening probably.  And perhaps this is an issue during the initial installation of 11.1, but don't know that for sure.
So resetting preferences did not work in the most straightforward way.
  1. Working in 11.01 without a problem
  2. Made a copy of the file (com.adobe.LightroomClassicCC7.plist)-- (located in folder  /Users/[user name]/Library/Preferences/)
  3. Moved copy to an external drive and deleted the copy in the preferences fold
I did those steps just in case things did not work out with changing preferences.
 
4.    Then upgraded to 11.1
  1. Updated preferences using the Shift + Option keys
  2. Lightroom opened without my old preferences (to be expected)
  3. Closed LR and it crashed on closing asking me to send an error report to Adobe…which I did
  4. Did this several times and it always crashed
So
  1. I down graded to 11.01
  2. Opened LR with the Shift +Option key to force a new preference file in 11.01
  3. LR opened without my old preferences as expected
  4. Closed LR without a crash. 
  5. Opened and closed without a problem several times
so
  1. Installed 11.1 again
  2. Nothing happened (icon on dock with bounce for a few times and then stop without windows opening)
  3. Opened LR with the Shift + Option key to install 11.1 preferences
  4. Tried to open LR and still did not open..just a brief bouncing icon
so
 
Rebooted computer, but had to force quit the Apple Music App to complete reboot process
 
18.    Opened LR after reboot and it opened without my old preferences.  Open and closed several times and it seemed to work
 
19.    Opened Music App
 
20.    Opened LR and got the brief bouncing icon on the dock and then nothing
 
21.    Closed the Music App, but had to force quit it
 
22.    Opened LR and it opened properly.  Did this several times and it seemed to work
 
23.    While LR was open, reopened the Music App and it spent a very long time loading the library
 
24.    In the meantime, I updated my LR preferences and finally the Music app loaded its library
 
25.    With the Music App open and playing music, quit LR
 
26.    Tried to reopen LR and nothing happened.  No bouncing icon or anything
 
27.    Quit the Music App
 
28.    Tried to reopen LR after Music App was closed and it opened with my updated preferences.  Closed and open LR several times without problems
 
29 With LR open, opened the Music app (no music playing)
 
30.    Closed LR and re-opened LR several times and it seemed to work (Music app open, but not playing music)
 
31.    With LR closed, started playing music on the Music App via airplay 2 to Homepod Minis.  With music playing, LR refused to open)
 
31.    Stop playing music in the Music App and LR still refused to open
 
32.    Quit Apple Music
 
33.    Opened LR and got an error message saying something about the windows and given an option to reopen the windows.  Selected reopen the windows and LR seemed to open properly.
 
34.    Closed LR and reopened it several times without additional errors. , but Apple Music was closed
 
35.    Opened Apple Music but NO music playing
 
36.    Opened and closed LR several times without problems.
 
I have now replicated this process and the following appears to be the case.
 
If Apple Music is open AND playing music, LR will not open
 
If Apple Music is open, AND HAS NOT PLAYED music, LR will open
 
If Apple Music has been opened and played music even briefly and then stopped, LR will start to open and then close
  1. Opened Pandora and played music through iMac.  LR opened and closed successfully several times
  2. Switched Pandora to play through Airplay to Homepod Mini’s.  LR fails to open and on second try get a message that says “The last time you opened Lightroom Classic, it unexpectedly quit while reopening windows.  Do you to try to reopen its windows again.”  Selected ReOpen option and and LR closes
  3. Switch Pandora to play through iMac, got the same error message as above, but then LR opened properly.
  4. Opened and closed LR several additional times without errors
Went back to Apple Music and played music through the iMac.  LR opened and closed several times without problems.
 
With LR open, switch Apple Music to airplay 2 to Homepod minis (stereo pair)
 
Closed LR, reopened and it failed to open.  On a second try, got the same error message “The last time you opened…), upon selecting ‘ReOpen’, LR closes.  A third try a repeat LR fails to open with the same error message
 
Closed the Music App, and upon reopened LR get the same error message, but selecting the ‘Reopen’, LR opens properly.
 
SO on further exploration it seems like it is related to any music app playing through airplay and somehow that interferes with LR opening properly.

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 28, 2021 Dec 28, 2021

Copy link to clipboard

Copied

Check in the OS and see what file types are associated to the music apps.

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 28, 2021 Dec 28, 2021

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Explorer ,
Dec 28, 2021 Dec 28, 2021

Copy link to clipboard

Copied

I had a similar problem and it seemed to be related to use of Airplay 2, as I could open LR with the Music or Pandora App open playing through my computer, but not if it was playing to my Homepod Minis.  When using airplay, LR would crash

Here is the link to my note

https://community.adobe.com/t5/lightroom-classic-discussions/unexpected-error-on-startup-of-11-1/td-...

 

Votes

Translate

Translate

Report

Report
Community Beginner ,
Dec 28, 2021 Dec 28, 2021

Copy link to clipboard

Copied

Interesting, all times Apple music was running ! was using Airplay 2 also. 

Votes

Translate

Translate

Report

Report
Explorer ,
Dec 28, 2021 Dec 28, 2021

Copy link to clipboard

Copied

How would I check the OS to see what apps are running.....activity monitor with just the app in question running?

 

Votes

Translate

Translate

Report

Report
Explorer ,
Dec 29, 2021 Dec 29, 2021

Copy link to clipboard

Copied

I have previously posted a very long note describing the process I went through to understand this problem.  In this note I want to reduce it to the most critical elements so it is a bit easier to understand

iMac 2017 5K retina display running OS 11.6.1.  The issue described below appeared following upgrade from 11.01 to 11.1 and is very reproducible on my machine.

1. If one starts to play music (either Apple Music or Pandora) through airplay to a homepod mini (in my cases a stereo pair) and then attempt to open LR 11.1, it will crash and fail to open

2. If one starts LR 11.1 first and then starts playing music through airplay to a homepod mini, LR 11.1 seems to work properly, but if you close LR 11.1 with the music still playing and then try to open LR 11.1, it will fail to open.

Votes

Translate

Translate

Report

Report
New Here ,
Dec 31, 2021 Dec 31, 2021

Copy link to clipboard

Copied

Same issue as everyone else....

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jan 02, 2022 Jan 02, 2022

Copy link to clipboard

Copied

We were able to reproduce this issue and have logged a bug for it. 

Setting status to acknowledged. 

Rikk Flohr - Customer Advocacy: Adobe Photography Products
Bug Acknowledged

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jan 10, 2022 Jan 10, 2022

Copy link to clipboard

Copied

When a bug like this verified, how long does it normally take to have it rectified?

Votes

Translate

Translate

Report

Report
Community Beginner ,
Feb 07, 2022 Feb 07, 2022

Copy link to clipboard

Copied

will this ever be fixed?

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Feb 07, 2022 Feb 07, 2022

Copy link to clipboard

Copied

Updates to the Adobe Photography Products were released today and contain a fix for this issue. Please install the update via your Creative Cloud Desktop App or your respective App Store. 

 

Note: 

You may need to refresh the Creative Cloud App for desktop software to show an update available.  ([Ctrl/Cmd]+[Alt/Opt]+ [ R ])

For Mobile downloads, it may take several days for the update to appear in your respective App Stores.

 

Thank you for your patience. 

Rikk Flohr - Customer Advocacy: Adobe Photography Products
Bug Fixed

Votes

Translate

Translate

Report

Report
Community Beginner ,
Feb 08, 2022 Feb 08, 2022

Copy link to clipboard

Copied

LATEST

Rikk, Thanks!

Due to our network situation the whole office has music again now. The entire crew says Cheers! 

Votes

Translate

Translate

Report

Report