P: Copy/Sync Crop and Spot Removal wrong results at portrait photos

2 Votes
Community Beginner ,
Oct 28, 2020 Oct 28, 2020

Copy link to clipboard

Copied

Copy or sync crop and spot removal develop settings causes wrong results at portrait photos. The crop and spot removal settings are wrong by 90° after copy/paste or sync.

 

Here an example photo to reproduce.

- Importing in Lightroom Classic 10

- Create a copy by edit in Photoshop 

20201028_194626-85cd79ad-6636-465e-a5ac-e9063216751f-2062927353.png20201028_194626-85cd79ad-6636-465e-a5ac-e9063216751f-2062927353.png

- Make a small edit, e.g. add text "Photoshop edit" and save.

- Add a crop and spot removal e.g.

20201028_195759_-b21a1fa4-3206-4bd7-96d5-d9124c35ca0b-1094168570.jpg20201028_195759_-b21a1fa4-3206-4bd7-96d5-d9124c35ca0b-1094168570.jpg
20201028_200351_-bbcb97a9-1285-4c19-8262-10bd709a9a2d-714499383.jpg20201028_200351_-bbcb97a9-1285-4c19-8262-10bd709a9a2d-714499383.jpg

 

- Copy or sync the crop and spot removal develop settings to the same/original photo before the edit in Photoshop. But the result of the crop and spot removal is totally wrong:

20201028_195844_-d59aca73-62e9-4b49-b55b-4725adc1a955-382007671.jpg20201028_195844_-d59aca73-62e9-4b49-b55b-4725adc1a955-382007671.jpg
20201028_200418_-c01b5eb2-cb95-4088-815d-2851bf45c078-892300949.jpg20201028_200418_-c01b5eb2-cb95-4088-815d-2851bf45c078-892300949.jpg
Bug Fixed
TOPICS
macOS, Windows

Views

78

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
46 Comments
Adobe Employee ,
Oct 29, 2020 Oct 29, 2020

Copy link to clipboard

Copied

Hi Maik,

Thanks for reporting this. 

I just verified this in 9.4, and could confirm the behaviour there as well. Have you also observed the same in older versions?

Irrespective of that, we will investigate the same and get back.

Few questions :

1) Was this a landscape image initially on which the orientation was changed to portrait?

2) Do you see this issue on an actual portrait image as well?

Thanks,

Arjun

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 29, 2020 Oct 29, 2020

Copy link to clipboard

Copied

@arjun_haarith

The provided sample image is the original JPG image from a Nikon Coolpix 995 camera after imported into Lightroom. Because the camera has no orientation sensor (and no orientation exif tag), Lightroom displays every portrait photo from this camera as a landscape photo after the import. So I had to rotate it manually in Lightroom [Library -> Photo -> Rotate Right (CW)].
This problem I has only now been noticed. Up to now I had denoised all my JPG images before importing them into Lightroom using the Neat Image application, because it gives much better results than the Lightroom denoised function. 
But now I wanted to change my workflow to completely use Lightroom and import the original (not denoised) JPG of the camera and try to transfer the development settings. I noticed that the crop and spot removal develop settings are transferred incorrectly. Affected are all images rotate in Lightroom, if the source image of the development settings was processed by any external program.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

Updates to Lightroom Classic and the Lightroom Ecosystem products for Desktop, Mobile and Web were released today and contain a fix for this issue.

Please refresh your Creative Cloud application and install your update when it becomes available. Thank you for your patience.

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

[Update: This isn't quite right, see below.]

The bug is only partially fixed -- copy/paste of crops and local adjustments between photos with different rotation/mirroring (called "orientation" by LR internals) now works only if the target photo's orientation has been saved to the file's metadata.

To reproduce:

0.  Uncheck the option Catalog Settings > Metadata > Automatically Write Changes Into XMP.

1. Import a raw photo that hasn't been rotated in-camera and that doesn't have a .xmp sidecar.

2. Do Photo > Rotate Right.

3. Do Photo > Edit In > Photoshop and save the file as a TIFF.

4. In LR, crop the TIFF and apply a visually noticeable brush stroke.

5. Select the TIFF, do Photo > Develop Settings > Copy Settings, select Local Adjustments and Crop, then do Paste Settings on the raw.

6. Observe that the crop and the adjustments have been placed in a different location on the raw:

Untitled1-0d927438-5b75-4108-aaef-8efa6f6b04c9-1210388217.png

7. Do Edit > Undo Paste Settings.

8. Select the raw and do Metadata > Save Metadata To File.

9. Do Photo > Develop Settings > Paste Settings.

10. Observe that the crop and local adjustments are now correctly placed on the raw:

Untitled2-c57791a2-68b2-420a-b922-04adacfb2371-1209464696.png

Tested with LR 10.2 / Mac OS 10.15.7.

Votes

Translate

Translate

Report

Report
New Here ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

When I select a group of photos in 4x6 format and change a 4x6 portrait to a 16x9 aspect ration and sync the other photos change to a 10x12 in landscape.

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

Hello, could you state the version of Lr Classic you are using, and your OS?

Votes

Translate

Translate

Report

Report
New Here ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

Lightroom Classic 10.2 release Build 202103041821-226a1211

Windows 10 Home 20H2 OS build 19042.867

There is a Cumulative update KB5001567 that is available

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

Thanks, Is this issue new/unique to this update of Lr?

Votes

Translate

Translate

Report

Report
New Here ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

Yes, was fine yesterday, automatic update this morning.  Also happens when going from 4x6 to 8x10.  Ran the windows 10 update, no change.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

Can you give me step by step instructions for reproducing?

1.

2.

3.

4.

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
New Here ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

Get 4 4x6 photos crop 2 as landscape and 2 as portrait.  Select all 4,  then using one of the landscape shots change it in develop to a 16x9 then sync with just process and aspect ratio.  At least the 2 portrait should be obviously wrong.  

I can give a step by step with more detail after the college double header I am shooting. 

Votes

Translate

Translate

Report

Report
New Here ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

Further checking this morning seems to show the problem happens when you crop a landscape picture to portrait and later sync to a different aspect ratio. The sync seems to go back to landscape and uses the center section.

The sync was referenced to a landscape photo, have not checked for using a portrait photo as the starting point.

Basic editing routine

1 import photos to Lightroom

2 preliminary edits 

3 export as uncropped

4 crop  and export as full

5 Select all photos then convert 1st photo in group to 16x9 aspect.

6 Sync all the photos to 1st photo checking only Process Version and Aspect ratio.

 Samples are in JohnWacher.com LR Problem. 

Votes

Translate

Translate

Report

Report
New Here ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

Used a portrait photo as reference for sync, it messed up all 3 other photos.

Samples in JohnWacher.com LR Problem labeled Synced2_from_Portrait.

This has never been a problem in the past.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

Either I am misunderstanding you or unable to reproduce what you are seeing. Can you post a screenshot of LrWeb and LrClassic showing the issue?

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community Beginner ,
Mar 19, 2021 Mar 19, 2021

Copy link to clipboard

Copied

@Rikk 

I updated to Lightroom Classic 10.2 on Windows 10 and unfortunately the bug still occurs and is not solved.

Even if I check the option in Catalog Settings > Metadata > Automatically Write Changes Into XMP (John_R_Ellis has previously written it should works with it).

20210319_131613-76fe27c4-5eb7-4163-a270-b709b5d027c4-409692571.png

Steps to reproduce:

- Download my sample image from post1

- Removing all metadata from the image (because Lightroom has unfortunately added the rotation directly to the image).

- Import the image into Lightroom Classic 10.2

- rotate the image by: Photo -> Rotate Right (CW)

- right click on the image -> Edit in -> Photoshop 2021 -> Edit a Copy

- In Photoshop 2021: File -> Save -> close Photoshop

- Now, 2 times the same image is existing (imported and a copy from Photoshop). 

20210319_131514-da542bf6-9b0f-4ade-822d-cbfc90d73ab7-476887589.png

- goto develop tab
- crop the left image
- add spot removal to the left image (removes the boat on the left side)

- now we have:

20210319_130026-7f21c1fa-01fc-4493-8674-89443015b50c-1963194456.png

- copy develop settings from from left image (spot removal + crop)
- paste develop settings to to the right image

- Now both images should have the same crop and spot settings, but the result is (grid view):

20210319_130155-454b7e03-9b8c-496d-a50c-d1596f30f72c-1359305227.png

- Result in Develop Tab and show the crop:

20210319_130922-30f45bc6-733b-4e83-8376-ddd9a67f7cc8-1357098909.png

20210319_135206-0e2e4fdf-05ee-4dab-adcf-6ece0d020244-489906697.png

Now you can see 3 bugs:

- crop is wrong

- spot removal is wrong (instead of removing the boat on the left, the plants in the water ( bottom) are changed

- lock for crop is wrong

Votes

Translate

Translate

Report

Report
Community Beginner ,
Mar 19, 2021 Mar 19, 2021

Copy link to clipboard

Copied

I just did more tests and found a new problem.

Steps to reproduce:

- reimport the same image (without metadata)

- rotated the image and added crop & spot removal

- now right click on the image -> Edit in -> Photoshop 2021 -> Edit a Copy

- In Photoshop 2021: File -> Save -> close Photoshop

Result: the copy (right) by Photoshop is completely different to the source (left) and also significantly distorted.

20210319_143452-2b634d8e-4fab-4b1a-aa6f-81989ffb1c95-426444499.png

Votes

Translate

Translate

Report

Report
New Here ,
Mar 19, 2021 Mar 19, 2021

Copy link to clipboard

Copied

Original_Photos-a0736ca2-f8e2-4984-9836-01c3168f96b5-114116574.jpg

Snip 1 showing original photos.

Votes

Translate

Translate

Report

Report
New Here ,
Mar 19, 2021 Mar 19, 2021

Copy link to clipboard

Copied

Snip 2 showing cropped edited photos ready to be changed to 16x9

B4_Sync-bed9719f-3dd7-48e2-bfe7-f23693fb91b1-2002288539.jpg

Votes

Translate

Translate

Report

Report
New Here ,
Mar 19, 2021 Mar 19, 2021

Copy link to clipboard

Copied

Snip 3 showing photos after syncing the 1st photo which had been changed from 4x6 to 16x9. Photos that did not have their original orientation changed are fine, the ones that were changed from landscape to portrait are not.

After_Sync-3167ffac-bcc7-4aa9-a085-6cc7b96e9820-630583983.jpg

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 20, 2021 Mar 20, 2021

Copy link to clipboard

Copied

"Result: the copy (right) by Photoshop is completely different to the source (left) and also significantly distorted."

This is a distinct bug that was adding to confusion about what we are seeing.  I filed a separate bug report for that here:

https://feedback.photoshop.com/conversations/lightroom-classic/lightroom-doesnt-correctly-import-a-r... 

There are two workarounds to this bug: After PS returns to LR, do Metadata > Read Metadata From File, or use Edit A Copy with Lightroom Adjustments instead of Edit A Copy.

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 20, 2021 Mar 20, 2021

Copy link to clipboard

Copied

The Edit A Copy metadata bug was creating confusion. Once I worked around that, I can copy crops and all the local adjustments EXCEPT spot removal correctly. (Prior to LR 10.2, none of those would copy correctly between photos with different orientations.)

Here's a video of the steps below:
https://www.dropbox.com/s/dimgdadxk9meljm/copying-local-adjustments.2020.03.20.mov?dl=0 

1. Set the option Catalog Settings > Metadata > Automatically Write Changes Into XMP.

2. Import a JPEG that doesn't have in-camera rotation applied.

3. Do Photo > Rotate Right.

4. Wait until the metadata badge in the upper-right corner of the thumbnail goes away, indicating that metadata has been saved to the photo.

5. Do Edit In > Edit In Photoshop, Edit A Copy.

6. In PS, add some brush strokes and close the photo.

7. In LR, select the edited photo and do Metadata > Read Metadata From File.

8. Take the edited photo into Develop, crop it, and add a spot removal, a gradient filter, a radial filter, and an adjustment brush.

9. In Grid view, select the edited photo and do Photo > Develop Settings > Copy, selecting Local Adjustments, Spot Removal, Crop, and Process Version.

10. Select the original photo and do Photo > Develop Settings > Paste Settings.

11. Observe that the crop, gradient filter, radial filter, and adjustment brush are correctly copied, but the spot removal is placed in a different location.

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 20, 2021 Mar 20, 2021

Copy link to clipboard

Copied

"lock for crop is wrong"

See this existing bug report:

https://feedback.photoshop.com/conversations/lightroom-classic/lightroom-classic-selected-aspect-rat... 

Click Like and Follow at the bottom of the first post, to make it more likely Adobe will prioritize a fix and to be notified when the bug's status changes.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Mar 22, 2021 Mar 22, 2021

Copy link to clipboard

Copied

@John_R_Ellis 

Hello John

Thanks for the support and the video.
I did exactly the same thing on my Windows 10 as you did in the video and unfortunately it doesn't work for me.
I then turned off that Lightroom writing metadata to the JPEG (rotation). But that does not work either. The file date was from 2005, after using it in Lightroom the file date was current. Lightroom still writes metadata to the JPG instead of XMP files and also external image viewers follow the new written JPEG rotation after that.
In addition, I then imported the 2 images again (this time without rotation) and changed the other image and then copied the settings to the Photoshop image, but that also does not work.

<iframe src="https://www.youtube.com/embed/yvBCR6e42JA" style="max-width: 100%; max-height: 100%;" width="640px"></iframe>

Looks like there are several bugs with basic tasks in the current version.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Mar 23, 2021 Mar 23, 2021

Copy link to clipboard

Copied

I believe you said so above but can you confirm the version you are on currently and the version you were on before your Auto-update?

If, on screen 3, rather than sync the images you select all in Grid and use the Quick Develop crop, what does your grid look like?

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community Beginner ,
Mar 23, 2021 Mar 23, 2021

Copy link to clipboard

Copied

Oh, sorry, unfortunately I had forgotten to activate the "Local Adjustments" when copy the settings. Here is a new video where I exactly follow your instructions.

<iframe src="https://www.youtube.com/embed/OsKdVOXFgEk" style="max-width: 100%; max-height: 100%;" width="640px"></iframe>

On the normal way, nothing works, crop, spot removal and local adjustments -> everything is wrong. After deleting the images and re-importing (but without rotation), the crop and local adjustments are correct, but spot removal is still wrong.

Why does Lightroom write metadata to the JPG when I have explicitly disabled it in the catalog settings? As you can see in the video, the JPG is modified and after deleting the images in Lightroom and re-importing, the last rotation is loaded.

Votes

Translate

Translate

Report

Report