• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

P: Doesn't Reopen Switching to Different Catalog

Community Beginner ,
Apr 30, 2023 Apr 30, 2023

Copy link to clipboard

Copied

Although in prior versions it did, Lightroom Classic does not automatically reopen when I have it opened and want to swwitch catalogs using File>Open Recent> [Select Catalog].  It just shuts down.  When I manually reopen it chooses the catalog I last selected, but this used to happend automatically without manually reopening it.  Running this from Macbook Pro M1 laptop while running OS X Monterey 12.5.1. Any suggestions are apprecited. 

Bug Fixed
TOPICS
macOS , Windows

Views

1.0K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Pinned Replies

Adobe Employee , Jul 13, 2023 Jul 13, 2023

Setting status - adding bug

Status Investigating

Votes

Translate

Translate
Adobe Employee , Oct 10, 2023 Oct 10, 2023

Greetings all,

 

Updates for the Adobe Photography Products have been released.  The October 2023 updates contain a fix for this issue. 

If you do not see the update in your Creative Cloud Application, you can refresh it by hitting [Ctrl/Cmd]+[Alt/Opt]+[ R ].

Note: It may take up to 24 hours for your update to be available in your Creative Cloud app.

 

Thank you for your patience.

Status Fixed

Votes

Translate

Translate
10 Comments
LEGEND ,
Apr 30, 2023 Apr 30, 2023

Copy link to clipboard

Copied

I've noticed this misbehavior a few times.  I've also noticed that the samizdat "restart" script:

import "AgApplication".relaunch ()

 

that many of us have used for years fails intermittently. 

 

But unless there is a precise recipe by which Adobe can reproduce these symptoms (or if dozens of people report it), the problem won't get addressed. 

Votes

Translate

Translate

Report

Report
Community Expert ,
Apr 30, 2023 Apr 30, 2023

Copy link to clipboard

Copied

I see this happening regularly. It also happens when Optimize Catalog is used.

Votes

Translate

Translate

Report

Report
New Here ,
Jul 13, 2023 Jul 13, 2023

Copy link to clipboard

Copied

Same thing happens to me every time. M1 MBP and M2 Mini running Ventura latest.

Votes

Translate

Translate

Report

Report
Community Expert ,
Jul 13, 2023 Jul 13, 2023

Copy link to clipboard

Copied

I submitted an internal Bug Report for this many months back.

 

@Rikk Flohr: Photography can you move this thread to the Bugs Forum.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jul 13, 2023 Jul 13, 2023

Copy link to clipboard

Copied

Like @johnrellis  I've seen it a few times but haven't been able to reproduce it.  Looks like it was LRD-4209824

and a second bug: LRD-4210190

I will merge them.

 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jul 13, 2023 Jul 13, 2023

Copy link to clipboard

Copied

Setting status - adding bug

Rikk Flohr - Customer Advocacy: Adobe Photography Products
Status Investigating

Votes

Translate

Translate

Report

Report
LEGEND ,
Jul 13, 2023 Jul 13, 2023

Copy link to clipboard

Copied

It happens to me now perhaps 1/3 to 1/2 of the time. I've tried but failed to identify a recipe for reproducing it reliably across machines, making it less likely it will get attention from Adobe.  I've tried tracing internal errors using the -tracebacks switch but didn't learn anything (mainly because the problem didn't occur while I was tracing).

 

It strikes me personally because I have several test catalogs for plugin development and helping out on the forums, as well as two personal catalogs with much different purposes.   So I'm constantly switching catalogs, many times a day.  Not representative of the typical user.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 10, 2023 Oct 10, 2023

Copy link to clipboard

Copied

Greetings all,

 

Updates for the Adobe Photography Products have been released.  The October 2023 updates contain a fix for this issue. 

If you do not see the update in your Creative Cloud Application, you can refresh it by hitting [Ctrl/Cmd]+[Alt/Opt]+[ R ].

Note: It may take up to 24 hours for your update to be available in your Creative Cloud app.

 

Thank you for your patience.

Rikk Flohr - Customer Advocacy: Adobe Photography Products
Status Fixed

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 22, 2023 Oct 22, 2023

Copy link to clipboard

Copied

i've just updated to the new Oct release and now can not use Lightroom at all the app. will not stay open after optimizing to a new cat, have sent reports to both Apple and Adobe but no help so far and my dealines are looming fast !

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 22, 2023 Oct 22, 2023

Copy link to clipboard

Copied

LATEST

johngjman@btinternet.com, you've posted in a thread that is almost certainly unrelated to your problem. Please start a new thread in the Discussions section, including more detailed description of what you see when you try to start LR.  Also do the LR menu command Help > System Info and copy/paste the entire contents in your post so we can see exactly which versions of hardware and software LR thinks you're running and important LR options that are set.

Votes

Translate

Translate

Report

Report