P: Negative Values Bug (German)

7 Votes
Explorer ,
Apr 23, 2015 Apr 23, 2015

Copy link to clipboard

Copied

LR 6:

Cannot enter negative values e.g. for lighting in Development (e.g., -1,0); sets always to zero.
Works if I just move the slider; positive values ("+1", "1") work also.

(MacOS 10.10.3)

Bug Fixed
TOPICS
macOS

Views

21

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jun 15, 2015 Jun 15, 2015
This was fixed in the CC 2015.1 / 6.1 Update.

Votes

Translate

Translate
23 Comments
Adobe Employee ,
Apr 23, 2015 Apr 23, 2015

Copy link to clipboard

Copied

No problems here, Mac or Windows.

You might reset your preferences:

Instructions:
Reset your Preferences by closing Lightroom and then holding down [Shift][Alt/Opt] and relaunching Lightroom. When prompted, reset the preferences.
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Apr 23, 2015 Apr 23, 2015

Copy link to clipboard

Copied

What are the language settings for your OS? In particular, if you go to your Systems Preferences>Language&Region>Advanced... What are your current Number separators settings? If you change the format language to English, does the bug happen? You might need to relaunch Lr after the change.

Votes

Translate

Translate

Report

Report
Explorer ,
Apr 23, 2015 Apr 23, 2015

Copy link to clipboard

Copied

@rikk: nope, didn't work

@Simon: current settings where German; changed everything to English, but didn't help.

Interesting fact:
while I enter the number (e.g., -1,0 German or -1.0 English), LR correctly shows the new preview. When I press return, it's gone and reset to 0.0

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Apr 23, 2015 Apr 23, 2015

Copy link to clipboard

Copied

I updated my mac to 10.10.3 from 10.10.2, I am still not able to reproduce the your issue. I am on an English setup. We had a bug report like this introduced in one of the more recent Mac OSX update and a fixed was made a verified by one of our prerelease customers. There is something special about your system setup.

Votes

Translate

Translate

Report

Report
Explorer ,
Apr 24, 2015 Apr 24, 2015

Copy link to clipboard

Copied

Ok, thanks. Situation is as following:

* problem only occurs if language is set to German, regardless of number formats
* if language is English, everything is fine
* problem doesn't occur in LR 5.7 or PS CS6 (Eng or Ger)

Votes

Translate

Translate

Report

Report
New Here ,
Apr 24, 2015 Apr 24, 2015

Copy link to clipboard

Copied



in lightroom CC in the Development Modul there i can't input negative values. When i input negativ values for instance for the values of brightness or black or or or the value always gets back to "0"

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Apr 24, 2015 Apr 24, 2015

Copy link to clipboard

Copied

What language are using with Lightroom?
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
New Here ,
Apr 24, 2015 Apr 24, 2015

Copy link to clipboard

Copied

German

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Apr 24, 2015 Apr 24, 2015

Copy link to clipboard

Copied

Thanks, we'll investigate.
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Apr 24, 2015 Apr 24, 2015

Copy link to clipboard

Copied

Ok, I found the bug. The bug would appear if you set the Lr UI language preference to certain local languages such as German, Dutch etc. There is a mistranslation in one of the translated strings. 

1. If your UI language is German, open the following TranslatedStrings.txt file in TextEdit on Mac OSX:

/Applications/Adobe Lightroom/Adobe Lightroom.app/Contents/Resources/de.lproj/TranslatedStrings.txt

2. Make a copy of the file so that you can revert to if you did something wrong in the following.

3. Find the text line text that looks like this

"$$$/AgUI/TextField/MinusReplacementNoSpace=^U+2212 "

4. Remove the extra space after the ^U+2212. The result would look like

"$$$/AgUI/TextField/MinusReplacementNoSpace=^U+2212"

5. Save your change to the original file named TranslatedStrings.txt.

Relaunch Lightroom and the bug would be fixed.

If you run into the same issue in other local language, you should look for TranslatedStrings.txt for your specific language at step 1. It is in a similar subfolder structure inside /Applications/Adobe Lightroom/Adobe Lightroom.app/Contents/Resources/. Something looks lie /Applications/Adobe Lightroom/Adobe Lightroom.app/Contents/Resources/[replace_with_your_two_letter_language_code].lproj

Votes

Translate

Translate

Report

Report
New Here ,
Apr 24, 2015 Apr 24, 2015

Copy link to clipboard

Copied

thanks a lot! It works! 🙂

Votes

Translate

Translate

Report

Report
Explorer ,
Apr 24, 2015 Apr 24, 2015

Copy link to clipboard

Copied

Awesome! Works!

Votes

Translate

Translate

Report

Report
Explorer ,
Apr 26, 2015 Apr 26, 2015

Copy link to clipboard

Copied



When Adjusting tint by entering value for text area, set minus value to adjust for green,
Bounce back value goes to 0 and oppsite adjust (i.e. set -20 , +20 adjust appears) automatically appears at history.

Lightroom CC 2015/ Mac OSX 10.10.3

Votes

Translate

Translate

Report

Report
Explorer ,
Apr 26, 2015 Apr 26, 2015

Copy link to clipboard

Copied

My Mac OS X system preference language is Japanese.

Votes

Translate

Translate

Report

Report
New Here ,
May 13, 2015 May 13, 2015

Copy link to clipboard

Copied

Same (very irritating) problem here in the Netherlands - Dutch language. You seriously don't want me to enter under the hood, do you? I have no clue how to find and manage the code you mentioned... Can't you just repair this in a soon to expect update?
Tina

Votes

Translate

Translate

Report

Report
LEGEND ,
May 21, 2015 May 21, 2015

Copy link to clipboard

Copied

[Reposting Simon Chen (employee)'s workaround, since the silly forum software is now collapsing his comment and people are missing it]

Ok, I found the bug. The bug would appear if you set the Lr UI language preference to certain local languages such as German, Dutch etc. There is a mistranslation in one of the translated strings.

1. If your UI language is German, open the following TranslatedStrings.txt file in TextEdit on Mac OSX:

/Applications/Adobe Lightroom/Adobe Lightroom.app/Contents/Resources/de.lproj/TranslatedStrings.txt

2. Make a copy of the file so that you can revert to if you did something wrong in the following.

3. Find the text line text that looks like this

"$$$/AgUI/TextField/MinusReplacementNoSpace=^U+2212 "

4. Remove the extra space after the ^U+2212. The result would look like

"$$$/AgUI/TextField/MinusReplacementNoSpace=^U+2212"

5. Save your change to the original file named TranslatedStrings.txt.

Relaunch Lightroom and the bug would be fixed.

If you run into the same issue in other local language, you should look for TranslatedStrings.txt for your specific language at step 1. It is in a similar subfolder structure inside /Applications/Adobe Lightroom/Adobe Lightroom.app/Contents/Resources/. Something looks lie /Applications/Adobe Lightroom/Adobe Lightroom.app/Contents/Resources/[replace_with_your_two_letter_language_code].lproj

Votes

Translate

Translate

Report

Report
New Here ,
May 21, 2015 May 21, 2015

Copy link to clipboard

Copied

I' have been trying to follow this steps exactly. But first: the Contents folder is a hidden one. I made it visible by rightclicking on the Adobe Lightroom.app -> 'show package' (in Dutch that'd called 'toon pakketinhoud")->Contents->Resources-nl.lproj (or for exemple in French it says fr.lproj)->TranslatedStrings.txt

The list that's being shown is in fact much longer then you think. Rightclick on the TranslatedStrings.txt and really open it in TextEdit, there you can find the string. After deleting the mentioned space the system tells you to make a kopie: it won't allow you to change the original. Get rid of that original (maybe save it somewhere) and leave the kopie in place. Start Lightroom again and everything works! Quite a relief I must say. But rather complicated for those not familiar in doing someting 'under the hood' I expect...
Tina

Votes

Translate

Translate

Report

Report
New Here ,
May 21, 2015 May 21, 2015

Copy link to clipboard

Copied

Problem again: now the whole program is in English instead of the original Dutch... What to do next?
Tina

Votes

Translate

Translate

Report

Report
LEGEND ,
May 21, 2015 May 21, 2015

Copy link to clipboard

Copied

Double-check that Preferences > General > Language is set to Dutch.

Votes

Translate

Translate

Report

Report
New Here ,
May 21, 2015 May 21, 2015

Copy link to clipboard

Copied

I did, but it doesn't work! I can change it into any other language that I'm capable of (quite a few, to be honest), but not into Dutch. Any more advice?
Tina

Votes

Translate

Translate

Report

Report
LEGEND ,
May 21, 2015 May 21, 2015

Copy link to clipboard

Copied

If you saved the original nl.lproj/TranslatedStrings.txt, put it back in place and restart LR. If that doesn't work, perhaps you'll need to re-download and reinstall.

Votes

Translate

Translate

Report

Report
New Here ,
May 21, 2015 May 21, 2015

Copy link to clipboard

Copied

Yeah, i've done that and now I have my Dutch back, but lost my negative numbers... There's another string, quite similar that says "$$$/AgUI/TextField/MinusReplacement=^U+2212 " I removed (and placed back) the space also. But both didn't help. Luckily I can use the English version, waiting for an update...
When it's really bothering me I consider re-downloading it... I can't belief I'm the only one with this problem?
Tina

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jun 15, 2015 Jun 15, 2015

Copy link to clipboard

Copied

LATEST
This was fixed in the CC 2015.1 / 6.1 Update.
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report