P: Some keywords not in alphabetical order

8 Votes
Explorer ,
Nov 02, 2017 Nov 02, 2017

Copy link to clipboard

Copied

Since I have updated to LR Classic, I have an issue with my keyword list. I have hierarchical keywords. Some on the top level are numbered and some of the top level have no child keywords. Since the update the keywords on the top level and the second level hierarchy are no longer in alphabetical order. Some keywords seem to be ordered correctly, but several others are not. The keywords which are not ordered alphabetically seem to get ordered by a change/creation date or so.

I do not use LR CC and have not done any keyword changes on my mobile devices.

Has anybody an idea, what I could do about it? Is there I setting, I have missed?

Bug Acknowledged
TOPICS
Windows

Views

34

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Employee , Dec 13, 2017 Dec 13, 2017
This is an open issue that engineering is investigating.

Votes

Translate

Translate
Community Beginner , Nov 07, 2017 Nov 07, 2017
@tpnotes: Try adding following config to config.lua: LibrarySort.useOldSort = true To locate the config.lua, Open Lightroom > Preferences > Presets  Click on "Show Lightroom Presets Folder..." It should take you to folder ending with ... /Application Support/Adobe/Lightroom/ If config.lua is already present in Lightroom folder, just add,  LibrarySort.useOldSort = true in the config.lua file. If the file is not present create a file named config.lua and add the same configuration there. Let me...

Votes

Translate

Translate
33 Comments
Adobe Community Professional ,
Nov 02, 2017 Nov 02, 2017

Copy link to clipboard

Copied

Do you use a Macintosh running High Sierra? Update to Lr Classic 7.01. The update fixes a problem with the sort order of several lists.
-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Explorer ,
Nov 02, 2017 Nov 02, 2017

Copy link to clipboard

Copied

I use macOS High Sierra (latest release) and have updated to LR 7.0.1 when it was released. This update has not fixed my issue with the keywords.

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 02, 2017 Nov 02, 2017

Copy link to clipboard

Copied

Please do Help > System Info and report the exact version number. (The LR update mechanism is unreliable and often fools people into thinking they're on "the latest".)

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Nov 02, 2017 Nov 02, 2017

Copy link to clipboard

Copied

Try reset the Lightroom preferences to see if it is helpful.

Votes

Translate

Translate

Report

Report
Explorer ,
Nov 02, 2017 Nov 02, 2017

Copy link to clipboard

Copied

@john: Yes, I can confirm that my version number of Lightroom is 7.0.1. For macOS it is 10.13.1.

@simon: Can you please give me some advice how to do the reset and what "collateral damage" might happen?

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 02, 2017 Nov 02, 2017

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Explorer ,
Nov 02, 2017 Nov 02, 2017

Copy link to clipboard

Copied

Thanks for the link. I will test resetting the preferences over the weekend and report back.

Votes

Translate

Translate

Report

Report
Explorer ,
Nov 04, 2017 Nov 04, 2017

Copy link to clipboard

Copied

I reset the preferences, but it had no effect. The some keywords are still not sorted alphabetically. 

But I had a deeper look into which keywords are effected: just 3 keywords. Two keywords starting with an "Ü". If I change that to "Ue" the keywords get sorted properly. Switching back to "Ü" make them appear again on the top of the list. That just happens for "Ü" but not for "Ä". I have made a new keyword starting with "Ö" and it is sorted between "abstrakt" and "Ähre" - somewhere in the middle of keywords starting with "a". Looks like an encoding issue or something like that, but it is unusual that it only effects all characters (umlaut).

I tested the behavior with the umlaut (Ä, Ö, Ü) on a second Mac and its the same on that machine too. I use the German version of Lightroom with a German keyboard layout.

The 3rd keyword is a top level keyword and starts with "06 ...". It is listed after keyword "08 ..." and I have no idea why. I have 8 such keywords (01 ..., 02 ..., 03 ..., 04 ..., 05 ..., 06 ..., 07 ..., 08 ...) and only 06 behaves different. Even changing the keyword from "06 ..." to "01..." does not effect the sorting. If I change keyword "08 ..." to "09 ..." it is still listed before "06 ...". If I remove the number 06, then the sorting is correct. 

Votes

Translate

Translate

Report

Report
Explorer ,
Nov 07, 2017 Nov 07, 2017

Copy link to clipboard

Copied

I reset the preferences, but it had no effect. The some keywords are still not sorted alphabetically. 

But I had a deeper look into which keywords are effected: just 3 keywords. Two keywords starting with an "Ü". If I change that to "Ue" the keywords get sorted properly. Switching back to "Ü" make them appear again on the top of the list. That just happens for "Ü" but not for "Ä". I have made a new keyword starting with "Ö" and it is sorted between "abstrakt" and "Ähre" - somewhere in the middle of keywords starting with "a". Looks like an encoding issue or something like that, but it is unusual that it only effects all characters (umlaut).

I tested the behavior with the umlaut (Ä, Ö, Ü) on a second Mac and its the same on that machine too. I use the German version of Lightroom with a German keyboard layout.

The 3rd keyword is a top level keyword and starts with "06 ...". It is listed after keyword "08 ..." and I have no idea why. I have 8 such keywords (01 ..., 02 ..., 03 ..., 04 ..., 05 ..., 06 ..., 07 ..., 08 ...) and only 06 behaves different. Even changing the keyword from "06 ..." to "01..." does not effect the sorting. If I change keyword "08 ..." to "09 ..." it is still listed before "06 ...". If I remove the number 06, then the sorting is correct. 

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 07, 2017 Nov 07, 2017

Copy link to clipboard

Copied

This person reported their Greek keywords were missorted on LR 7.0.1 / Windows 10 but not on the "previous" version of LR (previous was not defined):
https://forums.adobe.com/message/9927630#9927630

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 07, 2017 Nov 07, 2017

Copy link to clipboard

Copied

I confirm that those umlaut characters seriously confuse LR's keyword sorting.   Here's an example from my LR 7.0.1  on Mac 10.12.6 and then Windows 10:




Without those umlaut characters present, LR appears to properly sort keywords with numbers:

Votes

Translate

Translate

Report

Report
Community Beginner ,
Nov 07, 2017 Nov 07, 2017

Copy link to clipboard

Copied

@tpnotes: Try adding following config to config.lua:
LibrarySort.useOldSort = true

To locate the config.lua, Open Lightroom > Preferences > Presets 
Click on "Show Lightroom Presets Folder..."
It should take you to folder ending with ... /Application Support/Adobe/Lightroom/

If config.lua is already present in Lightroom folder, just add, 
LibrarySort.useOldSort = true
in the config.lua file. If the file is not present create a file named config.lua and add the same configuration there.

Let me know if it works.

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 07, 2017 Nov 07, 2017

Copy link to clipboard

Copied

Excellent, that fixes my test case:

Votes

Translate

Translate

Report

Report
Explorer ,
Nov 08, 2017 Nov 08, 2017

Copy link to clipboard

Copied

I store my presets with the catalog and the fix you suggested did not work, when I put the config.lua file (I did not have one before) in that folder. But when I put it at ... /Application Support/Adobe/Lightroom/ it worked.

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 11, 2017 Nov 11, 2017

Copy link to clipboard

Copied

Adding that setting in config.lua solved my problem (Greek keywords). Thanks a lot.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Nov 15, 2017 Nov 15, 2017

Copy link to clipboard

Copied

I have the same problem
- I tried creating a config.lua file (though I'm not sure if I did it right... on a Mac i created a Text file and just renamed it to config.lua - would that work?)
- I only have Folders in the Lightroom folder - you want me to just put the file in there by itself or would it also have to go into a folder?

It still looks the same:

Votes

Translate

Translate

Report

Report
Explorer ,
Nov 15, 2017 Nov 15, 2017

Copy link to clipboard

Copied

I just created a normal .txt file, named it config.lua and saved it here: Library/Application Support/Adobe/Lightroom/ (not in any of the subfolders). That worked for me.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Nov 15, 2017 Nov 15, 2017

Copy link to clipboard

Copied

By default there would be no files inside the ../Lightroom/ folder. You should put the config.lua with the config added to it and put it there.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Nov 16, 2017 Nov 16, 2017

Copy link to clipboard

Copied

OK, tried that - didn't work...

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 16, 2017 Nov 16, 2017

Copy link to clipboard

Copied

Verify that you correctly created Config.lua.  Do Help > System Info and look for this:
Config.lua flags: 
LibrarySort.useOldSort = true
If you don't see that, then you haven't got a correct Config.lua.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Nov 16, 2017 Nov 16, 2017

Copy link to clipboard

Copied

Hmm... seems it's not correct, since it shows:

Config.lua-Flags: None

Votes

Translate

Translate

Report

Report
Community Beginner ,
Nov 16, 2017 Nov 16, 2017

Copy link to clipboard

Copied

Though I cannot figure out what's wrong:



Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 16, 2017 Nov 16, 2017

Copy link to clipboard

Copied

It looks like you used TextEdit and saved it in the default format, which is "rich text".  You need to save it as plain text.  Best to start from scratch.   In TextEdit:

1. File > New

2. Format > Make Plain Text

3. Enter the line "LibrarySort.useOldSort = true" and be sure to hit Return at the end, so the input cursor (the blinking bar) is under "L".

4. File > Save.  Save As: Config.lua. Plain Text Encoding: Unicode (UTF-8).  Save.  Use .lua.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Nov 17, 2017 Nov 17, 2017

Copy link to clipboard

Copied

@John R. Ellis: perfect, thanks - it works! (That's probably why it says "Champion" next to your name in the first place 😉 )

Votes

Translate

Translate

Report

Report
Engaged ,
Nov 28, 2017 Nov 28, 2017

Copy link to clipboard

Copied



Sort keywords in alphabetic order french!

E....
e.....
é......




In this example, it's wrong!
Yves Crausaz, Suisse, retraité actif dans le monde de la photo et des arts graphiques.

Votes

Translate

Translate

Report

Report