P: Tone curve still broken in

69 Votes
Enthusiast ,
Dec 08, 2016 Dec 08, 2016

Copy link to clipboard

Copied

The bug that I reported here has not been squashed in the latest Lightroom.

The problem is hysteresis in the response of points on the tone curve control when following mouse movements.

If you drag a point (say, the white point) in the Tone Curve and move it back and forth, after a few drags you will not be able to put the point back in the upper right corner of the response panel.

The underlying cause is that (a) the point does not move directly with the cursor (LR hides the cursor so you can't see this, but when you let go of the mouse button you will see that the cursor does not align with the point, (b) as you drag, the relationship between the cursor position and the point changes, when the point hits the right edge of the box and the cursor continues to the right, then when you move the cursor back to the left it does not "pick up" the point at the same location that it "left" the point, and (c) the (invisible) cursor is limited by Mac OS to stay on the screen.

The work-around (which is not perfect), is to make your Lightroom window smaller so that there is more space beyond the right edge of the window, so the hysteresis effect doesn't show up as quickly. If you have 2 screens, you can move the Lightroom window to the left screen, which effectively solves this problem.

I assume that this problem occurs for all four edges of the Tone Panel, but because the Tone Panel is on the right hand side of the Lightroom window, the effect is seen mostly when trying to move a point on the tone curve to the right hand side of the panel.

If this is not clear, let me know, and I'll see if I can post a video.

[Edit -- I just confirmed this bug for the top edge of the Tone Curve as well.]

Bug Fixed
TOPICS
macOS, Windows

Views

83

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Mar 07, 2017 Mar 07, 2017
The bug associated with this post and thread is still open at Adobe. The bug to which the Blog Post refers and to which Alan subsequently refers is different. 

Votes

Translate

Translate
95 Comments
Community Beginner ,
Dec 08, 2016 Dec 08, 2016

Copy link to clipboard

Copied

so the problem is with the Tone curve was not resolved. I'll wait for the next update

Votes

Translate

Translate

Report

Report
Enthusiast ,
Dec 08, 2016 Dec 08, 2016

Copy link to clipboard

Copied

alyona, the problem that I reported was not solved. There were other problems (discussed in that thread) that were, I believe, solved.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Dec 08, 2016 Dec 08, 2016

Copy link to clipboard

Copied

Alan, this appears to be different behavior than was reported earlier. Can you confirm that to me?
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community Beginner ,
Dec 08, 2016 Dec 08, 2016

Copy link to clipboard

Copied

I encountered only one problem in the tone curves. I wait when will correct this bug

Votes

Translate

Translate

Report

Report
Enthusiast ,
Dec 08, 2016 Dec 08, 2016

Copy link to clipboard

Copied

It is exactly what I reported earlier, but I think it got lost in the noise of a long discussion. (I first reported this on your other board, but when I moved the report to this board, I put it into what I thought was a related discussion.) In any event, I think my report was too close to your release date for it to have been looked at. And I have no idea how long this has been in Lightroom, but it might have been there for a while, and I only recently got annoyed enough to figure out what the underlying symptoms were.

Do let me know if you can't understand or can't reproduce my report.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Dec 08, 2016 Dec 08, 2016

Copy link to clipboard

Copied

Wacom or touch pad?
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Enthusiast ,
Dec 08, 2016 Dec 08, 2016

Copy link to clipboard

Copied

Magic mouse, iMac 5K + Cinema display, Sierra

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Dec 08, 2016 Dec 08, 2016

Copy link to clipboard

Copied

That I can duplicate. I will get a new bug filed on it!
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Explorer ,
Dec 08, 2016 Dec 08, 2016

Copy link to clipboard

Copied

To be fair, when a bug is reported it does take some time to go through the code to correct the problem.  Then it has to be tested thoroughly before the update is released.  I'd be betting that the bug you reported never got into this release because of the time frame.

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 08, 2016 Dec 08, 2016

Copy link to clipboard

Copied

I hope what Chris said is correct. The tone curve sliding glitch is really annoying, and Lightroom developers do need to address this issue directly ASAP.
For those who want to have accurate curve adjustment now, you can sync your photos to lightroom mobile, and edit them with your phones or tablets.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Dec 08, 2016 Dec 08, 2016

Copy link to clipboard

Copied

This problem appeared with the update on Sierra.

I have also a magic mouse and Wacom bamboo

Votes

Translate

Translate

Report

Report
Enthusiast ,
Dec 09, 2016 Dec 09, 2016

Copy link to clipboard

Copied

That is exactly what I said, Chris.

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 09, 2016 Dec 09, 2016

Copy link to clipboard

Copied

Experiencing this same issue with native trackpad on a 13" MBP running Sierra

Votes

Translate

Translate

Report

Report
Contributor ,
Dec 09, 2016 Dec 09, 2016

Copy link to clipboard

Copied

I've always wondered how it's possible that the curve panel in LR has been broken for so long. It's extremely uncomfortable and sometimes impossible to use this panel... and the weird part is that it works as expected in Camera Raw. Go figure...
I truly hope someday it's usable.

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 12, 2016 Dec 12, 2016

Copy link to clipboard

Copied

Melissa, 
in response of tones curve problem mentioned in Adobe Forum https://forums.adobe.com/message/9198097?et=notification.mention#9198097

here my  lightroom psecs :

Version de Lightroom : CC 2015.8 [ 1099473 ]Licence: Creative Cloud
Système d'exploitation : Mac OS 10
Version : 10.12 [1]
Architecture de l'application : x64
Nombre de processeurs logiques: 8
Vitesse du processeur : 3,4 Ghz
Mémoire intégrée : 24 576,0 Mo
Mémoire réelle disponible pour Lightroom : 24 576,0 Mo
Mémoire réelle utilisée par Lightroom : 3 298,4 Mo (13,4%)
Mémoire virtuelle utilisée par Lightroom : 5 604,4 Mo
Taille de la mémoire cache : 4 855,9 Mo
Nombre maximal de liens utilisé par Camera Raw  : 8
Optimisation SIMD de Camera Raw : SSE2,AVX
Affichages : 1) 2560x1440, 2) 1080x1920

Informations relatives au processeur graphique : 
NVIDIA GeForce GTX 680MX OpenGL Engine

Check OpenGL support: Passed
Vendor: NVIDIA Corporation
Version: 4.1 NVIDIA-10.12.68 355.10.05.05b16
Renderer: NVIDIA GeForce GTX 680MX OpenGL Engine
LanguageVersion: 4.10


Dossier de l'application : /Applications/Adobe Lightroom
Chemin d'accès à la bibliothèque : /Volumes/Rugged_LR/Lightroom/shooting/shooting-2-2.lrcat
Dossier des paramètres : /Users/xavierfoulon/Library/Application Support/Adobe/Lightroom

Modules installés : 
1) 500px
2) Adobe Stock
3) Color Label
4) Facebook
5) Flickr
6) JPEGmini
7) Koken
8) LrControl
9) Module externe d'importateur Aperture/iPhoto
10) Module externe de prise de vue en mode connecté Canon
11) Module externe de prise de vue en mode connecté Leica
12) Module externe de prise de vue en mode connecté Nikon

Marqueurs Config.lua: None

AudioDeviceIOBlockSize: 512
AudioDeviceName: Sortie intégrée
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 44100
Build: LR5x4
CoreImage: true
GL_ACCUM_ALPHA_BITS: 0
GL_ACCUM_BLUE_BITS: 0
GL_ACCUM_GREEN_BITS: 0
GL_ACCUM_RED_BITS: 0
GL_ALPHA_BITS: 8
GL_BLUE_BITS: 8
GL_DEPTH_BITS: 24
GL_GREEN_BITS: 8
GL_MAX_3D_TEXTURE_SIZE: 2048
GL_MAX_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_UNITS: 8
GL_MAX_VIEWPORT_DIMS: 16384,16384
GL_RED_BITS: 8
GL_RENDERER: NVIDIA GeForce GTX 680MX OpenGL Engine
GL_SHADING_LANGUAGE_VERSION: 1.20
GL_STENCIL_BITS: 8
GL_VENDOR: NVIDIA Corporation
GL_VERSION: 2.1 NVIDIA-10.12.68 355.10.05.05b16
OGLEnabled: true
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_separate_stencil GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once 

Votes

Translate

Translate

Report

Report
Explorer ,
Dec 13, 2016 Dec 13, 2016

Copy link to clipboard

Copied

Actually the  hysteresis  problem exist not only for Tonal Curve.
Just try using  "Adjust ... by dragging in the photo" from HSL/Color/B&W close to TOP or BOTTOM edge of the screen and adjust accordingly. It will adjust as long as you will not hit the edge!
I think it is a general engine problem of calculating change of cursor position by it's relation to the screen area instead of using raw mouse/trackpad data.

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 13, 2016 Dec 13, 2016

Copy link to clipboard

Copied

Coming over from here: https://forums.adobe.com/message/9198097#9198097
Was told to drop my system info. The curve is now at least working but is still very choppy. Thanks to the Adobe Dev team for the persistence on this issue.

Lightroom version: CC 2015.8 [ 1099473 ]License: Creative Cloud
Operating system: Mac OS 10
Version: 10.12 [1]
Application architecture: x64
Logical processor count: 8
Processor speed: 2.4 GHz
Built-in memory: 8,192.0 MB
Real memory available to Lightroom: 8,192.0 MB
Real memory used by Lightroom: 1,177.7 MB (14.3%)
Virtual memory used by Lightroom: 2,965.8 MB
Memory cache size: 662.0 MB
Maximum thread count used by Camera Raw: 8
Camera Raw SIMD optimization: SSE2,AVX
Displays: 1) 3840x2400

Graphics Processor Info: 
NVIDIA GeForce GT 650M OpenGL Engine

Check OpenGL support: Passed
Vendor: NVIDIA Corporation
Version: 4.1 NVIDIA-10.12.68 355.10.05.05b16
Renderer: NVIDIA GeForce GT 650M OpenGL Engine
LanguageVersion: 4.10


Application folder: /Applications/Adobe Lightroom
Library Path: /Users/cordelj/Pictures/Lightroom/JostensPhotography/JostensPhotography-2.lrcat
Settings Folder: /Users/cordelj/Library/Application Support/Adobe/Lightroom

Installed Plugins: 
1) AdobeStock
2) Aperture/iPhoto Importer Plug-in
3) Canon Tether Plugin
4) Facebook
5) Flickr
6) Helicon Focus Export
7) Leica Tether Plugin
8) Nikon Tether Plugin

Config.lua flags: None

AudioDeviceIOBlockSize: 512
AudioDeviceName: Built-in Output
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 44100
Build: LR5x4
CoreImage: true
GL_ACCUM_ALPHA_BITS: 0
GL_ACCUM_BLUE_BITS: 0
GL_ACCUM_GREEN_BITS: 0
GL_ACCUM_RED_BITS: 0
GL_ALPHA_BITS: 8
GL_BLUE_BITS: 8
GL_DEPTH_BITS: 24
GL_GREEN_BITS: 8
GL_MAX_3D_TEXTURE_SIZE: 2048
GL_MAX_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_UNITS: 8
GL_MAX_VIEWPORT_DIMS: 16384,16384
GL_RED_BITS: 8
GL_RENDERER: NVIDIA GeForce GT 650M OpenGL Engine
GL_SHADING_LANGUAGE_VERSION: 1.20
GL_STENCIL_BITS: 8
GL_VENDOR: NVIDIA Corporation
GL_VERSION: 2.1 NVIDIA-10.12.68 355.10.05.05b16
OGLEnabled: true
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_separate_stencil GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fog_distance GL_NV_fragment_program_option GL_NV_fragment_program2 GL_NV_light_max_exponent GL_NV_multisample_filter_hint GL_NV_point_sprite GL_NV_texgen_reflection GL_NV_texture_barrier GL_NV_vertex_program2_option GL_NV_vertex_program3 GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod 

Votes

Translate

Translate

Report

Report
Enthusiast ,
Dec 13, 2016 Dec 13, 2016

Copy link to clipboard

Copied

Since Adobe has two forums, and this problem is being tracked in both of them, I think I need to duplicate my responses so that I am sure that someone from Adobe will read them:
1) I have not tried to replicate all of the various bug reports regarding the tone curve, but looking at them, I think that there may be two issues here, and they may not be closely related. I really encourage Adobe to look at all the reports and try to understand them before formulating a solution and regression tests.

2) The comment above makes a very cogent argument that this bug is a symptom of a larger issue with Lightroom's user interface engine. Again, I encourage Adobe to understand this comment before fixing "the problem."

My own feeling is that the Lightroom team should just steal the user interface that Photoshop uses for manipulating curves (&/or the interface used in Camera Raw) and adopt it for Lightroom, rather than trying to "fix" what you currently have.

Votes

Translate

Translate

Report

Report
New Here ,
Dec 19, 2016 Dec 19, 2016

Copy link to clipboard

Copied

Hi there,
Just purchased a new iMac and am having the same issue in the tone curve. Very frustrating as I use it heavily and it is unusable. I'm not quite sure where to find the specs you need.

Votes

Translate

Translate

Report

Report
New Here ,
Dec 29, 2016 Dec 29, 2016

Copy link to clipboard

Copied

Can this issue be fixed already?  This is ridiculous. 

Votes

Translate

Translate

Report

Report
Explorer ,
Jan 03, 2017 Jan 03, 2017

Copy link to clipboard

Copied

Downgraded to El Capitan from macOS Sierra today, because of this notorious Tone Curve bug and everything is fine. The problem with hitting the edge of the screen when "Adjust ... by dragging in the photo" exists but is not that bad.
For me it seems like for now LR6 is NOT compatible with macOS Sierra and is still having big issue with shadows reproduction in El Capitan as well (https://feedback.photoshop.com/photoshop_family/topics/tone-curve-still-broken-in-lr-cc2015-8)

Votes

Translate

Translate

Report

Report
New Here ,
Jan 03, 2017 Jan 03, 2017

Copy link to clipboard

Copied

This started for me with macOS Sierra, so that makes sense. Still, it's been out for months now, what happened to paying monthly means always being up to date?

Votes

Translate

Translate

Report

Report
New Here ,
Jan 06, 2017 Jan 06, 2017

Copy link to clipboard

Copied



Toning curve is insensitive to MacBook Pro touch pad. Curves don't move until I reset the click on touch pad.

Votes

Translate

Translate

Report

Report
New Here ,
Jan 06, 2017 Jan 06, 2017

Copy link to clipboard

Copied



I can't click and drag a curve point without it sticking as I drag. It's like the point hits an invisible wall especially as I drag to the right. Dragging the line as a whole from either corner of the panel is totally impossible. The point sticks and then all of a sudden it will jump half way up the panel.

I found this video (link below) on YouTube of others who are having the same issue.
The video description describes the problem well.
https://www.youtube.com/watch?v=GFE3e4kHzFo

I used to rely heavily on curves to make my major adjustments but now the panel is basically unusable. Very frustrating...
Please let me know if there's anything I can do to fix it.
Thanks!

Specs:
2013 Mac Pro
OS Sierra 10.12.1
Adobe Lightroom 2015.7
Same results whether using a mouse or trackpad.

Votes

Translate

Translate

Report

Report
New Here ,
Jan 06, 2017 Jan 06, 2017

Copy link to clipboard

Copied

I agree with everyone here. How much longer are we going to have to wait to get this fixed? I rely heavily on editing and I haven't been able to do so because every time I try to use that tone curve I just want to throw my computer out the window. 

Votes

Translate

Translate

Report

Report