P: Updating to version 9 but my catalog from version 8.4 is incompatible

7 Votes
LEGEND ,
Nov 08, 2019 Nov 08, 2019

Copy link to clipboard

Copied

Lightroom Classic - Updating to Lightroom Version 9 but my catalog from version 8.4 is incompatible and for some reason, it can't be updated. I can revert back to 8.4 temporarily so as not to lose my collection of work but it's not going to be a solution long term. Can you help give me some steps that might offer a solution to this issue I am encountering?

Any advice, solution or steps that I might be able to try would be most appreciated.

Thank you.

Joe

Bug Fixed
TOPICS
macOS, Windows

Views

45

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Dec 10, 2019 Dec 10, 2019
This should be resolved by the 9.1 update released earlier today. Please give it a try and let us know if you still see the issue after updating.  Thank you for your patience!

Votes

Translate

Translate
54 Comments
Adobe Community Professional ,
Nov 08, 2019 Nov 08, 2019

Copy link to clipboard

Copied

Do you get an error message and if so, what does it say?
-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 08, 2019 Nov 08, 2019

Copy link to clipboard

Copied

So, after updating to Lightroom Classic v9 and launching the programme, I get the message telling me that my catalog needs to be upgraded and a new catalog file will be created in a stipulated destination. I’m asked to either ‘Upgrade’ or ‘Choose a Different Catalog’.

If I choose Upgrade, the catalog will go through about 5 minutes of upgrading before I get the message

‘Lightroom encountered problems when trying to update the format of the catalog file and cannot use this catalog in this version of Lightroom’, to which I am given the options, ‘See Adoe TechNote’, ‘Show in Finder’, ‘Quit’ and Choose a Different Catalog’.

Now, I can start a new Catalog and Lightroom v9 seems to work fine, but I have none of the pictures from the last two years available, nor any of my presets for that matter but I haven’t considered that as an issue of concern yet.

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 08, 2019 Nov 08, 2019

Copy link to clipboard

Copied

So, after updating to Lightroom Classic v9 and launching the programme, I get the message telling me that my catalog needs to be upgraded and a new catalog file will be created in a stipulated destination. I’m asked to either ‘Upgrade’ or ‘Choose a Different Catalog’.

If I choose Upgrade, the catalog will go through about 5 minutes of upgrading before I get the message

‘Lightroom encountered problems when trying to update the format of the catalog file and cannot use this catalog in this version of Lightroom’, to which I am given the options, ‘See Adoe TechNote’, ‘Show in Finder’‘Quit’ and Choose a Different Catalog’.

Now, I can start a new Catalog and Lightroom v9 seems to work fine, but I have none of the pictures from the last two years available, nor any of my presets for that matter but I haven’t considered that as an issue of concern yet.

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 08, 2019 Nov 08, 2019

Copy link to clipboard

Copied

I actually got it working, thank you. It wouldn't work from the start trying to upgrade my Catalog, but after creating a brand new one, I relaunched my old catalog from within the updated program and for whatever reason, that worked and has remained working after several restarts.

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Nov 09, 2019 Nov 09, 2019

Copy link to clipboard

Copied

I love problems that fix themselves! Much easier to deal with.
-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 09, 2019 Nov 09, 2019

Copy link to clipboard

Copied

I have the same problem with my new catalog. None of the recently added pictures are available and I get a message that I cannot access files.  How do I get out of Catalina upgrade or do what Joe Kelly did.  I do not know what he means by 'create a brand new catalog. Where and how would I do that?

Votes

Translate

Translate

Report

Report
New Here ,
Nov 10, 2019 Nov 10, 2019

Copy link to clipboard

Copied

Following the upgrade to Lightroom Classic v9 (Windows 10) several catalogs upgraded successfully. But the next had the same error message as above
‘Lightroom encountered problems when trying to update the format of the catalog file and cannot use this catalog in this version of Lightroom
I tried to upgrade the most recent backup but encountered the same error message. I am stuck - is there a solution?

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Nov 10, 2019 Nov 10, 2019

Copy link to clipboard

Copied

@Phyllis: When you click 'Choose a different catalog' in the error dialog, you can click to create a new one in the next dialog.

@Christopher: Apparently Lightroom needs to read info from the images (depth info), so one thing to check when you get this error is if the originals are online. If they are not, this may cause the problem.
-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
New Here ,
Nov 10, 2019 Nov 10, 2019

Copy link to clipboard

Copied

Checked and all the files are online and in the original locations.

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 10, 2019 Nov 10, 2019

Copy link to clipboard

Copied

Having the same problem here as Christopher. Trying to role back Lightroom Classic to Version 8...

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 10, 2019 Nov 10, 2019

Copy link to clipboard

Copied

Im having the same issue updated to Catalina 10.15 then upon opening Lightroom got message about catalog being incompatible and have to choose a different catalog.  All my files I work with are on an external drive, I noticed that the drive is now handling file paths different than before.  "volumes" is missing before the drive location.  It is also showing the drive as a duplicate (same drive listed twice).   Getting message file not found in develop module.   How can I relaunch my old catalog? would that fix this?

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 10, 2019 Nov 10, 2019

Copy link to clipboard

Copied

Im having the same issue updated to Catalina 10.15 then upon opening Lightroom got message about catalog being incompatible and have to choose a different catalog.  All my files I work with are on an external drive, I noticed that the drive is now handling file paths different than before.  "volumes" is missing before the drive location.  It is also showing the drive as a duplicate (same drive listed twice).   Getting message file not found in develop module.   How can I relaunch my old catalog? would that fix this?

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 11, 2019 Nov 11, 2019

Copy link to clipboard

Copied

I’m having the same issue. Abode is of no help.

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 11, 2019 Nov 11, 2019

Copy link to clipboard

Copied

Try a cold reboot, worked for a couple  in the Adobe Support Community. No reason.

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Nov 12, 2019 Nov 12, 2019

Copy link to clipboard

Copied

Cyndi, at what stage are you seeing the missing volume? After you've opened the right catalog or the "other" catalog you need to open in that incompatible dialog?
-------------------------------------
The Lightroom Queen - Author of the Lightroom Missing FAQ & Edit Like a Pro books.

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Nov 12, 2019 Nov 12, 2019

Copy link to clipboard

Copied

Cyndi, at what stage are you seeing the missing volume? After you've opened the right catalog or the "other" catalog you need to open in that incompatible dialog?
-------------------------------------
The Lightroom Queen - Author of the Lightroom Missing FAQ & Edit Like a Pro books.

Votes

Translate

Translate

Report

Report
Explorer ,
Nov 12, 2019 Nov 12, 2019

Copy link to clipboard

Copied

We have the same problem. Here's the error message. We are using Mac 10.14.5. Classic 9 refuses to open the catalog but reverting to 8.4.1 works. Help. Thanks in advance for your time and effort.
T
Steve Gandy
Photographer - Instructor
stevegandy.com

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Nov 13, 2019 Nov 13, 2019

Copy link to clipboard

Copied

It's now a confirmed issue, should be fixed in the next release.
-------------------------------------
The Lightroom Queen - Author of the Lightroom Missing FAQ & Edit Like a Pro books.

Votes

Translate

Translate

Report

Report
Explorer ,
Nov 13, 2019 Nov 13, 2019

Copy link to clipboard

Copied

Didn't work for us.
Steve Gandy
Photographer - Instructor
stevegandy.com

Votes

Translate

Translate

Report

Report
Explorer ,
Nov 13, 2019 Nov 13, 2019

Copy link to clipboard

Copied

Excellent! We tried everything.

For anyone else out there with the issue. There is a file created each time with a -sync -2 at the end of the file name. We were throwing those out when we retested. And sometimes a lock file would be created. But we threw those out each time as well. 

The error message takes you to a page about deleting the lock files but that is _not_ the issue.

We also optimized the catalog each time we had it open in v8.4.1 so I believe the catalog is not corrupted.
Steve Gandy
Photographer - Instructor
stevegandy.com

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 02, 2019 Dec 02, 2019

Copy link to clipboard

Copied

I too have this issue - has it been fixed yet - I just tried to use lightroom for the first time in a few months and cannot access  my pics with has decades worth of family photos!

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Dec 03, 2019 Dec 03, 2019

Copy link to clipboard

Copied

You can roll back to 8.4.1 for the minute, or if you want to send me the catalog, I can get it upgraded for you.
-------------------------------------
The Lightroom Queen - Author of the Lightroom Missing FAQ & Edit Like a Pro books.

Votes

Translate

Translate

Report

Report
New Here ,
Dec 03, 2019 Dec 03, 2019

Copy link to clipboard

Copied

I too have been moving and have not accessed but have the upgrade and it is asking me to upgrade. I haven't done it yet in fear that something may happen. I have decades worth of images and cannot lose them. How do you roll back to 8.4.1?

Votes

Translate

Translate

Report

Report
New Here ,
Dec 03, 2019 Dec 03, 2019

Copy link to clipboard

Copied

I meant it is asking me to upgrade my catalog and is saying it will be be compatible with previous versions. Afraid to do this.

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 03, 2019 Dec 03, 2019

Copy link to clipboard

Copied

So I will tell you sometimes it is recognizing my folders in the upgrade when I launch Lightroom and sometimes it is not. I swear it has a mind of its own. For me Mac has changed the way it is handling external drives so the file path is different and lightroom thinks it has moved/missing...you can Locate the files and move them over but that isn't a long term solution when dealing with tons of files.  So I'm just waiting it out.   When this issue first started I was working around off my desktop with new images.  I also just filled up my old drive and bought a new one, I have not had any issues with new work only old.  Also as far as being lost you should have backups of catalogs stored in a folder.

Votes

Translate

Translate

Report

Report