P: Web export module still replaces legal characters without asking

4 Votes
Community Beginner ,
Jun 21, 2011 Jun 21, 2011

Copy link to clipboard

Copied

Filenames such as (for instance) photographer-place--year_month_day-filename.cr2 are exported by Lightroom 3.4.1's Develop module correctly, without change, into jpg versions. However, Lightroom's web module forces a conversion eliminating the dashes and replacing them by underscores, even converting two dashes into one underscore in the process. TTG Highslide Pro (which I use with LR) states on its website that this is built into the Lightroom web module, and recommends entering one's wishes in the "File Handling" tab within Lightroom Preferences.

However, my own LR preferences include the standard File Name Generation option "Replace illegal file name characters with: Dashes (-)" so this would indicate that a dash is not regarded by Lightroom as illegal and therefore should be left alone, as is in fact the case on a normal export from a raw cr2 to jpg: no change in Lightroom and therefore no problem. But export via LR, via TTG oor via LR's own web templates, causes an unwanted conversion from dashes to underscores. The preferences entered under LR's Edit - Preferences - File Handling - File Name Generation are apparently ignored by the web module.

Using dashes (or "hyphens") gives me no problems whatsoever in any application or use in web galleries and I am happy with the names generated automatically by specific third-party software which is more flexible than LR with file renaming. Hopefully it will not be too difficult for LR's programmers to allow exporting files through the web module without being renamed in the process, if one so wishes.

Bug Fixed
TOPICS
macOS, Windows

Views

10

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Mar 24, 2017 Mar 24, 2017
This is solved for Lightroom 4 and later.

Votes

Translate

Translate
3 Comments
Adobe Employee ,
Jul 14, 2011 Jul 14, 2011

Copy link to clipboard

Copied

Thanks Martin, I've entered this issue in our bug database.

-Ben

Votes

Translate

Translate

Report

Report
LEGEND ,
Aug 14, 2011 Aug 14, 2011

Copy link to clipboard

Copied

Lightroom's WEB module converts Dashes or Hyphens in filenames to Underscores. This is a massive pain, as it is unnecessary. Dashes are perfectly legal in file names, and many many people use them. When using the TTG Client response template, this bug causes an enormous about of manual work for no reason, really messing up workflow efficiency. This has been a problem in earlier versions of LR. Is ADOBE ever going to fix this issue. I believe that it has been reported and complained about on the net for a while now.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Mar 24, 2017 Mar 24, 2017

Copy link to clipboard

Copied

LATEST
This is solved for Lightroom 4 and later.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report