Canon 80d will not import raw into lightroom

New Here ,
Apr 02, 2016 Apr 02, 2016

Copy link to clipboard

Copied

I just bought the new Canon 80d after having the Canon 5dm2 and 70d work fine on import. The new 80d raw images will not import into lightroom. I get a message saying The files are not recognized by the raw format support in Lightroom. I have done the latest update to Lightroom CC and still will not import. I normally change to DNG on import but it will not import without that change either. Any suggestions would be greatly appreciated???

Views

42.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Apr 02, 2016 Apr 02, 2016

Open Lightroom, click-  Help > About Adobe Photoshop Lightroom.

You should see   "2015.5 Release" near the top of the 'About' box.  What do you see?

If you do not see "2015.5 Release" then you do not have the latest version.

The Canon 80D requires 2015.5 or v6.5 

Anthing less will not import from the 80D. (unless CR2s converted to DNG by the free Adobe DNG Converter)

Likes

Translate

Translate
Community Expert ,
Apr 02, 2016 Apr 02, 2016

Copy link to clipboard

Copied

Open Lightroom, click-  Help > About Adobe Photoshop Lightroom.

You should see   "2015.5 Release" near the top of the 'About' box.  What do you see?

If you do not see "2015.5 Release" then you do not have the latest version.

The Canon 80D requires 2015.5 or v6.5 

Anthing less will not import from the 80D. (unless CR2s converted to DNG by the free Adobe DNG Converter)

Regards. My System: Lr-Classic 11.5 Photoshop 23.5.1, ACR 14.5, Lightroom 5.5, Lr-iOS 7.0.2, Bridge 12.0.3, Windows-10.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 11, 2016 Apr 11, 2016

Copy link to clipboard

Copied

Thanks, this took care of my issue. I guess I thought I did an update when I updated through cc, but it did not do lightroom for some reason, only PS.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 11, 2016 Apr 11, 2016

Copy link to clipboard

Copied

I also bought the Canon EOS 80D and had the same problem by importing my CR2 raw files. I have updated Lightroom 6 this morning, but it does not work. I have still the version 6 and not the mentioned 6.5 version. When will Adobe give me the oportunity to download the 6.5 version? I bought Lightroom 6 just 2 weeks ago. DNG conversion is not the solution for me because I am loosing several Mbytes. Do I have to buy the version 6.5???

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 11, 2016 Apr 11, 2016

Copy link to clipboard

Copied

If you have just installed, it make take a little while for the CC Desktop app to see that there is a new update.

You can try right-clicking on the CC-App in the system notifications area, then select Check for App Updates.

You can also try signing out and back in of the CC App, by going to right-click Preferences, Signout.

You can also get the 6.5 patcher, from here: https://helpx.adobe.com/lightroom/kb/lightroom-downloads.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 17, 2016 Jul 17, 2016

Copy link to clipboard

Copied

Thank you.  Using the patch you supplied I was able to update to version 6.6 and I can now import canon 80d CR2

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 03, 2016 Apr 03, 2016

Copy link to clipboard

Copied

I had the same thing happen.  I did have the latest version, but there is a new update just for the latest cameras including the Canon 80D which I just purchased too.  I did the upgrade and now all photos are able to be imported. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 14, 2016 May 14, 2016

Copy link to clipboard

Copied

Hi,

I do not have CC. I bought Lightroom on CD a couple of months back. I have version 5.7.1  and after buying Canon 80D I cannot open CR2 files from my Canon 80D.

Since I bought Lighroom I expect there must be a way to open raw files from my 80D.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 14, 2016 May 14, 2016

Copy link to clipboard

Copied

Lightroom 5 is an old version, and will never be updated to support your camera.

You can either buy an upgrade to version 6, or use the free DNG converter to convert the CR2 files to DNGs that can be imported in Lightroom 5.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 14, 2016 May 14, 2016

Copy link to clipboard

Copied

wesox wrote:

Hi,

I do not have CC. I bought Lightroom on CD a couple of months back. I have version 5.7.1

Lightroom 6 was released about 13 months ago so you purchased and outdated version.  As said, you need Lr 6.5 for the 80d.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 14, 2016 May 14, 2016

Copy link to clipboard

Copied

Thank you Bob for your help.

This is what I was afraid of.

Usually Version updates are meant for adding new features. So if someone has an old version of a software, he/she would feel eager to upgrade and buy a new version as it has added features. However this issue is about lightroom 5 not even opening CR2 files on 80Ds. This is forcing me to now pay and upgrade. This is not fair, as CR2 files format have not changed. I feel like it is a monetisation strategy.

I will get in touch with them as I feel this is not fair for consumers.

Best.

Wes

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 14, 2016 May 14, 2016

Copy link to clipboard

Copied

This is not fair, as CR2 files format have not changed. I feel like it is a monetisation strategy.

Although all Canon raw files have the CR2 extension, it doesn't mean that the format is exactly the same for all cameras.

And Canon doesn't supply Adobe with information about new cameras, or supply them with sample files.

So Adobe has to buy every new camera on the market, examine the raw files, and then provide support for the camera in Lightroom in an update.

Whenever a new version of Lightroom is released, the previous version receives no more updates.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 14, 2016 May 14, 2016

Copy link to clipboard

Copied

Actually CR2 file format changes with every version of a new camera.  You can use the DNG converter from Adobe to convert your CR2 files to a format Lr5 will use but I personally DO NOT want to convert to DNG. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 14, 2016 May 14, 2016

Copy link to clipboard

Copied

It is exactly a monetization strategy.  Adobe has to pay their employees and other expenses with cashflow from somewhere.  Otherwise the current version would be something like  LR 1.45 and everyone would have paid only once and you probably wouldn't have been able to afford it, for Adobe to have made the same revenue of a pay-once-upgrade-forever version.

Did you purchase LR 5 over a year ago when it was still the current version, or did you purchase an obsolete version more recently from somewhere that wasn't Adobe due to some other reason, maybe minimum OS incompatibility with your computer?

You can get the DNG Converter from here, although if your OS is too old it won't run, either:

http://www.adobe.com/downloads/updates/

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 14, 2016 Aug 14, 2016

Copy link to clipboard

Copied

If you have Creative Cloud with Photoshop, just update Photoshop even if it says Lightroom has no updates, and it'll automatically update Camera Raw CC and solve the 80D issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 11, 2016 Sep 11, 2016

Copy link to clipboard

Copied

hello! i am having same issue now but the patch doesnt seem to be working?? my 5D4 files wont import and my version seems "stuck" on 6.1... HELP!!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 11, 2016 Sep 11, 2016

Copy link to clipboard

Copied

There are no Adobe products at the moment that support the RAW photos from a Canon 5D4. If your Lightroom is stuck at 6.1, that's probably because your operating system will not support later versions (OSX 10.9 is required for later versions of LR)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 11, 2016 Sep 11, 2016

Copy link to clipboard

Copied

ok, my osx is at 10.11! what then do i do if i cant get past 6.1??

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 11, 2016 Sep 11, 2016

Copy link to clipboard

Copied

Update to Lightroom 6.6.1 using these links

Keeping Lightroom Up-to-Date

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 11, 2016 Sep 11, 2016

Copy link to clipboard

Copied

hmmm still no luck! do i have to uodate to LR6??

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 11, 2016 Sep 11, 2016

Copy link to clipboard

Copied

Explain in a lot more detail what you did and what "still no luck" means.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 11, 2016 Sep 11, 2016

Copy link to clipboard

Copied

updated to LR6, and then did the patch update to 6.6 but when i go back into CC it still refers to version 6.1..

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 11, 2016 Sep 11, 2016

Copy link to clipboard

Copied

Lightroom version: CC 2015.6.1 [ 1083169 ]

License: Creative Cloud

Operating system: Mac OS 10

Version: 10.11 [6]

Application architecture: x64

Logical processor count: 4

Processor speed: 3.1 GHz

Built-in memory: 16,384.0 MB

Real memory available to Lightroom: 16,384.0 MB

Real memory used by Lightroom: 421.6 MB (2.5%)

Virtual memory used by Lightroom: 852.2 MB

Memory cache size: 0.0 MB

Maximum thread count used by Camera Raw: 4

Camera Raw SIMD optimization: SSE2,AVX,AVX2

Displays: 1) 2880x1800

Graphics Processor Info:

Intel(R) Iris(TM) Graphics 6100

Check OpenGL support: Passed

Vendor: Intel Inc.

Version: 4.1 INTEL-10.14.73

Renderer: Intel(R) Iris(TM) Graphics 6100

LanguageVersion: 4.10

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 11, 2016 Sep 11, 2016

Copy link to clipboard

Copied

So you don't have LR 6, you have Lightroom CC 2015.6.1, which is the current version. This is not 6.1, it is 2015.6.1

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 11, 2016 Sep 11, 2016

Copy link to clipboard

Copied

so now what?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

Save time with Adobe Express quick actions