Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Lightroom Classic crashes/freezes whole computer - Windows 10

Community Beginner ,
Jan 06, 2020 Jan 06, 2020

Copy link to clipboard

Copied

I applogise I accidentily posted this on the Lightroom community, forgetting lightroom classic is a different thing.

 

Recently, I upgraded my computer and after adding new hardware, lightroom classic started to crash, causing my whole computer to crash, the crashing appears to be kinda random. My mouse could still move around but everything slowly grinds to a halt (all windows functions stop to work until my mouse freezes, a window comes up to stop the process which is not responding, my wallpaper also becomes black), and my whole computer becomes unusable instantly, requiring a power cycle.

 

I changed my CPU, RAM and motherboard as described below:

Before:

Motherboard -> unknown but I can find out if required (intel I think)

CPU -> Intel i5-2500S @ 2.5GHz

RAM -> Unknown DDR3 memory.

 

After:

Motherboard -> Asus tuf b450m-plus gaming

CPU -> AMD Ryzen 3 3200g

RAM -> Corsair lpx vengeance 2x 8GB

 

Other hardware (unchanged):

GPU -> GTX 750 ti

 

Running Windows 10 64 bit

 

My OS is installed on a 120GB SSD (some adobe files are on this, such as creative cloud location), I also have a 2TB drive for games (which I play with absolutely no problem) and programs (where lightroom is installed), and 1TB drive for storing photos.

 

I'm pretty confident I have fully tried all the proposed fixes from the support page: https://helpx.adobe.com/uk/x-productkb/global/troubleshoot-system-errors-freezes-windows.html

I have installed all the latest drivers, GPU driver from GeForce experience, and others from https://www.asus.com/us/Motherboards/TUF-B450M-PLUS-GAMING/HelpDesk_Download/(updating BIOS, audio, LAN and chipset drivers). Checking others with device manager.

 

{Thread renamed by moderator}

TOPICS
Crash or freeze, Windows

Views

625

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Jan 08, 2020 Jan 08, 2020
After diagnosing hardware, then drivers, my computer went into a strange BDOS boot loop, so I just decided to reinstall windows as I had nothing to lose and wanted a fresh start anyway. Running lightroom on the new install didn't seem to fix the problem but then I removed my GPU and it worked.I decided to put the GPU back in and install the latest driver and I haven't had a problem with it so far (its been running for far longer than before), so I think the problem is fixed.

Likes

Translate

Translate
Adobe Employee ,
Jan 06, 2020 Jan 06, 2020

Copy link to clipboard

Copied

Hi Alfred,

 

Sorry to hear about Lightroom Classic freezing and crashing on the computer.

 

Have you tried turning off the GPU option from Lightroom's preferences? Go to Lightroom > Preferences > Performance tab > Uncheck "Use Graphics Processor" > Restart Lightroom.

 

You may also try creating a new user account with admin rights and test Lightroom on that account to see if it crashes or not. Please check the steps here: https://support.microsoft.com/en-in/help/4026923/windows-10-create-a-local-user-or-administrator-acc...

 

Let us know how it goes.
Regards,
Sahil

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 07, 2020 Jan 07, 2020

Copy link to clipboard

Copied

Thanks for the response,

I have tried creating a new account, with admin rights, and this doesn't seem to fix the problem. Disabling the GPU with or without using the new account still doesn't fix the problem either.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 06, 2020 Jan 06, 2020

Copy link to clipboard

Copied

Almost always, a system crash that requires a reboot is a hardware malfunction or a driver malfunction. You have to run diagnostics on all of your hardware (memory, cpu, motherboard, hard disk, cooling system). Also, it is possible that even though you have installed new drivers, either they somehow got corrupted, or they are the problem and an earlier version of the driver could solve the problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 08, 2020 Jan 08, 2020

Copy link to clipboard

Copied

After diagnosing hardware, then drivers, my computer went into a strange BDOS boot loop, so I just decided to reinstall windows as I had nothing to lose and wanted a fresh start anyway. 

Running lightroom on the new install didn't seem to fix the problem but then I removed my GPU and it worked.

I decided to put the GPU back in and install the latest driver and I haven't had a problem with it so far (its been running for far longer than before), so I think the problem is fixed.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 27, 2020 Dec 27, 2020

Copy link to clipboard

Copied

The problem is Lightroom 10.  I am having similiar issues after downloading Lightroom 10.  No problems before.  Tried all fixes mentioned.  The problem is Ligtroom 10.  Please fix it Adobe and stop blaming everything else!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 27, 2020 Dec 27, 2020

Copy link to clipboard

Copied

LATEST

“The problem is Lightroom 10. I am having similiar issues after downloading Lightroom 10. No problems before. Tried all fixes mentioned. The problem is Ligtroom 10. Please fix it Adobe and stop blaming everything else!!!”


We're not Adobe. We can't fix anything.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines