Lightroom won't let me remove broken photo

Explorer ,
Jan 15, 2019 Jan 15, 2019

Copy link to clipboard

Copied

So I've been having issues with this for a while now. I think this has been causing a majority of my issues with Lightroom. I have at least 1 broken photo that Lightroom Classic CaptionCall cannot do anything with. It won't load it, it has no information on it, it doesn't even have a file associated with it. When I try to remove it, nothing happens. I found it because I was having something scan through my photos methodically and it came up with an error (see attached screenshot) basically saying it couldn't do anything with that photo and thus couldn't proceed (since apparently it can't skip stuff).

So how can I remove this problem from my catalog so I can actually get stuff working again?

Screenshot 1: Error message

Screenshot 2: What the problem photo looks like in the library

I have covered my photos with gray boxes for my privacy.

Screen Shot 2019-01-15 at 11.13.15 PM.png

Screen Shot 2019-01-15 at 11.32.27 PM.png

Views

834

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , May 01, 2019 May 01, 2019
Just an update in case anyone was wondering how this turned out...I did contact tech support about this early on and they had me send them my catalog so they could remove the broken photos and send it back to me. That didn't work.I also created a new blank catalog and tried to Import From Another Catalog. That didn't work.I ended up having to create a new blank catalog then import all the photos directly from their masters. This worked largely because I did notice that the broken photos were not...

Likes

Translate

Translate
LEGEND ,
Jan 16, 2019 Jan 16, 2019

Copy link to clipboard

Copied

Wild guess: try File->Optimize Catalog (which you should be doing regularly anyway, either this way or at regular intervals when you make catalog backups, have you done this?)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 16, 2019 Jan 16, 2019

Copy link to clipboard

Copied

I do have it optimize every time it backs up, which is weekly. And I have manually optimized the catalog a couple times as well, hoping it would help. It hasn’t.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 16, 2019 Jan 16, 2019

Copy link to clipboard

Copied

Can you Export as Catalog all of the non-broken photos?

I think this has been causing a majority of my issues with Lightroom.

What issues?

Again, a guess, but the broken photo is a symptom of the problems, not the cause.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 16, 2019 Jan 16, 2019

Copy link to clipboard

Copied

The only real issues I’ve been having are with things that go through the entire library (or a large portion of it) in order. So whenever I try to sync with the cloud, it works just fine then gets stuck at one spot. Whenever I have face detection running, it works perfectly for most of the library then gets stuck at one photo. Same story with address lookup. Same story with a plug-in I got that scans for duplicates. They all work fine for a long time then get stuck at one spot. That’s why I’m thinking it’s this broken photo that is causing it: they all try to go through my library and work until they hit this broken photo, which they can’t get past.

Your idea about exporting as a new catalog without the broken photo(s) is brilliant! I will try it tonight!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jan 16, 2019 Jan 16, 2019

Copy link to clipboard

Copied

As it looks like there is a problem with LR Sync have you tried to use the 'Rebuild sync' data option?:

In preferences choose the Lightroom Sync tab, then hold down the ALT key and the 'Rebuild Sync Data' button will show.

(It will indicate rebuilding data for a while then restart Lightroom)

A previous sync operation may have been interrupted in some way to create a link to the phantom file.

Also recommend running a Catalog backup first.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 16, 2019 Jan 16, 2019

Copy link to clipboard

Copied

So in both screenshots, over on the left, in Duplicates, some sort of notice or warning that I cannot quite make out.

And why so much gray?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jan 16, 2019 Jan 16, 2019

Copy link to clipboard

Copied

Looks like the 'Smart collection' symbol to me. No error

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 18, 2019 Jan 18, 2019

Copy link to clipboard

Copied

I tried selecting all my photos then deselecting all the broken photos and exporting as a new catalog, but that didn’t work. It seemed like it was working fine, but at the very end it came back with an error “lightroom was unable to export the catalog due to an unexpected failure.“

and yes, I have also tried rebuilding the sync data.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 18, 2019 Jan 18, 2019

Copy link to clipboard

Copied

You might post a bug report in the official Adobe feedback forum: Lightroom Classic CC | Photoshop Family Customer Community . Include the first ten lines from the menu command Help > System Info.  Hopefully, they'll ask you for a copy of your catalog, and you might ask for an Adobe engineer to manually remove the zombie photo in the process. These kinds of catalog inconsistencies are fairly rare but usually an engineer can fix the catalog database. No promises here -- I don't work for Adobe.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 16, 2019 Jan 16, 2019

Copy link to clipboard

Copied

Also 2 requests.

Request 1, expand your Folder Panel so we can see any similar notices.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 16, 2019 Jan 16, 2019

Copy link to clipboard

Copied

Request 2, system information /Help/System Information/Copy/ Paste result in reply

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 01, 2019 May 01, 2019

Copy link to clipboard

Copied

Just an update in case anyone was wondering how this turned out...

I did contact tech support about this early on and they had me send them my catalog so they could remove the broken photos and send it back to me. That didn't work.

I also created a new blank catalog and tried to Import From Another Catalog. That didn't work.

I ended up having to create a new blank catalog then import all the photos directly from their masters.

This worked largely because I did notice that the broken photos were not, in fact, specific files. They were ghost photos inserted between working photos. I could tell because the file names of the photos would be in numerical order with a random ghost file thrown in but no numbers actually missing (like 12, 13, 14, X, 15, 16...). So basically, if this wasn't a new catalog and I had actually had a lot of edits and ratings and collections saved, I would've been completely screwed over and lost them all. The only reason it wasn't a very big deal was because it was practically a brand new catalog anyway, so I had very little customization in it. Just a huge library of photos.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 01, 2019 May 01, 2019

Copy link to clipboard

Copied

I just encountered this bug, which might be related to the corruption in your catalog: Lightroom: Importing after renaming a file can corrupt the catalog | Photoshop Family Customer Commu...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 01, 2019 May 01, 2019

Copy link to clipboard

Copied

Also, I'm surprised that Adobe couldn't fix your catalog. They probably didn't assign someone with sufficient skills.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 01, 2019 May 01, 2019

Copy link to clipboard

Copied

LATEST

I would think this should be reported as a bug, so others can see it, as well as Adobe developers can see it. Sending the catalog to someone in tech support may raise the issue, but filing an official bug report that somehow these "broken photos" appear in the catalog still ought to be the next step. Go to Lightroom Classic | Photoshop Family Customer Community​.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines