Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


P: Mask Panel does not appear in Full Screen Mode on Apple Silicon MacBook 14"

New Here ,
Nov 18, 2021 Nov 18, 2021

Copy link to clipboard

Copied

Just updated to Lightroom 11.01 tonight, on a brand new MacBook Pro 14" M1 Pro with 32GB of memory and 10 cores.

 

There are several bugs.

- BUG - The popup, for the completion of the import process (Smart Previews Created), does not pop-up onto the top of the main screen. It's like it's behnd the screen and not visible. I had to reduce the window size from Full-Screen to the smaller size before the pop-up became visible. Before I did this everywhere I clicked on the screen and the computer beeped, unhelpfully.

- BUG - Mask Panel does not pop out to show that you have created a mask and allow you to add a mask for the first time.

- BUG - When I hit the Mask Icon on the develop menu (the round shaped patch like thing all the way to the right.) to create a second mask after having already created a mask, the Mask Menu with it's various chocies about what kind of mask to create also does not show up. So you cant create one except by using a short-cut key.

 

After screwing around with this for a while, I found that these issues appeared to go away when I changed my window from Full-Screen mode back to the multi-window mode on my computer. I am also working with an external BenQ Photographers monitor and the same issue with being full screen or the smaller window showed up with LR displayed there.

 

System Details

 MacOS 12.01

  Model Name: MacBook Pro

  Model Identifier: MacBookPro18,3

  Chip: Apple M1 Pro

  Total Number of Cores: 10 (8 performance and 2 efficiency)

  Memory: 32 GB

  System Firmware Version: 7429.41.5

  OS Loader Version: 7429.41.5

 

Serious waste of my evening....

 

JP

TOPICS
macOS

Views

167

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 18, 2021 Nov 18, 2021

Copy link to clipboard

Copied

Ref Item 1, I cannot duplicate your results.

The Import dialog appears on top of the Lightroom interface - not behind it. 

 

Ref Items 2 and 3, I cannot duplicate your results.

The Mask panel behaves the same in Full Screen as it does in Windows version.

 

I am testing on the only M1 machine I have available a 2020 13 inch with Monterey and Classic 11.0.1

 

To confim these issues I would need repeatable steps to induce the bad behavior.  A video would be great if you can create on showing the issue.  Perhaps someone with a 14 inch 2021 can help us confirm. 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 18, 2021 Nov 18, 2021

Copy link to clipboard

Copied

Ok here it is. Before making this video, I've shutdown, and restarted. Confirmed that the MacBook is current - same as yesterday, confirmed that the version of LR is current, same as yesterday.

 

Bug occurs on open. Also the screen does not look like it's reading the default size of the MacbookPro screen when it opened the first time. But one bug at a time.....

 

JP

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

Thank you for the video. I so see what you are describing but am unable to replicate it.  

 

I've contacted another on the Lightroom Team with a comparable machine to yours and she was also unable to replicate the issue on her 14 MBP. We've tried both on the local display and an attached external.  At this point you may want to consider resetting your preferences to see if the issue persists.

 

This procedure works for both Lightroom Classic and Lightroom Desktop.

If you are using Lightroom Desktop it can change the location of your local storage. Please review this setting after resetting preferences. 

 

Reset Procedure:

1. Close Lightroom.

2. Hold down [Alt/Opt]+[Shift] while restarting Lightroom.

3. Overwrite the Preferences when prompted by the dialog.

4. Close Lightroom.

5. Restart Lightroom.

 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

Odd how that missing mask panel shows up in non full screen in a way that suggests it is popping under your right side panels. And how with it that far to the right that it does not dock with those panels, right above the masking adjustment panel.

 

In the not full screen, Drag the mask panel to the left. unhide your regular right side panel, can you drag the panel in question onto the right side? Does it the properly dock just above the masking adjustments panel?

 

Also, if you do not hide the right side panel, have it always show, does this behave differently?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

Will have to get off my rear end and test, mind you not on M1, but does a bug exists in the following scenario

 

You click on the mask tool.

You hide/close the right side panels

You drag the mask panel to the right

You unhide the right side panels

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 25, 2021 Nov 25, 2021

Copy link to clipboard

Copied

The new Masks panel in the upper right corner seems to constantly disappear. Is this a bug or is there a setting to prevent it from hiding? Or, is there a keyboard command to make it reappear?

 

I can understand if it temporarily hides itself while we draw with the brush. But, even after finishing a brush stroke the Masks panel never reappears.


The only way I can get the Masks panel to reappear is to switch back to the Finder or other app then return to LR.

 

masks panel.jpg

 

Macbook Pro 2013 - Big Sur - LR Classic11.0.1

Thanks for any help!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 25, 2021 Nov 25, 2021

Copy link to clipboard

Copied

Mine only dissapears if I exit masking.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 26, 2021 Nov 26, 2021

Copy link to clipboard

Copied

In a first step I would try to reset the Lightroom preferences.

https://www.lightroomqueen.com/how-do-i-reset-lightrooms-preferences/

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guru ,
Nov 26, 2021 Nov 26, 2021

Copy link to clipboard

Copied

You can also drag to "dock" it at the top of the right hand set of panels. There, it will collapse and expand itself as appropriate. So it won't be in its own separate window.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 26, 2021 Nov 26, 2021

Copy link to clipboard

Copied

LATEST

Thanks for all the help!

 

Seems pretty clear this is a bug. I also noticed the bug only happens when in Full Screen mode. And, if you Exit Full Screen then the Masks panel will hide/appear correctly. 

 

Docking the Masks panel to the side column works great too. Resetting my LR prefs didn't have any affect. 

 

Exit Full Screen.png

Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines