P: Desktop Memory leak on M1 Machines

24 Votes
Community Beginner ,
May 05, 2021 May 05, 2021

Copy link to clipboard

Copied

Hi!

 

I am a software developer. Recently, my Lightroom CC (version 4.2 - 20210301-0713) is very slow . A close look at activity monitor reveals that the app consumes too many threads and memory (attached photos) which freezes the app.

 

ScreenShot20210505at18.20.28-ee51c157-d137-49cb-a5e5-f8f251f9a9ed-1057135810.jpgScreenShot20210505at18.20.28-ee51c157-d137-49cb-a5e5-f8f251f9a9ed-1057135810.jpg

 

@Rikk Can you help me forward this to the development team?

 

Thank you so much!

Bug Fixed
TOPICS
macOS , Windows

Views

2.2K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jun 14, 2022 Jun 14, 2022
Greetings,   Updates to the Adobe Photography Products were released on June 13. The update contains a fix for this issue.  Please download and the latest version of your application via the Adobe Creative Cloud Application or your respective device app store. If you do not see the update (Mac and Win) you can refresh your Creative Cloud App with the keyboard shortcut [Ctrl/Cmd]+[Alt/Opt]+[ R ].    Note: App store availability can take several days for the update to appear and be available.   ...
Status Fixed

Votes

Translate

Translate
replies 115 Replies 115
115 Comments
Adobe Employee ,
May 05, 2021 May 05, 2021

Copy link to clipboard

Copied

This is not a commonly reported issue. 

 Have you performed a clean install? A preference file reset?

Clean Lightroom Install Procedure

Close Lightroom

Restart the computer

Use the Adobe Creative Cloud App to uninstall Lightroom

Restart the computer

Install Lightroom via the Creative Cloud App without launching any other programs.

Restart the computer

Launch Lightroom

Wait 5 minutes

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community Beginner ,
May 06, 2021 May 06, 2021

Copy link to clipboard

Copied

Hi Rick!

Have you performed a clean install? A preference file reset?

Oh yes. Last week, I reported an issue with export (https://feedback.photoshop.com/conversations/lightroom-desktop-cloudbased/lightroom-desktop-cloud-ba...). You suggested me to do a preference file reset. However, the problem (fail to export) resurfaced after a few days. A detailed investigation reveals that export failure is due to memory leak.

I have then performed a clean install ("Use the Adobe Creative Cloud App to uninstall Lightroom") and "Restart the computer". The problem, however, persisted (attached photo) 

ScreenShot20210506at20.16.19-699f3a96-b7c6-46d0-898e-aedb655c8436-758779019.jpg

=> To sum up, I have both performed clean install + preference file reset


This is not a commonly reported issue. 

This can be explained. Mac M1 has just released recently. Therefore very few users use Lightroom CC on Apple Silicon.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
May 06, 2021 May 06, 2021

Copy link to clipboard

Copied

This tells me you've done a preference reset but not a clean install. 

Clean Lightroom Install Procedure

Close Lightroom

Restart the computer

Use the Adobe Creative Cloud App to uninstall Lightroom

Restart the computer

Install Lightroom via the Creative Cloud App without launching any other programs.

Restart the computer

Launch Lightroom

Wait 5 minutes

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community Beginner ,
May 15, 2021 May 15, 2021

Copy link to clipboard

Copied

Hi @Rikk

So sorry for the late reply.

I performed the 9 steps as you have instructed (evidences: https://drive.google.com/file/d/1nRQiMjt__RpOuOshLRBdEe_hBYbujAfR/view?usp=sharing)

However, the problem persists. In particular:

- the app consumes 5 GB of memory when I double click on a photo (video:16:24)

- the app (Lightroom Helpers) consumes 5 extra GB of memory when I click export (video:17:08)

So in total, the app consumes 10 GB of memory when exporting a photo.

Please help!

----

P/S: This is the ID of the log file for which Adobe LogCollector Tool collected:

ScreenShot20210516at13.21.33-b989904a-7472-401f-8a6d-42f001900136-79169770.jpg

Votes

Translate

Translate

Report

Report
Adobe Employee ,
May 17, 2021 May 17, 2021

Copy link to clipboard

Copied

After exporting the photo and waiting 10 minutes or so without doing additional work in Lightroom, does it return the memory?

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community Beginner ,
May 29, 2021 May 29, 2021

Copy link to clipboard

Copied

This is actually a massive issue.  There is no way this isn't wide spread on M1 mac's.  I have 3 M1 mac's and they all do the exact same thing, this does NOT happen on my intel iMac.  As soon as you double click a photo the app goes from around 1GB of RAM used to 6-8GB without doing anything else.  It never releases the RAM until you close the app.  This basically makes the app completely unusable.  It's kind of insane this is even happening.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

@justinwadejones

I totally agree with you. That's what I and *JanPochyly experienced.

As a software developer, I discovered this bug a month ago. The architecture of M1 CPU is different. There must be a bug when they migrate the Intel-Lightroom to M1-Lightroom.

I hope @Rikk would soon report this problem to the development team. 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

One of the threads you link to is actually this thread-where you are the sole poster.  The other thread may be unrelated as it is a loupe-walk -not export/memory problem.

In any case, here is my test:

M1 Mac - 11.4 LrD 4.3 16 GB - files local on NAS

Open App: 1.49GB

Select 50MB raw file: 2.73 GB - memory usage is stable (not increasing)

Export: Peaks at 5.19 GB of memory

20 seconds later memory is at 2.81 GB

Select a different raw file- memory goes to 4.2 GB

Export: Peaks at 8.48 GB

Memory returns to 5.1 GB (Note that 2.86 GB of that is cached files - the two previous raw files held in memory in case you want to go back to them.

Select 3rd file - memory goes to 5.77 GB

Export - memory peaks at 7.12 GB 

Wait 20 seconds -Memory returns to 6.37 GB ( 2.96 is cached previous files)

After that it remains stable in the ~6.5 GB range where 3 GB is used to cache your last three images rendered.  That feels pretty reasonable to me for the primary app open to consume about 1/3 of ram.  I could never get it to consume 10 GB in my testing. 

I did restart and repeat the test and found memory remained in the 6 to 7 GB range after exporting several images. 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

I don't see the issue while exporting. I only see the memory leak after editing photos.  Edit a few photos and you will see it uses 12-16gb of RAM and never returns it until you close the app and reopen.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

@Rikk 

Thank you for reproducing the issue on your M1 Mac.

I got the very similar result as your:

Select a different raw file- memory goes to 4.2 GB

Export: Peaks at 8.48 GB

Memory returns to 5.1 GB (Note that 2.86 GB of that is cached files - the two previous raw files held in memory in case you want to go back to them.

But how about those users who use M1 MAC 8GB ram like me? You said the memory peaks at 8.48 GB. This is reasonable for you because you have a 16GB MAC and it consumes about 1/3 of your RAM. But it is not reasonable for me because 8.48GB is 100% of my RAM and it freezes my laptop the moment I click export.

To sum up:

1. When I subscribe for the app, Adobe tells me it can run on my 8GB M1 Mac but in reality it is not true for me, for @justinwadejones M1 MAC, and for *JanPochyly M1 Mac.

2. LightRoom CC on Intel chip consumes about 3GB of RAM during usage (reported by @justinwadejones) while M1 LightRoom CC consumes about 6-7 GB of RAM during usage (your report)

3. Lightroom is the most expensive photo-editing app on the market and I am now bound with a 1-year subscription contract.

Please help!

Votes

Translate

Translate

Report

Report
LEGEND ,
Jun 26, 2021 Jun 26, 2021

Copy link to clipboard

Copied

Can I just report that I am experiencing the same thing with Lightroom Classic? Twice now in the past week I have had a message that my M1 Mac has run out of RAM, with Lightroom being the culprit (despite being idle in the background for over a day in each case)

Screenshot20210626at14.04.31-dfe68745-cd0d-4c48-81ed-1155ea6cf3c3-210852216.png

Votes

Translate

Translate

Report

Report
LEGEND ,
Jun 28, 2021 Jun 28, 2021

Copy link to clipboard

Copied

I'm having the same problem on an Intel (3.6GHz 8-Core i9) Mac.   Have had to reboot my machine basically every time I use LightRoom

Votes

Translate

Translate

Report

Report
LEGEND ,
Jun 28, 2021 Jun 28, 2021

Copy link to clipboard

Copied

*xtalman38 I should add - trouble seemed to begin with latest update to Big Sur MacOS 11.4

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jun 29, 2021 Jun 29, 2021

Copy link to clipboard

Copied

*nickminers

Hi Nick!

Thanks for reporting. Currently, the issue is happening on at least 4 M1 mac: mine, @justinwadejones, *JanPochyly, and your. There is no solution available at the moment. The only thing we can do is to ask Adobe to release a fix soon.

For further support, please contact Rikk, Adobe administrator, https://feedback.photoshop.com/users/5f5f265b6880ca11de7cd433

Regards,

Minh

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jun 29, 2021 Jun 29, 2021

Copy link to clipboard

Copied

Hi!

Your problem is quite different from four of us as it happened on Intel Lightroom. In this case, please contact

Rikk, Adobe administrator, https://feedback.photoshop.com/users/5f5f265b6880ca11de7cd433 or Adobe helpx https://helpx.adobe.com/support.html for further support 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jul 01, 2021 Jul 01, 2021

Copy link to clipboard

Copied

Is there anyone on this thread who does not have an 8 GB M1 Mac?

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jul 01, 2021 Jul 01, 2021

Copy link to clipboard

Copied

@Rikk  yes I have a 16GB MacBook Air. 

Votes

Translate

Translate

Report

Report
LEGEND ,
Jul 01, 2021 Jul 01, 2021

Copy link to clipboard

Copied

@Rikk I have a 16GB MacBook Pro 

Votes

Translate

Translate

Report

Report
LEGEND ,
Jul 01, 2021 Jul 01, 2021

Copy link to clipboard

Copied

@Rikk  

I'm on an Intel (3.6GHz 8-Core i9) 27" iMac (2019)

Votes

Translate

Translate

Report

Report
LEGEND ,
Jul 06, 2021 Jul 06, 2021

Copy link to clipboard

Copied

@Rikk This is a very real issue. I am experiencing upwards of 300% CPU usage on Adobe Lightroom Helper when exporting, enhancing, or editing. Lightroom has been very slow and affects the rest of my system's speed as well.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jul 10, 2021 Jul 10, 2021

Copy link to clipboard

Copied

Hello,

Since the past few days, exports in Lightroom has been running very slow on my Apple M1, tasks that would take 10 minutes and now taking 1hr+ moreover, deleted pictures from the filmstrip now appear as ghosts(previously would be erased) and export as well. Exports in the "Large" preset would be a bit faster but still slow and still have the issue of deleted pics being exported.

Grateful if someone can help.

Regards,
Bg.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jul 10, 2021 Jul 10, 2021

Copy link to clipboard

Copied

Hi @brady

I have filed a report months ago regarding to this issue https://feedback.photoshop.com/conversations/lightroom-desktop-cloudbased/lightroom-desktop-memory-l...

Please make a comment at the post and mention the moderator so Adobe knows the seriousness and prevalence of the issue.

Thank you!

Minh

Votes

Translate

Translate

Report

Report
LEGEND ,
Jul 10, 2021 Jul 10, 2021

Copy link to clipboard

Copied

@dualeoo

Thanks Minh, will do! 

Votes

Translate

Translate

Report

Report
LEGEND ,
Jul 10, 2021 Jul 10, 2021

Copy link to clipboard

Copied

Hello,

Since the past few days, exports in Lightroom has been running very slow on my Apple M1, tasks that would take 10 minutes and now taking 1hr+ moreover, deleted pictures from the filmstrip now appear as ghosts(previously would be erased) and export as well. Exports in the "Large" preset would be a bit faster but still slow and still have the issue of deleted pics being exported.

Grateful if someone can help

Votes

Translate

Translate

Report

Report