Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


P: (iOS): Upright - Copy, Paste not working properly

3 Votes
Community Beginner ,
Feb 07, 2020 Feb 07, 2020

Copy link to clipboard

Copied

I am a real estate photographer and will often shoot 300+ photos a day. When editing I use the "Auto transform" tool under the upright selection in the geometry tab to straighten my photos. Then problem occurs when I copy and paste this setting (under any condition) the actual transforms get copy and pasted, and not the "Auto transform" selection. Its very frustrating when editing 300+ photos because each photo has to be selected, and the geometry section has to be reset and reset to auto in order to work. This was never an issue on Lightroom Classic. Its quite frustrating, since I got myself an iPad Pro to do work on the road, but this has made the program useless for this type of work. 

Bug Fixed
TOPICS
iOS: iPhone, iPadOS

Views

119

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Oct 26, 2021 Oct 26, 2021
Greetings,   The Max 2021 Photography products updates have been released and include remedies for this topic.  The updates will be rolling out worldwide, October 26 and 27, 2021. If you do not see the updates in your Creative Cloud Desktop app, you can refresh the apps to see if the updates are available in your region.  The keyboard shortcut to refresh is [Cmd/Ctrl] + [Opt/Alt] + [ R ].    Note: iOS and Android updates may take up to a week to appear in your App Store.   Thank you for your pat...
Status Fixed

Votes

Translate

Translate
27 Comments
Adobe Employee ,
Feb 07, 2020 Feb 07, 2020

Copy link to clipboard

Copied

I am not able to duplicate what you are seeing.

  1. Create Auto in Geometry Panel
  2. Copy Settings - Check Geometry - expand and turn off Manual Transforms - return to Copy list
  3. Click Check to complete
  4. Go to new image
  5. Expand Transform - note Auto is off
  6. Paste
  7. Auto is now on and no manual transformations appear. 
  8. Note picture appearance - turn off Auto
  9. Reapply Auto - image is same as step 7. 
If I missed a step let me know but it appears to be working correctly here.
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 07, 2020 Feb 07, 2020

Copy link to clipboard

Copied

Hi Rikk, 

Thanks, I am doing the same thing and it does indeed bring "auto" over to the next photo but it doesn't automatically straighten the image. It seems to be copying the transforms from the previous photo. In order to get it to work, after your steps listed, I have to turn auto off then turn it back on. It does the same in the desktop version as well. Lightroom classic worked just fine when I tried to do this. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 08, 2020 Feb 08, 2020

Copy link to clipboard

Copied

Is it possible to send me two files that exhibit this problem as I cannot reproduce?
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2020 Feb 08, 2020

Copy link to clipboard

Copied

I have attached three photos. The first Photo I just applied the upright auto. Then copy pasted only upright and took off manual transform. Pasted it into the second one. Then you will see it’s messed up. Then the third one I shut auto off and put it back on and it is fixed.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2020 Feb 08, 2020

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2020 Feb 08, 2020

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2020 Feb 08, 2020

Copy link to clipboard

Copied

I have asked two friends to try it on Lightroom mobile on their iPads and they have the same problem.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 08, 2020 Feb 08, 2020

Copy link to clipboard

Copied

I see the same thing with these two images.
-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2020 Feb 08, 2020

Copy link to clipboard

Copied

I put them side by side. Its easier to see them like that.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 08, 2020 Feb 08, 2020

Copy link to clipboard

Copied

Just so that we are clear on this: when I said “I see the same thing” I confirmed that I see what you see (so no reason to answer by putting the images side by side).
-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2020 Feb 08, 2020

Copy link to clipboard

Copied

sorry! I misunderstood!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 11, 2020 Feb 11, 2020

Copy link to clipboard

Copied

Do you see the issue in the new version of Lightroom released yesterday?
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 11, 2020 Feb 11, 2020

Copy link to clipboard

Copied

I do, It has been there for a long time. Even on the desktop CC cloud version. I finally decided to mention it because it hasn’t been fixed. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 12, 2020 Feb 12, 2020

Copy link to clipboard

Copied

Would you be willing to share with us two original files that show the problem so I can attach them to our engineering investigation?
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 12, 2020 Feb 12, 2020

Copy link to clipboard

Copied

Absolutely. Thanks a lot for taking the time to help! 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 12, 2020 Feb 12, 2020

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 12, 2020 Feb 12, 2020

Copy link to clipboard

Copied

Are these the originals (JPEGS) or did you start with raw files?
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 12, 2020 Feb 12, 2020

Copy link to clipboard

Copied

I start with JPEG. They are compressed because of the 2 GB limit on the upped here. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 12, 2020 Feb 12, 2020

Copy link to clipboard

Copied

The issue happens with RAW files as well though. When I was shooting weddings in the summer, I was running into the problem when trying to use a workflow with CC on my iMac. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 12, 2020 Feb 12, 2020

Copy link to clipboard

Copied

Which file should I use for Copy and which for Paste?
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 12, 2020 Feb 12, 2020

Copy link to clipboard

Copied

I copied the first one on to the second one

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 12, 2020 Feb 12, 2020

Copy link to clipboard

Copied

On Lightroom Desktop 3.2

I brought in the first renamed as "Copy From". I brought in the second renamed as "Paste To". 

On Copy From:
  • Go to Geometry and select Auto on the Upright pulldown.
  • Go to [...] and select Choose Edit Settings to copy.
  • Uncheck all.
  • Expand Geometry and check Upright. 

Go to Paste To:
  • Paste Settings.
  • Export Image as Paste to-2
  • Go to [...] and Reset to Original
  • Apply Geometry Auto from the Panel
  • Export Image as Paste to-3

Open Photoshop.
  • Load Paste to-2 an Paste to-3
  • Copy Paste to-2 to a layer above Paste to-3
  • Set Paste to-2 to Blend Mode Difference
  • Screen turns black - images are identical
Appears go be working correctly and as designed.

Photos have synced to Lightroom Mobile iOS.
  • Select Copy From
  • Apply Auto in Upright
  • Copy Settings an uncheck all except Geometry > Upright
  • Swipe to Paste To
  • Paste settings
  • Export as Paste To-4
  • Send to Photoshop with two previous files from above
  • File is different than Paste To-2 and Paste To-3
Summary:

Desktop is working as expected although you said above it wasn't.
iOS is not working as expected.

I will be writing a bug against LrM iOS for this. 

Thanks for the files and the reproducible case. 
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 29, 2020 Nov 29, 2020

Copy link to clipboard

Copied

Hi Rikk,

Has this issue with the upright been fixed on the mobile app? I also use the app for real estate, and this feature is incredibly essential for my field. Additionally, having the ability batch edit all of them using the feature make my editing process exponentially quicker. 

I have also tried to save the auto-upright

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 30, 2020 Nov 30, 2020

Copy link to clipboard

Copied

*Jonbarrino 

It hasn’t been fixed. I check every update lol it does it on the program for Mac as well. Not on classic though. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 30, 2020 Nov 30, 2020

Copy link to clipboard

Copied

At the top of the page, it says "Acknowledged". When fixed it will change to "Solved" and a message will appear in this space.

I do not have an ETA I can share at this time. 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines