Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Lightroom CC: Syncing stuck forever

New Here ,
Nov 11, 2017 Nov 11, 2017

Copy link to clipboard

Copied

All-new lightroom CC seems to get stuck syncing the catalgue to the cloud. There is a long thread here with dozens of users with the same problem.

Lightroom CC: Syncing stuck forever | Photoshop Family Customer Community

Anyone who can help here?

BR

Markus

Views

49.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Nov 19, 2017 Nov 19, 2017
you can find a fix for the problem here: Lightroom CC: Syncing stuck forever | Photoshop Family Customer Community In the My Photos area in the left pane, select the All Photos album. Switch to the Square Grid view (), which displays photos as equal-sized thumbnails along with their flag status, sync status, and rating. While holding down the Alt key (Win) or Option key (Mac), click the cloud icon (). Lightroom CC now displays only those photos that it's trying to sync. Press Ctrl+A (Win) or Co...

Likes

Translate

Translate
New Here ,
Nov 12, 2017 Nov 12, 2017

Copy link to clipboard

Copied

Honestly, this is getting ridiculous.

Plenty of people with this problem, I'm seeing my uploads going from ~2670, down to 2500 and then back to over 2.6k.

No idea of what's going on, no way of seeing logs and it's been over a week now.

Any news about this?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 29, 2018 Oct 29, 2018

Copy link to clipboard

Copied

So I've not found the fix, but I've found a way around it for now until they fix the newest update. If you go to your Creative Cloud and scroll down to Lightroom Classic. Where it say's 'Open' select the arrow next to this, and select 'Manage' and 'Other Versions'. Install the version before the most recent - for me this was 7.4 and I've found that all my photos are syncing in order and not freezing. It's not ideal that we can't have the newest update, but I don't think there is much to be missing out on but avoiding a rubbish bug and hours of stress!

Hope this helps everyone else!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 14, 2017 Nov 14, 2017

Copy link to clipboard

Copied

I am having the same problem and getting more and more frustrated by it

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 18, 2017 Nov 18, 2017

Copy link to clipboard

Copied

Same issue here. I tried to write a bit about my symptoms and some errors that I see here Initial sync gets stuck

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 19, 2017 Nov 19, 2017

Copy link to clipboard

Copied

you can find a fix for the problem here: Lightroom CC: Syncing stuck forever | Photoshop Family Customer Community

  1. In the My Photos area in the left pane, select the All Photos album.
  2. Switch to the Square Grid view (), which displays photos as equal-sized thumbnails along with their flag status, sync status, and rating.
  3. While holding down the Alt key (Win) or Option key (Mac), click the cloud icon (). Lightroom CC now displays only those photos that it's trying to sync.
  4. Press Ctrl+A (Win) or Command+A (Mac) to select all the photos displaying in the grid and then do any of the following:
    1. Delete the selected photos by choosing the Edit > Delete option and then add the photos in Lightroom CC again.
    2. Apply a flag or a star rating to selected photos.

The syncing issue should now be resolved. To check the sync status, click the cloud icon () at the upper-right corner.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 29, 2019 Jan 29, 2019

Copy link to clipboard

Copied

Questions and Corrections to the above instructions

1, "All Synced Photographs" is in the Catalog on the left panel

2, Where is the cloud icon?

3, What does the cloud icon look like, the sample photos are missing.

Corporate photographer based in Calgary, Canada and Oviedo, Spain. Making portraits, architectural, industrial and advertising photography for national and global brands.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 07, 2019 Nov 07, 2019

Copy link to clipboard

Copied

Alt-click against the only cloud I see doesn't do it - it just shows me the normal drop-down from that cloud, the normal cloud storage etc..

 

I also tried filtering by sync status, but there's nothing there and still it always says 2 syncing.  (If I add more, they will sync and it will come back to 2)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 24, 2020 Apr 24, 2020

Copy link to clipboard

Copied

Did you every get a resolution to this problem? I have the same issue, but with 9 photos not syncing and no way to find out which nine is the problem. Alt+Cloud Icon on a PC must be an old solution because it results in the normal drop down.  Also when filtering only "Syncing", I get the "Oh no! A black hole. No photos matching these filters were found."  This "9 photos syncing issue" has been going on about 2 weeks now.  When I add new photos, they appear to sync okay to the cloud, but the other nine are still stuck.  Maybe 9 photos syncing is the new normal for me, but it is really aggrevating that I can't find out which ones they are.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 24, 2020 Apr 24, 2020

Copy link to clipboard

Copied

Wow, I dont remember what finally resolved it, but my Lightroom is no longer stuck syncing.  Sorry.  Maybe it eventually resolved itself, or maybe I uninstalled and re-installed Lightroom.  I'm not sure, but I think it was the latter.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 25, 2020 Apr 25, 2020

Copy link to clipboard

Copied

Thanks for the response.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 29, 2020 Apr 29, 2020

Copy link to clipboard

Copied

I'm having this issue at the moment - stuck on one photo syncing. Tried the suggestions above but no change. Any other things I can try?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 06, 2020 May 06, 2020

Copy link to clipboard

Copied

Hi - I am still having that issue with LR cc always saying it is syncing 37 photos, but none of the above suggestions help ???

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 12, 2020 May 12, 2020

Copy link to clipboard

Copied

I have one stuck phone and holding down alt does not do anything... 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 27, 2020 May 27, 2020

Copy link to clipboard

Copied

I have been looking for a solution to this for several weeks - have had 198 syncing photos for about 10 days. Moved some folders around then and went from about 40 to 198. Holding down ALT does nothing.

Besides all that, where is this Cloud icon that the old solution refers to?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 28, 2020 May 28, 2020

Copy link to clipboard

Copied

Read more posts and finally found a suggestion that worked!! YMMV.

This was posted by johnrellis:

In LR Classic "try going to Preferences > Lightroom Sync, holding down Alt / Opt, and clicking the Rebuild Sync Data button that magically appears.  This should not change your existing synced collections or their contents, just rebuild the existing relationship between LR Classic and LR CC. "

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 11, 2020 Jul 11, 2020

Copy link to clipboard

Copied

Oh my goodness, it FINALLY WORKS. I have deleted all my synched data (unfortunately) to fix this. My LR classic has tried to sync 19.000 photos and got stuck in a loop for weeks. Yeah! Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 09, 2020 Nov 09, 2020

Copy link to clipboard

Copied

This worked for me! Thank you very much for finding this hidden setting.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 13, 2021 Jan 13, 2021

Copy link to clipboard

Copied

I did this and found the problem photo (same problem: metadata), but the photo doesn't show up anywhere in my "All Photos" section or my deleted section. It's a non-existant photo. What do you think I should do??

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

Same problem here as well - pulled the log, searched through my entire library, was unable to find it; then searched my computer and every other place I could think of - still unable to find anything.

 

Now sitting with my computer, phone and ipad all spinning trying to sync this mysterios photo... would really appreciate this being looked into.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 15, 2020 Nov 15, 2020

Copy link to clipboard

Copied

Your suggestion didn't work for me, however, it did help find a solution to my problem. A similar secret option trick works in Lightroom CC. 

  1. With Lightroom CC open go to Preferences -> Account
  2. Hold down Alt/Opt and click the Mini Report option that appears near the bottom of the right panel
  3. Generate the report, download and open the HTML file in a browser, DiagnosticLog.html
  4. Scroll down to 'Syncing and Error Assets' section

 

Under that section you might see a table with rows. For me I had just one row which showed a file with a sync status of 'NeedsMetadataUploaded'

 

I searched for the filename in my Lightroom CC, deleted it and then readded it and that solved my problem.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 16, 2020 Nov 16, 2020

Copy link to clipboard

Copied

Thank you very much - I will give this a try

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 28, 2020 Dec 28, 2020

Copy link to clipboard

Copied

Late to the party pon this, but I've had the same problem (in Lightroom CC).  Finally solved it by doing the above (holding down the clous icon and finding the offending picture) BUT that didn't completely work.

 

Last step was to go to the deleted files folder in (in Lightroom CC) and then "delete forever" the offending picture.

 

Cleared it up immediately!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 06, 2021 Feb 06, 2021

Copy link to clipboard

Copied

Stumbled into this problem again, my steps described didn't work this time around but the steps SeanSE9B described above worked.

 

How is this not solved yet by Adobe? The size of this thread and the repeated updates you'd think they'd have rolled a fix for this by now. Given the subscription model and how they manage to vendor tie you in I'm not surprised by the lack of action on these bugs. Which is an utter disgrace.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 03, 2021 Mar 03, 2021

Copy link to clipboard

Copied

Might be a stupid question but if I delete these photos forver, where are they saved?  I am afraid of losing photos and I am not entirely certain how the saving works when uploading photos across multiple devices directly into Lightroom.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines