Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Lightroom CC - Unable to setup wf rtmfp notify pipe

Community Beginner ,
Dec 23, 2017 Dec 23, 2017

Copy link to clipboard

Copied

Hello.

Every time I launch the latest version of Lightroom CC I get:  Unable to setup wf rtmfp notify pipe.  I have uninstalled, reinstalled and rebooted and the problem is still there.  Graphics processor acceleration is disabled as well.

Windows 10 64 bit

32 gb ram

2 tb free disk space

I do not use a vpn.

Can anyone assist.

Thank you

Views

2.8K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jan 17, 2018 Jan 17, 2018
Hi David,We've never seen this issue before, and unfortunately we cannot reproduce the behavior you've described. Something you could try is adding an exception to the Windows firewall for the Lightroom CC executable: Open the Windows Firewall from the control panel. Click on the “Advanced Settings” link on the left pane. Windows Firewall with Advanced security UI opens up. Click on the “Inbound Rules” option. On the  left pane, click on “New rule”. Under “Rule Type” select the option “Program” ...

Likes

Translate

Translate
Dec 27, 2017 Dec 27, 2017

Copy link to clipboard

Copied

Hi DavidJBier,

Do you get to open the Lightroom CC app when you see the error "Unable to setup wf rtmfp notify pipe"? Could you please help us with the exact error message and a screenshot of the error pop-up menu?

Thanks,

Akash

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 27, 2017 Dec 27, 2017

Copy link to clipboard

Copied

Hello.

When I launch the app, I get the normal Lightroom splash screenImage2.jpg, then a spinning blue circle in the middle of the screen.  I get the error message if as soon as I hit Edit - Preferences.

Image1.jpgImage3.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Dec 28, 2017 Dec 28, 2017

Copy link to clipboard

Copied

Please restore Lightroom preferences to default. See How to set Lightroom Classic CC preferences

Let us know the outcome.

~Akash

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 28, 2017 Dec 28, 2017

Copy link to clipboard

Copied

Hello.

I reset the preferences as you stated and I am still getting the exact same error message as shown in the above screen shot.    I have all the latest Windows 10 updates and graphic drivers installed.  The only thing I noticed is my desktop (the one that cannot launch Lightroom CC) is an HP Envy 700 series with an AMD A10 processor but my laptop has no problem launching Lightroom CC but has an Intel I7 processor.  Both machines have the most up to date drivers.   Lightroom Classic works fine on both my laptop and desktop.

Thank you

David

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 28, 2017 Dec 28, 2017

Copy link to clipboard

Copied

There is a similar topic where the user had a VPN running.

Could not run script: OrganizeModuleFactory.lua ...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 28, 2017 Dec 28, 2017

Copy link to clipboard

Copied

Hello

As I stated in my original post, I do not use a VPN.

Thank you,

David

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 04, 2018 Jan 04, 2018

Copy link to clipboard

Copied

Hey David J Bier​,

I've passed this thread along to engineering. So far, the multiple cases that we've received with this issue have all been successfully solved by turning off VPN, so it's strange that you're seeing this and do not have VPN on.

We'll update here if we have a workaround to suggest.

Thanks,

Melissa

Melissa Rios, Product Manager, Community Experience & Platform | Adobe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 05, 2018 Jan 05, 2018

Copy link to clipboard

Copied

The issue "Unable to setup WF RTMFP Notify Pipe" occurs when Lightroom CC is unable to initialize communication between the various Lightroom CC processes that run simultaneously on a user’s machine.

Some users experience this issue when using a VPN because certain VPN services block all local network traffic that uses IPv6 (a type of internet protocol used by Lightroom CC for local process communication). Most VPNs can only route IPv4 network traffic, and so many VPNs disable IPv6 to ensure that no IPv6 traffic leaks out over your normal internet connection when you are connected to the VPN.

Unfortunately, some VPNs have implemented this leak protection in such a way that it also erroneously blocks local network traffic that uses IPv6. This can prevent any app that uses IPv6 locally, even when not communicating with outside servers, from working properly.

For users that encounter this issue and are using a VPN, there are two workarounds:

  1. Disable the VPN
  2. If it exists, then disable "IPv6 Leak Protection", or any similarly worded setting, in the VPN preferences. With this setting disabled, LrCC should work just fine.

For users that are not using a VPN, it's likely that they have some other software installed that is preventing IPv6 network traffic. Likely candidates are firewall and anti-virus software. If you have such software installed, I'd advise you to disable it and then try launching LrCC. If this fixes the problem, then you will need to add some sort of exception to the anti-virus software for LrCC.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 12, 2018 Jan 12, 2018

Copy link to clipboard

Copied

Hello.

This is the only way I can get Lightroom CC to work:

1).  I turned off the Windows 10 Firewall (no third party firewall or anti-virus is used)

2).  Launched Lightroom CC and I get a collage of my photos

3).  Closed Lightroom CC

4).  Turned Windows firewall back on

5).  Launched Lightroom CC - and I get the same collage of my photos. 

I do NOT use a VPN !!!!!!!  

When I reboot, I have to go through this process again. 

David

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 17, 2018 Jan 17, 2018

Copy link to clipboard

Copied

Hi David,

We've never seen this issue before, and unfortunately we cannot reproduce the behavior you've described. Something you could try is adding an exception to the Windows firewall for the Lightroom CC executable:

  1. Open the Windows Firewall from the control panel.
  2. Click on the “Advanced Settings” link on the left pane.
    Windows Firewall with Advanced security UI opens up.
  3. Click on the “Inbound Rules” option.
  4. On the  left pane, click on “New rule”.
  5. Under “Rule Type” select the option “Program” and click next.
  6. Select the option “This Program path”.
  7. Browse to the Lightroom CC executable location:
    C:\Program Files\Adobe\Adobe Lightroom CC\lightroomcc.exe
  8. Select the option “Allow the connection”.
  9. Click Next, do not change any option here and click Next again.
  10. Specify a name for this rule.
  11. Click Finish.

If the above does not resolve the issue, you could try repeating these steps for lightroomcchelper.exe which is found adjacent to the Lightroom CC executable.

Hopefully this resolves your issue.

Thanks,

Jeff

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 18, 2018 Jan 18, 2018

Copy link to clipboard

Copied

Thank you Jeff.

I did exactly what you said and it still doesn't work.  The only way I can get Lightroom CC to work is:

Turn the Windows 10 firewall off,

Launch Lightroom CC (works fine),

Close Lightroom,

Turn on the Windows firewall,

Launch Lightroom CC (works fine).

I guess we need to file this under things that make you say Hmm.

David

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 18, 2018 Jan 18, 2018

Copy link to clipboard

Copied

Darn, I'm sorry to hear that. There's a slight chance that your Windows 10 firewall is blocking IPv6 traffic; potentially you could check the "Outbound Rules" section in the firewall settings to see if there's a rule that's explicitly blocking IPv6. This would be tedious and it's only a theory, but you might be able to find an offending rule and disable it.

The next version of LrCC (1.2) moves away from IPv6 for local network communication, so it's possible that it will fix this issue for you. I really hope you stick with LrCC and try out the next version when it's released. It just might do the trick.

Sorry again for the frustration. Thanks,

Jeff

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 21, 2018 Jan 21, 2018

Copy link to clipboard

Copied

Hi Jeff! I'm experiencing the same problem using my company's laptop (with VPN and Firewall). However, I don't have enough permissions to change the settings.

When is the next version of LrCC (1.2) due to be launched?

Can I switch to Lightroom Classic in the meantime?

Thanks!

Vitor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 27, 2018 Jan 27, 2018

Copy link to clipboard

Copied

Hello.

I installed the Lightroom CC update and I still get the same issue. 

David

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 29, 2018 Jan 29, 2018

Copy link to clipboard

Copied

Lightroom CC 1.2 ( the version with the potential fix for this issue ) has not yet been released. Though we're hoping to release it soon, we are taking the time to make sure it's right.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 10, 2018 Feb 10, 2018

Copy link to clipboard

Copied

LATEST

I reinstalled the software as admin, added the exception to the Firewall and I'm running it as admin as well.

This fixed the issue even in v1.1

(however, using the software I discovered I can't live without my folder structure, therefore will try to change my subscription to Classic CC)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines