Huion H640P doesnt work in photoshop

Guest
Jan 08, 2018 Jan 08, 2018

Copy link to clipboard

Copied

i recently got the product and it works well except in photoshop. When i open photoshop it doesn't recognize the pen. I am also confused with setting up the driver, i declared the buttons and the sensitivity. Do i import or export config. I have had this product for over a week now and its frustrating.

If you can help me that would be great, thank you in advance

Views

37.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

New Here , Nov 29, 2018 Nov 29, 2018
I have found the solution for Windows 10. It's quite simple really. Microsoft recognises the table for their Windows Ink space but the Huion software gets confused and thinks Photoshop is part of the Windows ink suite. To make it work: On the tab Press Keys on the Huion application. Just untick: Enable Windows Ink and presto! Photoshops now works perfectly.I hope this can help you too

Likes

Translate

Translate
New Here , Oct 16, 2020 Oct 16, 2020
Thanks much. Problem solved in 5 seconds. A correction to @untamedstreet comment - Press "Digital pen" on Huion application and follow the steps of @untamedstreet comment.  Cheers

Likes

Translate

Translate
LEGEND ,
Jan 08, 2018 Jan 08, 2018

Copy link to clipboard

Copied

See if this search helps any.  I do not have one.

https://forums.adobe.com/search.jspa?place=%2Fplaces%2F1413024&q=Huion

JJMack

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 06, 2018 Nov 06, 2018

Copy link to clipboard

Copied

did you find a solution? I'm having the same problem  with the same tablet and nothing I do fix this
please help

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 29, 2018 Nov 29, 2018

Copy link to clipboard

Copied

I have found the solution for Windows 10.

It's quite simple really. Microsoft recognises the table for their Windows Ink space but the Huion software gets confused and thinks Photoshop is part of the Windows ink suite.

To make it work:

On the tab Press Keys on the Huion application. Just untick: Enable Windows Ink

and presto! Photoshops now works perfectly.

I hope this can help you too

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 29, 2018 Nov 29, 2018

Copy link to clipboard

Copied

CC version of Photoshop use INK by default.  Old CS Photoshop versions have no INK support they only use Wintab API for pen support.   So I configure my Wacon tablet not to use ink with  Photoshop and I configure Photoshop CC version  to use Wintab API. So Pen pressure work with both CS versions and CC versions of Photoshop on my machine. All others Application use Windows INK    Photoshop uses WinTab api.

JJMack

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 26, 2020 Jan 26, 2020

Copy link to clipboard

Copied

what do you mean by Untick?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 22, 2020 Feb 22, 2020

Copy link to clipboard

Copied

Unclick. If you see a square with a tick or check mark click to remove. I had to run the tablet software in admin mode and it worked.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 06, 2020 Oct 06, 2020

Copy link to clipboard

Copied

THANK YOU SO MUCH !!! ❤️

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 16, 2020 Oct 16, 2020

Copy link to clipboard

Copied

Thanks much. Problem solved in 5 seconds.
A correction to @untamedstreet comment - Press "Digital pen" on Huion application and follow the steps of @untamedstreet comment. 
Cheers

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 04, 2022 Feb 04, 2022

Copy link to clipboard

Copied

LATEST

This method is absolutely correct
Bravo

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 10, 2021 Apr 10, 2021

Copy link to clipboard

Copied

i dont have a keys option on my huion app pls help

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 18, 2021 May 18, 2021

Copy link to clipboard

Copied

In windows 10, open pen & windows link setting, (or you can search, just type ink) turn on "let me use my pen as a mouse in some apps". 

Hope its work 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 15, 2021 Dec 15, 2021

Copy link to clipboard

Copied

omg this works! Thank you so much! I was so close to giving up 😭

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 13, 2021 Sep 13, 2021

Copy link to clipboard

Copied

The solution doesn't work for me, any other possible fixes?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 01, 2022 Jan 01, 2022

Copy link to clipboard

Copied

I found a solution, I made an account just to post this I hope this helps someone. 

 

First I would try other peoples solution of unchecking "windows ink"

 

If that doesnt work someone else reccomended "In windows 10, open pen & windows link setting, (or you can search, just type ink) turn on "let me use my pen as a mouse in some apps". "

 

That still did not work for me, the solution I found: I was opening photoshop through a saved file I was working on, once I actually just opened photoshop by its self it worked fine, and then I just opened the file while in photoshop.

 

Hope this helps someone.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines