Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Mojave and PS2021. After disconnecting monitor, workspace turns green!

New Here ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

Coincidental with disconnecting a TV monitor ( HDMI to Thunderbolt) my Photoshop document becomes overlain by a bright green layer. If I scroll I can see my work layer flickering beneath the green. The only solution is to uninstall PS, download it again -not keeping preferences as this perpetuates the problem- and reinstall it.

Has anyone any ideas? In the middle of a large project so don't appreciate having to do this. I'm guessing that disconnecting the Thunderbolt cable causes the problem. Do I have to turn of TV, then turn off computer, then disconnect Thunderbolt cable every time I have finished with the monitor? Grrrrrrr

TOPICS
Problem or error

Views

716

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , May 28, 2021 May 28, 2021
Can you try this: Go to Preferences > Technology Previews and check "Deactivate Native Canvas". Then close and restart Photoshop. Dave

Likes

Translate

Translate
Adobe Community Professional ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

What is your computer specs - this sounds more like hardware than software. 

Computer brand/version/age, OS, HD space, RAM, Graphics Card, Vram

Kevin Stohlmeyer Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

Well I thought so too but Apple said more like software problem.

Macbook Pro late 2015, Mojave, capacity 500 GB available 43.49 GB,

Memory 16 GB 1600 MHz DDR3;

Graphics AMD Radeon R9 M370X 2 GB Intel Iris Pro 1536 MB

Can't find VRAM

Meant to say that even when PS workspace green, thumbnails look fine in welcome window and in Finder

Apple suggested using HDMI to HDMI cable but in middle of project so will try later and hope I don't foul things up again.

Thanks for your reply

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

Can you try this:

Go to Preferences > Technology Previews and check "Deactivate Native Canvas". Then close and restart Photoshop.

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

Hi,

Thanks for your reply. I will do as you suggest and see if that works.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

Hi again,

Photoshop is working fine, having been reinstalled. I will try to recreate the problem tomorrow and then deactivate native canvas and restart and see if that clears it. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 29, 2021 May 29, 2021

Copy link to clipboard

Copied

Well, I followed your advice, checked 'deactivate native canvas' and quit Photoshop. Opened up a PSD, used HDMI to HDMI and no problem - even disconnecting cable while TV on. Tried with suspect HDMI to Thunderbolt and still no problem - even disconnecting cable while TV on. It may be that the Mac is just in a Saturday morning good mood but it seems your advice has worked.... for now anyway.

Thanks so much. I will try it for a few days and if no problem I will tick your answer as correct.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 29, 2021 May 29, 2021

Copy link to clipboard

Copied

LATEST

It sounds positive. A bit of background that might explain why.

Adobe are updating the core graphics functions in Photoshop. This is driven by the operating systems of Apple and Microsoft in which the old Open GL/Open CL functions are being removed in the case of Apple, or deprecated in the case of Microsoft. This means that the graphics functions that have worked for years must be rewritten to use Metal and Direct X. At the same time, Adobe are sensibly updating those core functions to deliver the additional speed we require to handle the very large files of today.

 

Preferences>Technology previews>Deactivate Native Canvas switches Photoshop to use the previous GPU functions. So that checkbox is a workaround if you run into issues but if that resolves the problem for you it will still be worth raising it at the link below which is monitored by Adobe developers and state that the switch resolved the issue. That way the developers can look for the cause in the new code.


https://feedback.photoshop.com/photoshop_family

 

Dave

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines